Link to home
Start Free TrialLog in
Avatar of blackjack2003
blackjack2003

asked on

WINSTLE Error creating Office 07 msi ODSERV.exe not found

I'm trying to create an Office 07 MSI package using Winstle.  I have completely clean fresh install of Windows XP sp2 in which I run my before scan.  Install Office 07 and run my after scan.  All is well until it converts the NAI file to MSI.  I receive this error every time I've tried this.

Error processing service odserv: service executable file ODSERV.EXE not found in package.

And no MSI is created.  Winstle is not installed on my "clean pc" and no drives are mapped.  Any ideas or suggestions?
Avatar of Shakti109
Shakti109


The problem relates to your chosen path. You should never, ever, use a setup-capture utility to "watch" an .MSI based installation (which all versions of office are).  
The setup capture is picking up the Microsft Office Diagnosis Service.

The problem with using a setup-capture utility on an .MSI install (whether it be from WISE, installshield, or other) is that it picks up base windows components (even the windows installer service itself) and then tries to include them in the install, the result is that when you go to try to use the installer you are now overlaying windows system components (often in a piecemeal fashion) which can leave the system so unstable a re-image is necessary.

Unfortunately, the main KB article that people find when the are learning about creating installer packages is : http://support.microsoft.com/kb/257718.

This article has some good information and omits nearly all of the warnings, pitfalls and problems, one of which being re-capturing an .MSI, here are some of the reasons :

Repackaging a MSI package is against Microsoft Best Practices.
If you make changes to a MSI package, vendors will no longer provide support for that product.
If you repackage a MSI package, the component codes within the MSI package are not retained and, hence, future patching or upgrades will not work.
Traditionally, repackaging tools ignore the MSI-specific data in the registry. This results in an incomplete package.

What are you trying to do with this install?
Automate it on a target? (this can be done with command line switches called against the office install).
Change the install properties? (this can be done with command line switches OR a transform)

Give me an idea as to what you are after with this install and we will get you moving in the right direction.
Avatar of blackjack2003

ASKER

All I'm trying to do is to have MS Office 2007 deploy using Group Policy..This wasn't an issue with 2003 because it already had a prepackaged MSI install file for the entire suite.  However Microsoft notes that 07 can't be installed through the packaged MSI files and that the setup.exe must be used.  I have created a custom installation with the OCT and the only way I think it'll work without using SMS is to implement a logon script that will initiate the Setup.exe w/ the customized installation.  I'm not real familiar with GPO's but from what I can see the only way I can add a software install package is through an MSI file which is what stemmed this process.  Any advice or guidance would be much appreciated!
ASKER CERTIFIED SOLUTION
Avatar of Shakti109
Shakti109

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Thanx for the great info...The script works if I run it manually..it starts up the office install and it's installed properly without any interaction.  However when I added it to my GPO it pulls an error when my test machine starts up.  Says Line : 3, Char: 1, error: the system cannot find the file specified. code: 80070002, source: null...

little background on my setup...in my GPO I have the script attached to the startup scripts under the windows setttings for Computer Configuration as I want this to be machine based rather than user based...my actual script is in the default scripts dir...(domain/sysvol/domain/policies/reg key/machine/scripts/startup)...

I'm not familiar with logon scripts so this is a cloudy area to me...like I mention I know the script works cause I can click it manually and office will install properly..just doesn't wanna run through this GPO so I must have configured something wrong..

So you more or less used the script as I described above? If thats the case then yup, based on the error you reported it is unable to locate the share.

This could be a permissions problem on the share at which you have the script/config stored.

Check the share permissions for the location at which you have stored the files, as a test, add the "Everyone" group and give it read access and then try again.

I thought that was what the problem was and I've been playin around with my permissions but I'm going to create a brand new share with new permissions on a diff server and start from scratch with the folder structure.  I'll let ya know how it turns out.
Ok that did work...It run at startup, in its own window..looks like all is well til I logon and nothing is there..not even the base office12 folder lol...I do have a custom OCT file in my updates folder and am using the config.xml however that may be setup wrong...here's a current paste of my config file..


<Configuration Product="ProPlus">

      <Display Level="Basic" CompletionNotice="yes" SuppressModal="yes" AcceptEula="yes" />
      
      <Logging Type="standard" Path="%temp%" Template="Microsoft Office Professional Plus Setup(*).txt" />
      
      <PIDKEY Value="xxxxxxxxxxxxxxxxxxxxxxxxxxx" />

      <USERNAME Value="Nalpac" />
      
      <COMPANYNAME Value="Nalpac" />
      
      <INSTALLLOCATION Value="%programfiles%\Microsoft Office" />
      
      <LIS CACHEACTION="CacheOnly" />
      
      <DistributionPoint Location="\\giga64\office07" />

      <OptionState Id="WORDFiles" State="Local" Children="force" />

      <OptionState Id="EXCELFiles" State="Local" Children="force" />

      <OptionState Id="PPTFiles" State="Local" Children="force" />

      <OptionState Id="OUTLOOKFiles" State="Local" Children="force" />

      <OptionState Id="SHAREDFiles" State="Local" Children="force" />

      <OptionState Id="TOOLSFiles" State="Local" Children="force" />
            
</Configuration>
I have noticed that the install bar only goes about halfway across and then it instantly finishes with a successful installation notice..I'm looking through the install log file right now to see if there's any errors that could be causing this..

When the install gets to a certain point and then finishes near instantly, it is usually a sign of a "rollback" that has been induced by a failure of some part of the installation.

You are definately on the right track with looking through the installation log, that will tell you where and how it failed (which caused the rollback).

If you need help decyphering the install log just come back and I'll be happy to help troubleshoot that.
http://www.corrupteddatarecovery.com/File-Data/ODSERV.EXE-Office-Diagnostics-Service-Microsoft-Corporation-12.0.4518.1014.asp


HERE show you how to download this file. You can put it under C:\Program Files\Common Files\Microsoft Shared\OFFICE12\