Link to home
Create AccountLog in
Avatar of spanishPC
spanishPC

asked on

change DHCP time out

Hello Experts!,

I'm running Windows XP SP2 on acer laptop with Intel 3945ABG Wireless adaptor.
This adaptor has DHCP enabled and an alternatie static IP configuration for my house and work configurations.

The problem i want to fix is the looooooooong time i have to wait at startup, above 60 seconds, while the computer takes or not the IP address on a not-dhcp server enviroment.

If fact, at house i got the IP in a few miliseconds and the system boots properly, but at work, where THER IS NOT DHCP SERVER and configuration should be taken static/manual, boot takes above 60 seconds.

I have seen there are some post regarding the solution, but as im not a premiere user, i cannot see the answers.

Can anyone tell me how to change this client DHCP timeout issue?
Avatar of johnb6767
johnb6767
Flag of United States of America image

Try looking at this registry key....

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\TcpMaxConnectRetransmissions
http://technet2.microsoft.com/WindowsServer/en/library/895c4bfa-1feb-4c16-a0c0-69e342b542261033.mspx?mfr=true

And this page also. In some instances, you have to use both registry values....

TcpInitialRTT
http://www.microsoft.com/technet/prodtechnol/windows2000serv/reskit/regentry/58802.mspx?mfr=true

Possibly that one as well....
Dont know if it always works though....
Avatar of spanishPC
spanishPC

ASKER

That could be a solution, cause default values are 30 and 2...that gets 60 seconds.
Im going to set them and reboot, and see if works

thanks ;)
        I dont think that this is a DHCP issue. This is a DNS related issue. Make sure that you dont have a static Primary DNS server ip entered in TCP/IP properties of your network interface card.
        *In your TCP/IP properties of your NIC, tick the circle next to "Obtain DNS server adress automatically". Then right click your network connection and click repair.
         
         
IT IS a dhcp related issue
Im sorry guys, but TcpMaxConnectRetransmissions and TcpInitialRTT regisry keys didnt solve the problem.
keep working together and possibly well find the solution

(there are some posible solution on expert exchange seach parameters "dhcp time out win xp", but as im not a premium user, i cannot see the solution)

¿can anyone help?
IT IS NOT a dhcp issue nor a DNS issue. It's simply that windows first tries to query a DHCP server and if none answer for some time, then it uses the alternate config.

I couldn't find any way to change the default timeout (quite long). It might be hardcoded in windows or  hidden somewhere in the registry, but maybe the easiest thing to do is to install a dhcp server at work. There are free dhcp server for unix and windows (e.g. http://tftpd32.jounin.net/), besides hardware boxes.
By the way, what laptop is it?
ASKER CERTIFIED SOLUTION
Avatar of lbertacco
lbertacco

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
acer 5672, could you check on expert exchange database for "dhcp time out xp"?, because there are some articles related to this, but i cannot see them, cause im not premier

thanks!
I searched for dhcp time out xp but I couldn't find any answer suggesting how to change the time out. Just proposing alternative method such as using specific utilities (netswitcher, etc...) to change the network config. As I said, since there is no documented tcpip parameter for this timeout, I doubt you will find how to change it. You might try asking to Microsoft.
I'll left this question open, until talking with M$
Anyway it's probably much easier to add a dhcp server (software or hardware) to the office network than to get some useful info from MS :-)
i have asked on M$ communities, by phone they tell me they dont give that kind of support
¿what kind they give..."next, next, next"?
Quoting Experts-Exchange help section (https://www.experts-exchange.com/help.jsp#hi54)
The correct answer to some questions is "you can't do that"...is correct, and deserves the points.
Ibertacco,
   You are correct, I guess with all of the responses to this question, in reading thru it I lost track of the question and missed your answer.
  I will change my recommendation.

Riteheer
EE Cleanup Volunteer