"The memory could not be read" errors

I have a Dell Inspiron 9400 Laptop running XP SP2.
I keep getting an error (2-3 times per day) saying
"xxxxxx Application Error"
"The instruction at "0xXXXXXXXX" referenced memory at "0xXXXXXXXX". The memory could not be read."
For example::
"ATI video bios poller client: Ati2evxx.exe - Application Error"
"The instruction at "0x7c911639" referenced memory at "0x008b3005". The memory could not be read."
OR
"wmplayer.exe - Application Error"
"The instruction at "0x078f0807" referenced memory at "0x08ee68c28". The memory could not be read."

Help anyone!!
Brian
LVL 1
bleggeeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

BillDLCommented:
It would appear, although not all error messages accurately reflect the real problem, that you may have some problems with your physical memory ie. RAM Modules.

Probably the best place to start off is to download a memory diagnostics program and run it to either prove or disprove this assumption.

I use the Microsoft Memory Diagnostics:
http://oca.microsoft.com/en/windiag.asp
http://oca.microsoft.com/en/mtinst.exe

Running "mtinst.exe" prompts you to either:
- create a bootable floppy that will run the memory tests in its own environmeny
- extract an *.ISO file that can be loaded into most CD-Burning applications to create a bootable CD that will do the same.

Either way, press the "T" key when it runs to toggle the extended tests on, and leave it to complete all the tests.  It will keep running if left, and you can just power off when done (takes many hours).  Take a note of any errors reported.

It is usually best to test out one memory stick at a time if the system allows you to do this.
jeepstyx22Commented:
I had a similar problem with 2 Compaq laptops.  During shutdown i would get the same error.  Go to the ATI download site, http://ati.amd.com/support/driver.html, and download the latest drivers and software, this solved my problem.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
beatifiedCommented:
I have also had a similar problem try updateing windows completely there is an issue with thier drivers that requires the DOTNET framework 2.0 or something like that. I'm not sure if DOTNET is what you need thats why I say just update windows completely doing so will be good upkeep on your computer as well as fix your problem (hopefully)

Do both critical and non critical updats to make sure you get it.

Good luck
Get a highly available system for cyber protection

The Acronis SDI Appliance is a new plug-n-play solution with pre-configured Acronis Software-Defined Infrastructure software that gives service providers and enterprises ready access to a fault-tolerant system, which combines universal storage and high-performance virtualization.

bleggeeAuthor Commented:
Stand by ... I did Bill & Jeep's suggestions (mem checks out ok) but am having a little PC side-issue ... I'll post back as soon as I can do beatified's Windows Update idea & let you all know ...
bleggeeAuthor Commented:
Thx ... all good suggestions. For me, the updated ATI drivers seem to fix it.
BillDLCommented:
Thank you Brian, glad you got the problem fixed
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.