Turn off offline files via registry setting

In windows xp pro, is there a registry setting that can be used to simply turn off offline files?

Thanks,

Bill
w_marquardtOwnerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sirbountyCommented:
Try this...

Start->Run->cmd /k reg add hklm\software\microsoft\windows\currentversion\netcache /v enabled /t reg_dword /d 0

That will disable them...
0
w_marquardtOwnerAuthor Commented:
Almost there. It works.. Yea! but I need to be able to run it from a batch file so that I can include it in a series of other updates that I'm doing at the same time. It also needs to run silent as well. The prompt whether to add the value messes up the process.

For my own education, I've been using a tool to modify the registry in a Windows Batch type mode (Macro Scheduler). When I open a command line window and run the code you provided, it works. When I put it into a batch file, it doesn't. Looking at the code, it looks like it's writing a '0' into the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\NetCache,Enabled Dword.

While I can write directly into the registry with Macro Scheduler, when I write a '0' into it does change it correctly, but offline files are still enabled. Can you tell me what else is going on in the code so I can learn what I'm missing?

Thanks,

Bill
0
sirbountyCommented:
Add this in a batch...doesn't get any more silent then this... ;^)

@reg add hklm\software\microsoft\windows\currentversion\netcache /v enabled /t reg_dword /d 0 /f

And you are correct on what it does...the added /f is to 'force' the change...
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

w_marquardtOwnerAuthor Commented:
Hmm... Still not working (now not at all).

When I put the code into the batch file and add a pause command just to see what it did, it does show that 'the operation completed successfully.' If I check the registry setting, the dword has changed to '0' but the check mark is still in the Enable offline files box (tools / folder options / offline files (tab)). If I log off and log back on, it's still on.

Any idea on why this isn't working as expected (or what I'm doing wrong with the code?)

Thanks,

Bill
0
sirbountyCommented:
I have a good idea...you are running this with limited user permissions?

HKLM must be modified using an Admin account...
0
w_marquardtOwnerAuthor Commented:
Nope, I'm both local and domain admin on the machine.
0
sirbountyCommented:
Perhaps it's in HKCU as well?

http://www.microsoft.com/technet/prodtechnol/windows2000serv/reskit/regentry/92773.mspx?mfr=true details this setting further.  Could it be that it's also set in group policy?
0
w_marquardtOwnerAuthor Commented:
I've always seen it work at the local machine level and not per user. I'll check on the machine when I'm in next (tomorrow). It might just be a hinkey machine. I'm going to add the change to the registry in my script and hope for the best. Worst case, I turn it off by hand (annoying but some projects are only worth so much time). At least it's only a 100 computers and not a 1000 <g>.

I'll assign the points after I check on the HKCU and update the answer here for future reference.

Thanks,

Bill
0
w_marquardtOwnerAuthor Commented:
One more think. Do you think the value '0' should be an integer or a string? Maybe that's my problem?

Thanks,

Bill
0
sirbountyCommented:
No, it's definitely a dword value on that one...
0
w_marquardtOwnerAuthor Commented:
Sirbounty,

Sorry about the long delay on this. This was one of many clients I work with and I got pulled off the project. I just got back to it and it works fine on every computer except my test computer. Go figure...

Thanks for all the help.

Regards,

Bill
0
rosekiCommented:
You could actually create a policy that would accomplish the same thing, but allow you to turn it on and off for specific groups.  We turn it on for Laptop users and off for Workstation users; based on machine groups.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.