SBS cant receive external email

I have SBS 2003 set up using 2 NIC one for the internal domain, and one which connects to a modem for the BB connection. Currently i am able to send and receive emails internally, and i can send emails to an external address fine, but when i try and send them from my external address xxxxxx@virgin.net to xxxxxx@mydomain.com it doesnt get there and is usally returned to my external address with a faliure notice, i have tried everything i can think of and still got no where, i have also tried to re set the name servers, MX records etc (but may have made them worse!)

PLS HELP!
cjwdentAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

zappafan2k2Commented:
What does the failure notice say?  That should give you a starting place.  If it says, could not make connection, then I would guess the problem lies with your firewall/port forwarding.  Can you telnet to port 25 of your public IP address from outside your network?

If you're worried about your DNS settings, try this on a windows box ourside your network:

nslookup
set type=MX
yourdomain.com
    -> this should return the public host name of your mail server
set type=A
the-host-name-returned-above.com
   -> this should return your public IP address

or go to www.dnsreports.com and use their tools.
0
cjwdentAuthor Commented:
Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Chris>nslookup
Default Server:  BelkinModem.Barnwell
Address:  192.168.2.1

> set type=MX
> msdpuk.net
Server:  BelkinModem.Barnwell
Address:  192.168.2.1

Non-authoritative answer:
msdpuk.net      MX preference = 10, mail exchanger = mx0.123-reg.co.uk
msdpuk.net      MX preference = 20, mail exchanger = mx1.123-reg.co.uk

mx1.123-reg.co.uk       internet address = 195.224.48.126
mx1.123-reg.co.uk       internet address = 195.224.48.125
mx1.123-reg.co.uk       internet address = 195.224.48.124
mx1.123-reg.co.uk       internet address = 195.224.48.123
mx1.123-reg.co.uk       internet address = 195.224.48.121
mx1.123-reg.co.uk       internet address = 195.224.48.120
mx1.123-reg.co.uk       internet address = 195.224.48.119
mx1.123-reg.co.uk       internet address = 195.224.48.118
mx1.123-reg.co.uk       internet address = 195.224.48.117
mx1.123-reg.co.uk       internet address = 195.224.48.116
mx1.123-reg.co.uk       internet address = 195.224.48.115
> set type=A
> mx1.123-reg.co.uk
Server:  BelkinModem.Barnwell
Address:  192.168.2.1

Non-authoritative answer:
Name:    mx1.123-reg.co.uk
Addresses:  195.224.48.123, 195.224.48.121, 195.224.48.120, 195.224.48.119
          195.224.48.118, 195.224.48.117, 195.224.48.116, 195.224.48.115, 195.22
4.48.126
          195.224.48.125, 195.224.48.124


That is what i get when i do an NSLOOKUP from out side the network, and when i telnet to prot 25 i get the message :

220 msdpuk.net Microsoft ESMTP MAIL Service, Version: 6.0.3790.1830 ready at  Sa
t, 17 Mar 2007 20:40:35 +0000


which i presume means yes i can telnet.
0
zappafan2k2Commented:
It looks to me like your problem is with DNS then.  
FYI, your e-mail would first be tried at mx0.123-reg.co.uk, since that has a higher priority.  It seems that your e-mail is being sent to a hosting company.  I tried manually sending an e-mail to info@msdpuk.net using one of the servers, but they must use greylisting or some other spam prevention method that always returns a temporary error.

Anyway, what you really need to do is set up:
1. a hostname (possibly mail.msdpuk.net?) that points to your public IP address
2. a single MX record that points to the hostname in step 1

You'll want to remove the other MX records, because if for some reason your server is unavailable, the sender's server would try the other hosts.
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

cjwdentAuthor Commented:
zappafan2k2,

that makes sense, how do i go about setting up a host name, is that something i do on my sbs box or with the ISP provider or hosting company?
0
zappafan2k2Commented:
From the information I was able to acquire, you will need to talk to someone at Pipex (your domain service provider).  They manage the DNS for your domain.  Tell them what you are looking to do.  
0
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
In reviewing the whois for msdpuk.net, it looks as though you registered the domain with TUCOWS.com.  If this is correct, then you most likely need to modify your DNS Zone file there with the information that zappafan2k2 recommended above.

Jeff
TechSoEasy
0
zappafan2k2Commented:
TechSoEasy:

I saw that too, but the NS servers are
msdpuk.net name server ns.123-reg.co.uk.
msdpuk.net name server ns2.123-reg.co.uk.

so DNS is handled by those servers.  Are they under Tucows' control?
0
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Well, I don't really know... but cjwdent should... since msdpuk.net already points to the SBS.  Wherever that got configured is where the MX record and HOST record goes.  :-)

Jeff
TechSoEasy
0
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
I should point out, however, cjwdent... that you've apparently configured your SSL certificate on your SBS for www.msdpuk.net.  This is fine if you plan on hosting a business card type public web site on your server and if you want users to be able to access Remote Web Workplace (http://sbsurl.com/rww) via https://www.msdpuk.net/remote.  But if you choose to use a different host name (such as mail.msdpuk.net) to access the server for RWW or OWA you'll need to rerun the Configure Email and Internet Connection Wizard to recreate the SSL certificate with the proper host name.

Jeff
TechSoEasy
0
cjwdentAuthor Commented:
Hi, thanks for the comments.

The RWW will really just be another backup way of gaining access to the server in an emergancy from somewhere else, our employees will have access to the www.msdpuk.net/exchange to gain access to there email when not at work.

With regard to the hostname, the domain is registered with http://www.123-reg.co.uk/ but i not entirly sure what the hostname will do or why i need to do it, i have emailed them to check whether it is them i need to do this with, but as of yet have heard nothing back!

Thanks for your help so far.

Chris (cjwdent)
MSDP
0
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
RWW does not grant access to the server for employees, by the way.  It provides them access to THEIR desktops, as well as email and the companyweb.  They get a different interface than you would.  See http://sbsurl.com/rww for details.

What will the Hostname do?  Well, it will allow you to create an MX record.  You need to do both because an MX record can ONLY point to a hostname not an IP address.  And YES, it is them that you would do this through... just log into your control panel on their site and as you'll see by their help pages:
http://www.123-reg.co.uk/support/trouble.pl?id=44&switch=DNS/NameServer%20Management&from_faq=1
http://www.123-reg.co.uk/support/trouble.pl?id=46&switch=DNS/NameServer%20Management&from_faq=1

You can create an A Host record and an MX record right there.

Jeff
TechSoEasy

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cjwdentAuthor Commented:
Jeff,
I have created a new MX record and i think an A host record, I have emailed you experts-exchange email address, with a screen shot of what i have done, not 100% it is correct!

Thanks.

Chris

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.