Solved

Can't get laptop in peer to peer network, PATH in not accessible (but can with IP address) - Help

Posted on 2007-03-17
40
448 Views
Last Modified: 2013-11-21
Help,

We are having problems with a peer to peer network. It consists of three Windows XP home PC's (one a desktop and two laptops).

Never the fastest network it it now seems one of the laptops will no longer participate.

We now get the network message:
 
"PATH is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.
The network path was not found."


This is what happens when you navigate to the laptops from Network Places and then choosing the workgroup name. Also the laptop itself cannot select other computers in the network (although they are listed in there as a name sometimes).

I have found that using IP addresses of PC's in the network one can see other PC and the PC's associated files. For example, if I type from the Run command, \\192.168.1.102 (the IP of broken non communicating laptop) we can see its files. vice versa also worked, on the bad laptop using IP addresses of other PC's, but not using names.

One concludes this is because of some problem converting names to IP addresses, but that has still not helped fix it.

Some things we have tried after looking through these pages:
*dnsnetwork flush
*Disabled IEEE authentication which was enabled on bad laptop when checking
*CA anti virus package was installed. there is no firewall component with it so no need to disable.
*Disabled Windows firewall
* Rerun networking wizard, renamed workgroup on all PC's even. (all to the same new name).
* Checked windows/system32/etc/hosts files for unusual entries (no entries other then normal ones
*many, many reboots.
* pinging IP seems to be OK
* Uninstalled QOS service and then re-installed it again as made no difference (don't actually no what QOS is but tried anyway)

All to no avail, we are left with the same problem.
Please, please help!
0
Comment
Question by:afflik1923
  • 17
  • 12
  • 4
  • +2
40 Comments
 
LVL 28

Expert Comment

by:burrcm
Comment Utility
How are the machines physically connected. Are you sharing an internet connection? Where is this plugged in?

Chris B
0
 

Author Comment

by:afflik1923
Comment Utility
OK, yes,

Broadband connected to router (wireless but in this case was trying it all with cables). when I first visited I did suspect a faulty router (does this ever happen to give this error) but as all the PC's / laptops can connect to the interne fine whether wireless or wired I assume the router is fine.

My laptop attached fine to the network and was able to access files from the other two PC's on the peer to peer network, but again not on the offending laptop.

Any ideas?
0
 
LVL 28

Expert Comment

by:burrcm
Comment Utility
Potential clashes here. Only one of the units must provide dhcp facilities. I run a similar setup. A speedtouch modem and d-link 4 port wireless router. I have the speedtouch running the show plugged into a lan port of the router, so the router only acts as a pass through. This works fine to wireless and wired clients. The key point is don't have them both trying to manage the network.

Chris B
0
 

Author Comment

by:afflik1923
Comment Utility
No the DHCP is fine. The router has a DHCP server built in and all of the clients get their address via DHCP. (well accept one with a manual static IP address, but things don'g work even when this is turned off).

So the setup of DHCP is fine. All the PC's get an internet connection.
0
 

Author Comment

by:afflik1923
Comment Utility
Actually reading back maybe I should make lkayout clearer.

Internet connection to cable modem. Modem to (cheap unbranded) wireless router that has DHCP capabilities.

All PC's via either ethernet or wireless are attaced to that router (which is a DHCP server).

Typical setup I beleive.
0
 
LVL 28

Expert Comment

by:burrcm
Comment Utility
Sounds OK. When you do an ipconfig does the router ip appear as the default gateway?

Chris B
0
 

Author Comment

by:afflik1923
Comment Utility
yes
0
 
LVL 28

Expert Comment

by:burrcm
Comment Utility
Don't know then. It sounds like it should be working. You could try a TCP/IP reset. This works -

http://www.xp-smoker.com/freeware.html

Chris B
0
 
LVL 4

Expert Comment

by:Shplad
Comment Utility
You disabled Windows firewall...on all 3 machines?

If so, and nothing is blocking packets, then it could likely be a name resolution issue.
Try enabling NBT (NetBios over TCP/IP). In theory it is no longer necessary, (not when you're using
UNC pathames. such as IP addresses.
In reality, however, it is often still necessary for things like network browsing (i.e. using My Network Places instead of a UNC pathname) and print serving.

Network Connections-->Highlight appropriate NIC card-->Properties-->Internet Protocol-->Properties-->
     General Tab-->Advanced-->WINS Tab-->Enable Netbios over TCP/IP

Alternatively, it could be a permissions issue.
Do you have accounts set up for each of the other client computers? If so, have you logged in to each account on the host PC in question in order to set up a preliminary trust relationship? That is sometimes a tedious, but necessary step.

Are the browser service and server service started on each of the PCs?

http://www.chicagotech.net/accesserrors.htm

This page summarizes it more thoroughly than any I've seen:
http://www.chicagotech.net/accesserrors.htm



Shplad
0
 
LVL 4

Expert Comment

by:guardsman85
Comment Utility
First, for a peer-0to-peer network, default gateway should not affect peer-to-peer connectivity.  It's only needed to access an outside network (such as the Internet).

Second, you mentioned that the router will do DHCP, but have you verified that the addresses the hosts have are being given to them by DHCP and they're not just defaulting to a private IP address?  What are the IP addresses and subnet masks of your hosts (use ipconfig at the command prompt to check)?

Third, since you know you can reach the PC's with the IP address you might try clearing/refreshing the ARP cache.

At the command line type:
netsh (press enter)

At the netsh> prompt, type:
interface ip delete arpcache (press enter. should display OK)

Type:
exit

Ping each of the other two computes using:
ping 111.222.333.444 (substitute the proper IP address, of course.  what this does is updates the arp table with new information about the IP address and host name.)

Repeat this process on each computer.
0
 
LVL 4

Expert Comment

by:guardsman85
Comment Utility
EDIT:  Sorry, I misread a prior comment.  I see that you've already verified that DHCP is working.
0
 
LVL 4

Expert Comment

by:guardsman85
Comment Utility
Edit number 2:
The APR cache updates IP and MAC address info, not host names as I stated before, so this really might not help you.

Sorry.
0
 
LVL 4

Expert Comment

by:Shplad
Comment Utility
Dumb question, I know, but...is something share on the other machine?
Is file and printer sharing turned on?

Are there any Antivirus programs running which might block access?


Shplad
0
 
LVL 4

Expert Comment

by:webadministrator
Comment Utility
ok if the pc is accessable through ip not with DNS names then you better check the DNS configuration as well.
 See if it works.
0
 
LVL 4

Expert Comment

by:Shplad
Comment Utility
I have to disagree here with WebAdministrator. DNS is not working in a peer-to-peer network,
where there is no domain controller or DNS server, except when those machines go out onto the Internet. Which client machine would provide DNS service?

It's strictly NetBIOS and NetBIOS over TCP/IP/browser service at work here.


Shplad
0
 
LVL 4

Expert Comment

by:webadministrator
Comment Utility
I am extremly sorry for not going through with whole question properly.
Shplad you are right, one more thing which you didnt mention is Peer Name Resolution Protocol,
PNRP is ideal for Peer to peer environment.
0
 
LVL 4

Expert Comment

by:Shplad
Comment Utility
Webadmin:

Yes, you are right. I just thought of that after you posted. No slight was intended, of course.

We are all here to solve the same problems (kinda like on the resta the planet, we just
forget that sometimes)

Shplad
0
 
LVL 4

Expert Comment

by:webadministrator
Comment Utility
:) thanks
i think we should come back to the point.. solving the issue of afflik1923
:-)
0
 

Author Comment

by:afflik1923
Comment Utility
I'm glad a lively debate is on about my original posting. As I now have the laptop in my possession (same problem on my network) I intend to get to the bottom of it.

All the obvious stuff has been checked, I do not want to do re-insatll. there has to be something fixable and I will go through suggestions so far shortly but when I looked before there were many that I had tried.

Thanks for input.
0
 
LVL 4

Expert Comment

by:guardsman85
Comment Utility
Is it feasible for you to give the computers static IP addresses instead of having them assigned by DHCP?  If you could get by with using static IP addresses you could manually edit the hosts file (usually located in C:\WINDOWS\system32\drivers\etc) to include the IP addresses and host names of the other computers.  If you still want your laptop to get its address from DHCP when you're at other locations you could configure the TCP/IP settings to use DHCP primarily and configure the Alternate Configuration tab with your static settings.  Another option would be to have your router always assign the same address to each host (if it supports this type of option).
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 

Author Comment

by:afflik1923
Comment Utility
Unfortunlety they have a cheap router which I believe does not have that option. Static IP address is no good either as the laptop will move from place to place.

but this has to be a fixable problem. The laptop has the same problem in my own network. there must be some registry fix or something that will make this work.
As this thread has got a bit scattered I'm tempted to start the question again.

Now assuming that I have checked ipconfig and the IP address assingment is all OK. The network itself is fine.
Thw Windows firewall is off. I can ping other PC's on the network. I can even access other PC's on the network by typing IP address.

But I just can't access throuh Windows Explorer and browsing to network place. Therefore this probably has to be something to do with converting names into IP addresses.
But surely something is broken.

One thing I did note. On disabling the firewall Windows does not seem to be giving the securoty warning. There are no other processes running that are recogniseable firewalls, but even so, I'm able to access network resources through IP address anyway.

PLEASE HELP!
0
 
LVL 4

Expert Comment

by:Shplad
Comment Utility
afflik1923:

I ddidn't see a reply back about my suggestion of setting to NetBIOS over TCP/IP to
"Enable" under Network Properties. Has that been tried yet? You should also ensure
"Use LMHOSTS" is checked as well.

Did you also check the various solutions mentioned on the link I provided above?
I didn't catch whether you tried those things or not. The ChicagoTech page has several
solutions for that problem that often work.

Would you please confirm that filesharing is turned on on the laptop, and that you have
something shared?

Have you ensured only one machine on the network is acting as the Master Browser?



Shplad
0
 

Author Comment

by:afflik1923
Comment Utility
Regarding NetBIOS over TCP/IP. How do I add this?

This is what I tried.
In Nework proerties for Lan I selected Geenral Tab and then Install
I selected Protocol and the ones I had avaialble which I added were
NWLink NetBIOS
and
NWLink NetBIOS IPX/SPX/NetBIOS Compatiable Transport Protocol.
I added these both and still the same problem.
I've not looked at the ChicagoTech page but will do next unless anyone else has good ideas.



0
 
LVL 4

Expert Comment

by:Shplad
Comment Utility
From my previous post:

Network Connections-->Highlight appropriate NIC card-->Properties-->Internet Protocol-->Properties-->
     General Tab-->Advanced-->WINS Tab-->Enable Netbios over TCP/IP



Shplad
0
 

Author Comment

by:afflik1923
Comment Utility
yes sorry, I just noticed and tried that. I was going through it now and that section opened up a new world of options to try. I just missed that Advanced Button.
Anyway,

LMHOSTS was already enabled.

I chaned the setting to ALWAYS use NEtbios over TCP and... no change. Still the same issue. Not trying the links you suggested for more information. But I just do not see why this does not work.

One thing I mentioned at the start when I first checked the laptop the IEE authenticaion box was checked but now disabled.


Any more tips always welcome
0
 

Author Comment

by:afflik1923
Comment Utility
that list on
http://www.chicagotech.net/accesserrors.htm

looked good. But I went through each one to no avail. It's so frustration as if I type \\IP address it goes right to the network location typed. Vice versa also works being ablt to access the laptop from my network typing it's IP address.

Currenlty in my network the laptop has a different workgroup name to mine but this should not be a problem. In the network from whcih it came it has the same workgroup name and still had the same issue. If you type the direct IP address in and the folder path shows in Windows Explorer, as soon as you click the parent Worlgroup name you get teh same error message again

AAAAHHHRRRRGGGGHHH

Currenlty installing Windows defender to see if there is spyware or something.

cluthing at straws,

From the list of resolutiosn on the weblink I was not sure how to
3) check user's rights.

any pointers?

any other ideas, please??
0
 

Author Comment

by:afflik1923
Comment Utility
Note the securoty software they have installed is CA Security centre but it says Firewall component is not installed. I disable the virus part as well to be sure that it's not interferring.

Also tried over the wireless rather then wired and exactly the same behaviour.

what could be causing this. Am I looking at a reinstall?

Please please please please help!!
0
 
LVL 4

Expert Comment

by:Shplad
Comment Utility
Man, you're making me work overtime here.  ;-)

BTW, until our crack team solves this problem-(I'm criticizing myself here), have you considered
mapping a drive as a temporary workaround to at least save yourself the browsing?

No, I would definitely not reinstall. I've seen this type of behaviour with Windows too many times to
mention. There can be so many causes. I had another technician friend who went through this for weeks before he resolved it. I remember the solution, but it was on Windows 2000.

Clearly you're right-there's a good chance its a name resolution issue.

I assume you enabled NetBIOS over TCP/IP on all machines, not just the laptop?

In theory, two different workgroup names should not prevent name resolution. In practice, though
I've seen it happen. I'd make sure they're in the same workgroup.

Next, I'd immediately check to see if there's a master browser conflict going on.   In a Microsoft peer to peer network, the PCs elect one machine to become the master browser. The master browser acts as a sort of server with a "small s". It keeps information about other computers, and helps negotiate communications. A master browser conflict occurs when more than one machine decides it's going to become the master browser, thereby creating a conflict, and sometimes preventing reliable name resolution, communications and more. If this is the case, you will generally see error messages to that effect in Windows event log.

Please, if you could check the system event log on both computers. I believe there's a good chance
you'll find something in there.

Start-->Programs-->Administrative Tools-->Event Viewer-->in left pane, click "System"
to see the system log.

If there is no Administrative tools menu, you can do:
Start-->Run-->eventvwr.msc-->in left pane, click "System"


There's got to be something in there. Be on the lookout for browser event id
8032 or 8021 in particular.

I'll be referencing this article in particular:
http://support.microsoft.com/kb/135404/en-us



Shplad

0
 
LVL 4

Expert Comment

by:Shplad
Comment Utility
Oh, and I wasn't clear-did you check that the browser service and server service
are working on all PCs?


Shplad
0
 

Author Comment

by:afflik1923
Comment Utility
Yes certainly one of those overtime tasks that when I took it I thought, yeah no problem, and hours later I'm still trying to resolve it.

Anyway, some more details. Firstly this particularly laptop has not worked with the same problems in both environments. So even if I make the other PC's in my own network work with it, when I give it back to the owner it needs to work in their network too and it will be a pain having to get them to change all their other PC's when this laptop seems to be a problem whatever environment it is in.
Also they take it to more then one locaiton where it nees a peer to peer network as well.

It's anoying how peer to peer seems so ropey in XP. It seemed much more solid in Windows 2000.
I notiece there is an optional Windows XP upgrade relating to peer to peer networking. Would that help?

Anyway, on the subect of my own network, I notice that the PC's have the default option selected to the following:
Default:
Use NetBIoS setting from the DHCP server. If static  IP address is used or the DHCP server does not provide NetBIOS settings enable NetBIOS over TCP/iP.

Also Use LMHOSTS is checked.

These were also the default settings on the offendeing laptop.
I also checked the log and previously thought that none of the errors are related but now perhaps they are.

"Warnings" that have occured often in the "application" log are
1517 -stillusing registry while logging off
1524 - cannot unload registry classes registry file

the above seems to occur quite frequently  and mostly together altohugh 1517 a bit more then the other.

In the system log there are 8021 warnings which seem to occur after first switching on.
For today for exampl there is the
8021 followed by four entries of 8004 (backup request when already master browser).

So maybe this is where we should be focusing our attention. Maybe that registry warning has more to it then we think (or I should rephrase then - then I thought :) ).







0
 
LVL 4

Expert Comment

by:Shplad
Comment Utility
Afflik1923:

I don't know about the 8004 errors, but the 8021 errors definitely could be a sign of master browser
problems. (Ooh, better be careful how I pronounce that).

I'm going on holidays for a few days, so I may not be able to contribute until this question is
answered. However, I think we've got you on the right path.

It was never mentioned in the original post that the laptop would have to go back to another
network, so I didn't plan for that at all, or take it into account in my suggestions. Was the original
network a domain? Is the laptop a member of the domain? Another thing about a machine that
was originally part of another network: it could have other software, such as a VPN client
program, wireless networking software, TCP/IP filtering settings, or other factors which might prevent connection. Can it communicate with other PCs in its original environment? I think we need more
clarity here, as you just added in a whole pile of other factors.

Either way, I believe you should pursue the master browser fixes, as outlined by MS and
other websites in some detail. But also check to see if that laptop is joined to a domain.
Oft times, a machine joined to a domain will act bizarrely in other environments.

I would set your own machines to "Use NetBIOS over TCPIP" (Also known as "NBT").
It's a more reliable setting in peer-to-peer networks. If nothing else, it speeds up name
resolutions, because it eliminates the timeout of waiting for a WINS or DNS server to answer
when there isn't one on your peer-to-peer network.

I do not believe you need the Windows XP peer to peer networking pack to fix the problem.
QUOTE from https://www.microsoft.com/presspass/press/2003/feb03/02-26sdkannouncespr.mspx:
"The related Windows XP Peer-to-Peer Networking Update supports automatic tunneling technology, enabling IPv6 communication over existing IPv4 networks and NAT devices"
IPV6 is definitely not your problem, and neither is getting past NAT devices, as you are on
an internal LAN.

However, it does add peer-to-peer name resolution protocol. This could be Microsoft's way of adding a "patch" and introducing it as a feature. (Sorry MS, but it's not like you've done it before.)
The peer-to-peer is available as a public update/patch/whatever, so if you exhaust all other options
(and there are others) I would install that, rather than a larger update like the one listed above.

Here's why I think most technicians would probably agree with me:
My machines which I setup here at my IT business do not have either installed, and can all talk
to each other. So do the machines on millions of other peoples' networks. And that was before
they ever issued the update.

A few things I suggest you try:

Ping the laptop from one of the other machines with the -a command switch.
"ping -a laptopname" (without the two preceding slashes)

That will give you an idea whether the ping command can find an IP
address when given the computer name i.e. name resolution via
NBT.

Next, use the nbtstat command to troubleshoot NetBIOS over TCP/.IP name resolution functioning.
Obtain the the laptop's computer name.
Then, from another computer, enter:
"nbtstat -c".
The output should include the common workgroup name, and the names
of at least some of the computers on the network. It should look something like this:
================================================
C:\Documents and Settings\Shplad>nbtstat -c

Local Area Connection:
Node IpAddress: [192.168.0.6] Scope Id: []

                  NetBIOS Remote Cache Name Table

        Name              Type       Host Address    Life [sec]
    ------------------------------------------------------------
    PRO-1D499E6268B<00>  UNIQUE          192.168.0.8         145
Local Area Connection:
Node IpAddress: [192.168.0.6] Scope Id: []

===================================================
In this case, it was a 3-PC workgroup on one of our small networks, but one of the PCs
was off, so you can only see one other machine's entry-"PRO-1D499E628B" .
(You don't see your own machine's name in the output, because you never need
to do name resolution to your own machine.)
 
So to repeat, try issuing the nbtstat -c command from one of the other PCs.
If the laptop's name does not show up, you have an NBT name resolution problem.

If that's the case, it could be the NBT  name cache has become corrupted. To resolve that,
issue the DOS command "nbtstat -R" ON BOTH THE LAPTOP AND THE OTHER PC.

Now try pinging via machine name again. If that doesn't work, I'm sure one of  the other
fine experts around here can continue where I'm leaving off. NBT is a bit dated, but (unfortunately)
it's still part of troubleshooting a Windows peer-to-peer network.

Oh, and I'll try to check in some time in the next few days.


Shplad
0
 
LVL 4

Expert Comment

by:Shplad
Comment Utility
Afflik1923:

Oh, and umm...I hate to be the bearer of bad news, but I've seen AV software just being
installed prevent name resolution or, in some cases, network communication entirely.

I doubt that's the case here, but it could be your last resort to uninstall it. If the client
permits it, of course.



Shplad
0
 

Author Comment

by:afflik1923
Comment Utility
Without reading your reply fully in case you happen to be around Ithougt I would get in more details.

The original home of the laptop was not a domain, it was another peer to peer network. So in that peer to peer network and my own peer to peer network the same problems happen just on this laptop.
All other PC's /laptops behave OK in both of the networks. This particular laptop behaves badly (as can't see out or no on can see into it) when using copmuter names as opposed to IP addresses. On both networks using IP addresses to/ from the laptop networking works fine.

I have had permission to uninstall Anti virus, but am hesitant to do so as reinstalling the licence etc. may be grief.

OK wanted to get that in. Will now study your comments in greater detail.

THANK you for all your input so far.

0
 

Author Comment

by:afflik1923
Comment Utility
Some other things of note.
Of the offending laptop the login screen shows the guest account as an option to click (as well as the main user who is administator). I don't remember it being like this on other PC's but I could be wrong.

On other PC's on the network. one is able to see the offending laptops copmuter name in the entire network / workgroup name tree, it's just when you actually click on it the error occurs.

On the offending PC, it is not possible to see other computer names (that is unless you first navigate to the PC using IP address, then the names appear in the list but still cannot be clicked on).

Maybe this helps.
0
 

Author Comment

by:afflik1923
Comment Utility
OK, I'm temtping fate here, but MAYBE I've found it

http://support.microsoft.com/kb/903267

I'm crossing my fingers BIG time, but I noteiced on doing an ipconfig /all is said peer-to peer.

I would have thought this was OK, but on comparing to other PC's they said broadcast.
Internet searches led to this.
I'm about to try now and prey!!!
0
 

Author Comment

by:afflik1923
Comment Utility
Excuse my french but

EEEUUUUUUURRRRRRF****KINGRRRREEEEEKKKKKAAAAAAAAAA!!!!

The fix in
http://support.microsoft.com/kb/903267
solved the problem in an instant!!!!!
My node type does now say unknown, but I can browse the networks as expected and all works great!

Shplad (and others) thank you for the input. If you can post a response to this stating the above URL as the fix and to refer to these last few posts I would be greatful and award you the points. Then others will know to cut right to the chase and right to the link.
I knew it had to be some silly registry thing or something

THANKS TO EVERYONE -
0
 

Author Comment

by:afflik1923
Comment Utility
Also note;
http://support.microsoft.com/default.aspx?scid=kb;en-us;318030
and
http://www.richardcleaver.com/?p=15

Afterwards I played around with getting the NodeType settings right and aded the DHCPNodetype parameter (even though MS at the URL below says do not edit)

http://support.microsoft.com/default.aspx?scid=kb;en-us;314053
Hope this helps others.

Cheers

0
 
LVL 4

Accepted Solution

by:
Shplad earned 500 total points
Comment Utility
afflik1923:

Wow, Congratulations! It was a long road, and you made it without reformatting.
Outstanding.

Microsoft's solution:
"You cannot view other workgroup computers on the network on a Windows XP-based computer"
http://support.microsoft.com/kb/903267

I had a hunch it had to do with NBT, but I wouldn't have guessed that the machine
was set for point-to-point. By the way, THAT FIRST ARTICLE INCORRECTLY DESCRIBES
NBT P-MODE NAME RESOLUTION AS "PEER-TO-PEER". That IS NOT THE PROPER NAME. P-Node stands for "POINT-TO-POINT", as opposed to broadcasting the name resolution request all over the LAN.

A machine is usually configured for p-mode when someone has manually configured it
for a domain-based network or if it was connnected to a domain-based network with
a DHCP server which specified that setting when it doles out ip addresses.

This is well-described in Richard Cleaver's Blog Archive
http://www.richardcleaver.com/?p=15
QUOTE:
"If a parameter is *optionally* set by *some* DHCP server then that parameter will persist in the registry regardless of any other actions you might try. The parameter is “DhcpNodeType”. Not all DHCP servers set this parameter. I obviously had the misfortune of connecting to another network, which I often do when I travel, where the DHCP service changed this parameter. My network’s DHCP server does not change the parameter and that is why the notebook failed to join the workgroup and gave the error message."

In other words, when you bring the machine back to a different, peer-to-peer network, and it is configured for P-mode resolution, it tries to contact a WINS server. Of course, there (usually) isn't
a WINS server on a peer-to-peer network. That means the machine's NBT name resolution won't
function, and it will have no ability to browse or show up in other PC's "Network Neighbourhood"
or "My Network Places", but it is still able to contact machines by IP address and vice-versa, since
that requires no name resolution.

I was assuming largely out-of-the-box configuration because it was being used on a peer
to peer network. I guess I should have tried to "think outside the box", so to speak.

These were mentioned earlier on, as preliminary steps to try:
"You cannot access shared files and folders or browse computers in the Workgroup"
http://support.microsoft.com/default.aspx?scid=kb;en-us;318030
Basically, make sure NetBIOS over TCP/IP is set to enabled and browser service
is turned on, because on a peer-to-peer network, NBT is the main method for name resolution,
and the browser service is required if you want to see machines in "Network Neighbourhood"
(Win2000) or "My Network Places" (WinXP)

This article clearly describes NetBIOS over TCP/IP (AKA "NBT") and WINS Name Resolution:
http://support.microsoft.com/kb/119493

And this article:
http://support.microsoft.com/default.aspx?scid=kb;en-us;314053
defines the TCP/IP and NBT configuration parameters used in the registry
for adjusting name resolution using the former two protocols.

Thanks for all your patience on this afflik1923.

I'll be printing this one out and adding it to my binder.


(exhausted) Shplad
0
 

Author Comment

by:afflik1923
Comment Utility
Exhausted indeed.
The laptop was delivered to the cleint and they were happy (probably not full y appreciating how much effort I had gone to).
It did always take a good few seconds to do the initial network search. When first demonstrating I would say it tool about 15 seconds to find the other peers, but once found it worked better. This is despite me turning on NetBIOS over TCP option.

I guess if they could complain I could add entries into LMHosts file right??

anyway all seems good for now and thanks for all inpt.

As said I've awarded Shplad points for continunued efforts.
Thanks again!
0
 
LVL 4

Expert Comment

by:Shplad
Comment Utility
afflik1923:

Thank you for being so patient about it, and thanks for the points.
One possibility for the delay could be the "scheduled tasks" feature. I can't remember
where, but somewhere, there is a registry patch or info. on how to change a setting in
the registry.

Basically, when a machine goes out onto the network to connect to another machine,
it will (believe it or not), not only grab a copy of the network shares offered, but also the
scheduled tasks on the remote machines. Shutting that off can cut the delay in browsing
sometimes.

And yes, there are always other ways to speed up peer-to-peer Windows networking,
but alas, that's another question for another day.

Take care, and thanks for the challenge.

Shplad
0

Featured Post

Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

Join & Write a Comment

This is the first one of a series of articles I’ll be writing to address technical issues that are always referred to as network problems. The network boundaries have changed, therefore having an understanding of how each piece in the network  puzzl…
This article offers some helpful and general tips for safe browsing and online shopping. It offers simple and manageable procedures that help to ensure the safety of one's personal information and the security of any devices.
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now