activate flash menu on asp page in dreamweaver

i have a flash menu when it comes up it i have to click it to activate it is there a way it can come up without having to click it to make it work

here is the code for it
 <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0" width="725" height="210">
          <param name="movie" value="Top/Empirevolleyball.swf">
          <param name=quality value=high>
          <param name="BGCOLOR" value="#FFFFFF">
          <embed src="Top/Empirevolleyball.swf" width="725" height="210" quality=high pluginspage="http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash" type="application/x-shockwave-flash" bgcolor="#FFFFFF"></embed>
        </object>
Jesse26Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

steelseth12Commented:
use javascript to call the flash

http://blog.deconcept.com/swfobject/

0
Jesse26Author Commented:
I need a little more help than that.  I have researched this.  I dont have a .js file.  where do i make it or find it? do i need to change all my flash code in order to do this?  Do i just add this code of the example site you gave?  I thought i wanted to keep the object tags, is that not right?  I provided some code if possible can you show me through that?
0
pmagonyCommented:
Dreamweaver 8 should fix this problem for you automatically.  What version of DW are you using? If you have 8:

Go to Edit | Preferences | Code Rewriting and look for the Active Content check boxes at the bottom of the options.  Make sure both of those are checked, restart DW8, open your html page (you should be prompted by DW to fix your issue) - once complete... upload the folder called Scripts to your server and the page with the Flash.

Else: http://www.amarasoftware.com/flash-problem.htm
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Learn SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

Jesse26Author Commented:
I appreciate the both examples
I use both DWMX and DW8
When i opened the dw8 i went to the edit | preferences | code rewriting and found no active content check boxes.  Are they called something differernt.  I also tried both examples and niether worked.  I tried a few times each.
0
Jesse26Author Commented:
I have retried all your guys examples i dont get why it doesnt work
0
pmagonyCommented:
What version of DW8 do you have?

Help | About Dreamweaver | Click once on the splash screen and you should see a version number.
0
steelseth12Commented:
Ive made an example on how to do it .

http://rapidshare.com/files/21776365/example.rar
0
Jesse26Author Commented:
my version of dreamweaver 8 is 8.0 and steelseth12 am i supposed to download something from your link?
0
pmagonyCommented:
You need to upgrade your DW to the most recent version 8.02, it contains the fix you need to get the job done.

http://www.adobe.com/support/dreamweaver/downloads_updaters.html

If you have any problems thereafter, refer back to my post about making sure the options are checked-on and uploading your file and Scripts folder.

Good Luck,
0
steelseth12Commented:
emm yeah
0
Jesse26Author Commented:
Yeah I really dont want to buy anything thats why i sign up with you guys
0
steelseth12Commented:
You dont have to buy anything just press on free ... wait 60 sec and download the file
0
pmagonyCommented:
It's a free update.
0
pmagonyCommented:
Did you download it and  update your DW?  I can assure you this is your 'easiest' route.  Don't waste your time on other hacks.
0
Jesse26Author Commented:
I tried the update but it threw all my pages out of whack.  
0
Jason C. LevineNo oneCommented:
Jesse26,

The 8.02 updater installs the functionality for the code rewriting.  You need to reopen any page with Active Content and allow DW to convert the direct embed to a javascript-based embed.

Once that is done, you need to upload the pages to the server AND upload the new Scripts directory created in your site's root folder.

Aside from the tone, I agree with pmagony in that you need to help us help you.  Be descriptive with your errors and problems and you'll find the quality of the support we give you rises considerably.  Whenever possible, post a link to a problem page or a screenshot of what "out of whack" means...

Thanks
0
Jesse26Author Commented:
IBelieve me I try out all the advise you guys give me.  Multiple times.  Im sorry I dont get the results Iyou want.  i am not trying to shoot down anything I really really really want this to work.  I am not trying to frustrate anyone.  I wasnt aware that I was asking the questions correctly?  I simply want the active controls to work automatically?  jason1178  I installed the functionality for code rewriting.  I opened a page that had the menu that had code rewriting selection.  When I go there I see two active button check boxes.  If I click on these two buttons my web page looks totally different than before.  It doesnt have the same dimensions as the old Internet Explorer pages.  IThe menus and images and text is all over the place.   Thats what  i meant by out of whack.  I figured I did something wrong.

If there is any other solutions i am happy to try anything that might make this work
0
Jason C. LevineNo oneCommented:
Can you post a link to a rewritten page where the formatting got blown away so we can see it for ourselves?
0
steelseth12Commented:
<<off-topic comments deleted - modguy>>

either go here http://blog.deconcept.com/swfobject/ and follow the guys examples or download my example from here http://rapidshare.com/files/21776365/example.rar
<<off-topic comments deleted - modguy>>
0
Jesse26Author Commented:
check it out steelseth I dont need to get verbally abused for not knowing the internet.  I dont want any advice from you thanks for the time you have spent.

Jason here is my page http://www.empirevolleyball.com/Alumni.asp
if you click a link you can see how the other pages are generally put together.  This is the result of the active content check boxes.  
0
pmagonyCommented:
"http://www.empirevolleyball.com/Alumni.asp"

In IE7 it's not giving me the activate box. Nor IE6... it looks as though you got it fixed by using the DW8 Update.

Can you confirm?
0
Jason C. LevineNo oneCommented:
Hi Jesse26,

I see the <script src="Scripts/AC_RunActiveContent.js" type="text/javascript"></script> in the source, so the Active Content fix is in place.

I do see some differences between that page and others on the screen, but I think this is due to poor design technique.

When I open your pages in DW, I see what you mean about the layout.  Again, I think this is due less to the Active Content fix and more to your (mis)use of tables and CSS styles to do things.  IMO, you may be better off getting rid of the tables and embedding the Flash into floating divs and use CSS to rearrange the site.
0
Jesse26Author Commented:
pmagony i get this in my ie7
i appreciate your time jason.
0
Jason C. LevineNo oneCommented:
No problem.  Just to clarify what I said above...it appears to me that you "drew" your site layout in design view and embedded the Flash movies into the tables.  While this will sort of work, as you go back and add things to the pages (such as the calls to javascript for the active content, styles, etc.), DW loses it's ability to render the page internally and you will also start to run into browser issues.  

I hate to say it, but you may be better off starting over with a complete CSS layout and/or simplifying your site's structure.  I could spend hours going through the existing code and I may never be able to get it back to normal...
0
pmagonyCommented:
I just tested this link ("http://www.empirevolleyball.com/Alumni.asp") again in IE7.0 and I did not receive a request on the hover of my cursor to 'click to activate'.  Can you verify you are using IE7?

Internet Explorer: Help | About Internet Explorer
0
Jason C. LevineNo oneCommented:
Jesse26,

Try removing the styles from the page.  Also, preview your page in Firefox.  It looks almost fine there.  I think we are narrowing the problem to inconsistent IE CSS support.

Also, I agree with pmagony that the fix is in place for IE.
0
Jason C. LevineNo oneCommented:
Hi Venabili,

IMHO, pmagony provided the best solution first (upgrade to DW 8.02) for the Active Content problem.  We devolved into a design layout issue at the end but that shouldn't affect things.

I recommend points to pmagony or a split between pmagony and steelseth12.
0
Jason C. LevineNo oneCommented:
Whoops...looks like Jesse26 agrees.
0
VenabiliCommented:
Sometimes the Askers just reappear. :)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Adobe Dreamweaver

From novice to tech pro — start learning today.