Solved

FC4 - "x" process is a system hog

Posted on 2007-03-17
3
552 Views
Last Modified: 2013-12-16
My FC4 box is getting pounded.  "top" shows:

Tasks: 127 total,   4 running, 123 sleeping,   0 stopped,   0 zombie          
Cpu(s):  1.0% us, 53.7% sy,  0.0% ni,  0.5% id, 44.1% wa,  0.2% hi,  0.5% si  
Mem:   1034572k total,   991692k used,    42880k free,     1660k buffers      
Swap:  2097144k total,   199876k used,  1897268k free,   593184k cached        
                                                                               
  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND          
 2953 root      25   0     0    0    0 R 99.9  0.0 135:08.27 X                
16905 postgres  15   0 36664  26m  25m S  5.0  2.6   0:38.87 postmaster        
18745 postgres  15   0 36688  26m  25m R  3.0  2.6   0:01.00 postmaster        
  170 root      15   0     0    0    0 S  1.0  0.0   0:52.98 kswapd0          
 2109 root      15   0  8588 1504 1072 S  0.3  0.1   0:05.56 cupsd            

I don't use "X" on this machine.  Charater is fine.  How do I kill this process and/or remove "X"?  I have tried a kill -9 2953 and the process is still running.

Thanks.
0
Comment
Question by:shannon_adams
3 Comments
 
LVL 40

Expert Comment

by:noci
ID: 18741582
It is possible that X is started from the /etc/inittab, so killing it will just restart a new one.

In most installations (at least redhat) level 5 for init means a graphical environment needs to be started.
therefore X.
If you modify the /etc/inittab file and set the initdefault to 3 like this,

id:3:initdefault:

then no graphic environment should be started.
'telinit 3'
will set the runlevel back to three, interactively.

After editing the /etc/inittab file you can activate the new file with 'telinit Q'
0
 
LVL 2

Accepted Solution

by:
fpintos earned 500 total points
ID: 18753683
Alternatively, you can turn off the X server explicitily by doing the following:
Change the line in /etc/initab:
x:5:respawn:/etc/X11/prefdm -nodaemon
To:
x:5:off:/etc/X11/prefdm -nodaemon

do a "telinit Q" to inform init to re-read the initab file and you are done.
0
 
LVL 10

Expert Comment

by:ssvl
ID: 18756070
if you dont want the X the you have to chage your runlevel to 3

vi /etc/inittab

id:5:initdefault:   ( change the 5 to 3)

(id:3:initdefault:)

0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
wifi not working on Raspberry Pi 3? 2 57
Guacamole cut and paste issue 3 78
installing LSI MegaRAID Storage Manager on CentOS 7 22 379
Remote desktop Ubuntu from Windows 10 5 65
Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
I don't know if many of you have made the great mistake of using the Cisco Thin Client model with the management software VXC. If you have then you are probably more then familiar with the incredibly clunky interface, the numerous work arounds, and …
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

832 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question