?
Solved

X11 Forwarding over SSH w/ Putty

Posted on 2007-03-17
7
Medium Priority
?
7,072 Views
Last Modified: 2008-01-09
I am trying to forward X11 to my local computer using putty and ssh.
I have tried this before with another remote server on my local network and it worked fine.
Now I am trying the same with a remote server and I get the error message "Can;t open display localhost:0.0"

In putty I have set the machine to X11 port forwarding on localhost:0
I have also started an Cygwin X-Server on 0.0.
My DISPLAY variable on the remote machine is set to localhost:0.0

How can I find out what is wrong?
0
Comment
Question by:tomanizer
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
7 Comments
 
LVL 9

Accepted Solution

by:
binary_1001010 earned 1500 total points
ID: 18742955
X-windows forwarding :

To enable , change the line X11Forwarding yes
In /etc/ssh/sshd_config , then do a :

service sshd restart

Also, remember to change the DisallowTcp=false in /etc/X11/gdm/gdm.conf
0
 
LVL 6

Expert Comment

by:_iskywalker_
ID: 18743099
to assure it works:
ssh -X myremote
export DISPLAY=myhost:0.0
0
 

Author Comment

by:tomanizer
ID: 18745227
Thanks guys. a few more questionsÖ

How can I restart the sshd service?
I cannot find gdm in my X11 folder.

iskywalker: what do I need to replace myremote and myhost with?
0
Use Filtering Commands to Process Files in Linux

Learn how to manipulate data with the help of various filtering commands such as `cat`, `fmt`, `pr`, and others in Linux.

 
LVL 9

Expert Comment

by:binary_1001010
ID: 18754586
are you using Redhat or ubuntu?  

to restart sshd in  redhat  :  service sshd restart


myremote is the linux server ip.
myhost is the ip of the PC where cygwin is running, i assum it is xp?
0
 

Author Comment

by:tomanizer
ID: 18755105
Thanks binary.

The distribution is SUSE 10.0.
I tried "service ssh restart" but the service command is unknown.
Cygwin is running on XP.

I cannot find the gdm or the gdm directory. What does it stand for?
0
 
LVL 9

Expert Comment

by:binary_1001010
ID: 18756870
sorry man, i am not sure about suse.

have you try google?
0
 

Author Comment

by:tomanizer
ID: 18817010
I could not figure out how to restart the service.
So I rebooted the server...
Now it works following Binary's suggestions.
Thank you.
0

Featured Post

DFW AZURE MEETUP TONIGHT FRI 6PM

We will be discussing what Azure Stack is, how does it fit into the suit of offerings that Azure has currently, and where can it fit into your organizations technology stack. We will also be discussing limitations of the platform while covering various applicable scenarios.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Network Interface Card (NIC) bonding, also known as link aggregation, NIC teaming and trunking, is an important concept to understand and implement in any environment where high availability is of concern. Using this feature, a server administrator …
Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses
Course of the Month9 days, 13 hours left to enroll

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question