Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Classic ASP on IIS 7.0 Troubles...???

Posted on 2007-03-18
4
Medium Priority
?
362 Views
Last Modified: 2010-05-18
I've just installed Windows Vista Ultimate and noticed that a new version IIS 7.0 is included.  I'm trying to get my classic ASP applications working but I'm having some issues.  First, I'm getting a mime type error that the extensions isn't configured on my web server.  I Googled "enable ASP on IIS 7.0" and I found the following MS article:

http://technet2.microsoft.com/WindowsServer/en/library/8c6d5aa5-d4e1-44a5-a7d2-ac0be88c50331033.mspx?mfr=true

It says to open up the UI, go to Features View, and open up ASP.  However, take a look at a screenshot of what I get when I go into Features View: http://www.dealexpress.com/temp/IIS.jpg

I do not have anything that says ASP.  I have a section called ASP.NET, but this reads like I'm suppose to have an icon called ASP that I can click into to get to ASP settings.  I don't have that.  

Any information on this would be greatly appreciated. Thanks!

0
Comment
Question by:Andrew Angell
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 10

Accepted Solution

by:
skca54 earned 1000 total points
ID: 18742957
Did you install IIS or was it already installed?

If it was already installed then you need to install ASP support  via 'Control Panel' 'Programs and Features' 'Turn Windows features on or off' 'Internet Information Services' 'World Wide Web Services' 'Application Development Features' 'ASP'
0
 
LVL 11

Author Comment

by:Andrew Angell
ID: 18743257
Ok, I wasn't aware that was an extra check box now.  Now I have the ASP option but I'm getting the following when trying to load a page.

"An error occurred on the server when processing the URL. Please contact the system administrator"

Nothing else. Any ideas?
0
 
LVL 16

Assisted Solution

by:golfDoctor
golfDoctor earned 1000 total points
ID: 18743760
Yes, IIS debugging mode is set to not show errors.  Set the debugging in IIS in properties.
0
 
LVL 11

Author Comment

by:Andrew Angell
ID: 18746064
Thanks!
0

Featured Post

 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I'm a big fan of Windows' offline folder caching and have used it on my laptops for over a decade.  One thing I don't like about it, however, is how difficult Microsoft has made it for the cache to be moved out of the Windows folder.  Here's how to …
Preparing an email is something we should all take special care with – especially when the email is for somebody you may not know very well. The pressures of everyday working life stacked with a hectic office environment can make this a real challen…
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…
Sometimes it takes a new vantage point, apart from our everyday security practices, to truly see our Active Directory (AD) vulnerabilities. We get used to implementing the same techniques and checking the same areas for a breach. This pattern can re…

670 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question