• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 629
  • Last Modified:

Connecting a VPN router to existing router on network.

I am trying to hook up a Netgear ProSafe VPN Firewall up to my existing network so that I can use it to VPN into my works network but I am having some problems.

I have a Linksys Wireless router hooked up to my cable modem and then I have another Linksys 5 port switch hooked up to the router.  What I want to do is hook the ProSafe VPN firewall up to my existing router and use it to VPN into my work.   My current network is using 192.168.10 ip's which are DHCP assigned to the computers.  I want to plug the VPN firewall into the smaller 5 port switch and plug the computers I want to be on the VPN network in the firewalls swtich.

I have tried giving the firewall a IP address to the WAN interface and using a standard cat 5 cable to connect the WAN interface to one of the standard ports on the smaller 5 port router but I am unable to ping the VPN routers IP address.

My question is, how would I accomplish this?  I thought that I could just assign the VPN's interface a local IP and plug it into the 5 port router port and it would work.  Please help!
  • 2
1 Solution
Rob WilliamsCommented:
The VPN router needs to be assigned a true public IP on it's WAN interface. Therefore you need to set the Netgear to be the primary router and hook the Linksys to it. In order to have all devices on the same network the Linksys should be connected by on of it's LAN ports rather than the WAN and therefor making it an Access point rather than a router. Have a look at the following as to how to connect and configure:

-The Netgear's WAN port should be connected to the modem directly. Configure it to obtain the IP from the ISP. Also make sure DHCP is enabled.
-reset the wireless WAN connection to default, i.e un-configured
-assign the wireless LAN side an IP address in the same subnet as the Netgear router.  Make sure it does not conflict with the wired router's DHCP range, or any statically assigned devices
-disable DHCP on the wireless
-wireless connections/security should be configured in the normal manor
-connect a cable from one of the LAN ports of the wired router to one of the LAN (not WAN) ports of the wireless. If the lights do not light up indicating a connection you may need a cross-over cable (usually only necessary on older units)
-now all devices should have Internet access and be able to easily connect to one another to share resources. Don't forget to refresh and DHCP addresses on the wireless clients
-now you can configure your VPN. One note; the VPN clients that connect cannot be  using the same local subnet as your Netgear's LAN. i.e. if the Netgear were to locally use 192.168.1.x then no remote client using the same subnet on their local network could connect via VPN. To avoid conflicts make sure you use an uncommon subnet for the Netgear's LAN. 192.168.10.x as you have above should be a good choice.  
RWJDComAuthor Commented:
Well.  Your way worked.  It wasn't what I wanted to do but what I did end up doing is actually taking the Linksys Wireless Router off of my network and I hooked the Netgear VPN router up to the network and I just put up a Wireless-G Access Point rather than a router and now my network works fine.

I did have some issues with my Vonage device being behind the firewall because of the packet inspection that the firewall did and it ended up making all of my phone calls quite choppy so what I actually had to do is put the Vonage device on the outside of the firewall directly connected to the internet and then connected the firewall to the Vonage device.

Anyhow, that's for all the assistance.
Rob WilliamsCommented:
Very welcome. Thanks you RWJDCom. Glad to hear it is working.
The VoIP systems are adding a whole new series of problems. A lot of folks have started subscribing to a second IP, as a solution. Some ISP's only charge $5/month. With that option you can put a basic switch between the modem and 2 routers and configure them independently.

You mentioned "put the Vonage device on the outside of the firewall directly connected to the internet and then connected the firewall to the Vonage device."  Did the VPN still work in this configuration ? If so the Vonage using must treat the LAN side as a DMZ allowing all traffic....I assume.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now