• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 457
  • Last Modified:

any drive in my computer can not open when press double click on it but it open when i use right click then open

hi
i have problem in windows xp
my problem is when i enter to my computer and press double click on any drive except drive D i get
error file copy.exe can not be found type it correctly or go to run and type it
but when i use right click then open on any drive the drive is open good
i do not what is the problem
can anyone help me
thanks
0
nasemabdullaa
Asked:
nasemabdullaa
  • 4
  • 3
  • 3
3 Solutions
 
Alan Huseyin KayahanCommented:
      There must be an autorun set to these drives to run copy.exe somehow. You should disable autorun for these drives. Link below describes how.
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/shellcc/platform/shell/programmersguide/shell_basics/shell_basics_extending/autorun/autoplay_reg.asp
0
 
Crash2100Commented:
When you right-click the drive, is any text in the menu bold?  Also, does this happen with folders too, or just the drives?
0
 
nasemabdullaaAuthor Commented:
hi
thanks for all reply
>>>When you right-click the drive, is any text in the menu bold
first item is autorun

>>>does this happen with folders too, or just the drives?
no only for drive

thanks
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
Crash2100Commented:
Then it sounds like MrHusy is right.  Right-click the drive this is happening with, and select "Open".  Once you're in the drive, look for a file called "autorun.inf".  Open the file in notepad, and post it's contents in here.  Once you do that, delete the file and your drive should open correctly again.
0
 
Crash2100Commented:
After you do that, I would scan all your drives for viruses.
0
 
Alan Huseyin KayahanCommented:
       *Start>Run
        *Type regedit and press enter
        *Locate HK_Current_User\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
        *At the right pane Double-click NoDriveTypeAutoRun
        *Change the value as 8. Click OK. Then restart your computer.
       
By this way, you wont see that happen again although autorun.inf exist in your partitions.
0
 
nasemabdullaaAuthor Commented:
hi
thanks for all reply
know i have problem when i press double click on any drive its open search page but the drive not open

thanks
0
 
Crash2100Commented:
Check this registry key, is the (default) value set to anything besides "none"?

HKEY_CLASSES_ROOT\Drive\shell
0
 
Alan Huseyin KayahanCommented:
      You were having a different problem. Whixh step above changed the situation?
0
 
nasemabdullaaAuthor Commented:
hi
iam realy sorry i do not know what is happand
first it the old problem and when i go to registry key and made the above detail i get the new problem
and its still
iam sorry and thanks for all who help me

thanks
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

  • 4
  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now