host and admin login failure immediatly after install

I am trying to develop a DNN module.  I have installed DNN through VS.Net Studio and the DNN Starter kit.  The site installs and starts up but when I attempt to login as either the host or the admin I get redirected back to the main page with no additional functionality showing.

Using VS2005 and Starter Kit 4.4.1

Any ideas?

P.S.  Sorry, I'm new to DNN, is there a way to debug this through Visual Studio?


Who is Participating?
pitsterConnect With a Mentor Commented:
Try registering on the site and see if you can login with the new user credentials. The default for DNN sites is that registration is not public so your verification code should be 0-3 for the first user. This may help you eliminate some of the issue. Also if you  have not set your site up make sure your url reads http://localhost/yoursite. Once you have logged in you can add as many aliases like http://myserver/yoursite, or if it is in the root of your default web site just get rid of the /yoursite.

Hope this helps
BruceAuthor Commented:
Mayank SAssociate Director - Product EngineeringCommented:
BTW Visual Studio .NET is not open source so I suggest you should get this Q moved to the .NET topic area
7 new features that'll make your work life better

It’s our mission to create a product that solves the huge challenges you face at work every day. In case you missed it, here are 7 delightful things we've added recently to monday to make it even more awesome.

BruceAuthor Commented:
".NET is not open source"

Sorry, I thought this would be appropriate here as DNN is open source.  I did actually list it in the .NET topic area also.  At least I thought I did.  I'll check that...
Mayank SAssociate Director - Product EngineeringCommented:
That should be good enough then.
"P.S.  Sorry, I'm new to DNN, is there a way to debug this through Visual Studio?"

Yes you must download the source and in the DotNetNuke.sln change the url to yoursite/dotnetnuke.vbproj (ex. "http://localhost/DNN337/DotNetNuke.vbproj") then open with IDE and change your setting in the web.config Debug="false" to Debug="true". A quick note... when unzipping your source file, you should go to properties of the and click Unblock. This will save you a little time with error messages the first time you open this in the IDE. When creating your own modules Code Smith(plugin for IDE) is great for helping you. is a great place for tutorials on setting things up.

Good luck!!
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.