Installing MediaWiki 1.9 on 1and1.com

I am trying to install Mediawiki 1.9 on 1and1 server.  It requires PHP 5.0 which,they have installed.  BUt I get an errror about I am trying to install version 1.9 on a 1and1.com server.
I know they have PHP5.x but I get the error 'PHP 5.0.0 or higher is required. ABORTING'. when I try to run the install. I was wondering if it is because they have the database server located differently form the localhost and do not see it when the install script is started.

You can look at:
http://www.mwusers.com/forums/showthread.php?t=2505&highlight=1and1.com
to see a similar problem

Any thoughts?

thanks
olyanesAsked:
Who is Participating?
 
hernst42Connect With a Mentor Commented:
Can you check what the output of phpversion() is on that server and also what the output of
version_compare( phpversion(), '5.0.0' )

Thats the check mediawiki performs to give that error-message
0
 
olyanesAuthor Commented:
1and1 has php 5 on their server.  Did you look at the reference I added? It is not a version problem.  Check the reference and let me kow if you have any other thoughts
thanks
0
 
hernst42Connect With a Mentor Commented:
The problem might be that 1and1 have their own compiled php-version with some modification to fit the useage at mass hosting. So if they decided to modify those functions for security reasosns such programs might fail. Please post the output of those 2 statements. If they are ok I might look into other directions.
echo phpversion();
echo version_compare( phpversion(), '5.0.0' );
0
 
olyanesAuthor Commented:
I have checked that, fortunately got the answer on:

http://www.mwusers.com/forums/showthread.php?t=2505

At the MediaWiki Users Forum.
0
 
olyanesAuthor Commented:
thanks for your advice
0
All Courses

From novice to tech pro — start learning today.