Solved

OWA ActiveSync not working after installing Messageware Calendar share

Posted on 2007-03-19
9
893 Views
Last Modified: 2010-08-05
I have 2 exchange servers completely seperate and I installed Messageware's Calendar Share to give OWA the same function as Outlook  to share calendars, it worked with a few hickups but the greatest was ActiveSync does not work anymore, you get the error;

ActiveSync encountered a problem on the server
Support code 0x85010014

This is a typical Microsoft error which covers a multitude of things. I have emailed the Company but they are 5 hours behind so I dont expect to hear for a while.
The software works on OWA which uses Form based authentication and SSL as they say the permissions on the IIS folders have to be Basic not Integrated windows authentication. All seemed fine till I tried to sync my XDA then nothing.
I have;
Uninstalled the software
Put back a backup of IIS config
reset IIS back to original
Uninstalled IIS - drastic but getting desperate, which meant I reinstalled Exchange and SP2. Didn't lose anything including the error!!
I use self SSL and have renewed it numerous times
I have checked all IIS folder settings against another working Exchange server and there is nothing different apart from that never had Calendar share on.

Has anyone used this software and had similar problems.  
0
Comment
Question by:DaleGregori
  • 4
  • 3
9 Comments
 
LVL 6

Accepted Solution

by:
AbhijeetNigam earned 250 total points
ID: 18748047
look into this article from Microsoft http://support.microsoft.com/kb/817379/en-us
0
 
LVL 104

Assisted Solution

by:Sembee
Sembee earned 250 total points
ID: 18752542
If you would like an alternative version of 817379 then take a look at my web site here: http://www.amset.info/exchange/mobile-85010014.asp

Simon.
0
 

Author Comment

by:DaleGregori
ID: 18752622
I tested going to https://url/oma and got the microsoft not trusted message and  chose to continue anyway and then got a 401 you do not have permission.

We do use a self certificate, but having said that I do on another server and that is OK. I installed it on my XDA no problem. This server worked fine untill I installed this software.
0
 
LVL 104

Expert Comment

by:Sembee
ID: 18753074
Did you try OMA on the handheld device?
I would suspect that the application you have installed has changed something. Have you spoken to their support?

Simon.
0
Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

 

Author Comment

by:DaleGregori
ID: 18757751
Sorry yes I did forgot to say, I got the following error message.
Directory Listing Denied
This Virtual Directory does not allow contents to be listed.

I have spoken to the support team 'constantly' but I get the feeling this software isn't finnally developed yet. Most of the MANY problems I am having have all been experienced but there are no formal fixes yet. I have installed this on a test network and live, on the test network I uninstalled the spoftware and I am still having problems, I have also reinstalled IIS and Exchange and am still having problems. This software may be small but it has a big impact on exchnage and IIS.
0
 

Author Comment

by:DaleGregori
ID: 18758107
UPDATE -

I have been through IIS and checked every directory against a server I know works and there was only two differences,
one on the EXadmin the working server had Integrated Authentication whilst on my faulty one it was Basic. Apparently it has to be Basic to allow the software to work,
and the other was on the oma directory, cant believe I didn't see it, the oma.aspx had been replaced by the default list of documents.

I have tried the oma test on my XDA and have now got the directory listing now, BUT am still getting the following when I tried to sync

ActiveSync encountered a problem on the server
support code: 0x85010014
0
 
LVL 104

Expert Comment

by:Sembee
ID: 18760837
Have you removed the Messageware application to see if the problem continues? If the product looks rough around the edges and unfinished I would ask for my money back along with comment of "I don't want to beta test your software and be charged for it".

Simon.
0
 

Author Comment

by:DaleGregori
ID: 18762280
Fortunately I haven't paid for it yet which is why they are so helpful but there are too many issues for me to seriously think about it. I wanted it to give OWA calendar sharing capabilities whih we desperately need. Do you know of any products which do this.

I have put the fix on which was first writen and used the suggestions you said Sembee and it now works on one of the servers, I am now trying it on the other.

Because of this I will split points between you.
0

Featured Post

Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

Join & Write a Comment

Suggested Solutions

Know what services you can and cannot, should and should not combine on your server.
Find out how to use Active Directory data for email signature management in Microsoft Exchange and Office 365.
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
how to add IIS SMTP to handle application/Scanner relays into office 365.

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now