WordPerfect document permission problem

I am running WordPerfect 11 on Windows XP Home.  The permissions of documents created by WordPerfect are preventing other uses on my network from using the documents (Administrator, System, and the user in question are the only ones with any permissions).  If I manually change the permissions everything works fine.

Other programs (MS Word, Notepad, etc) don't have this problem.

The folder they are being created in has appropriate permissions (Shared Documents, i.e. C:\Documents and Settings\All Users\Shared Documents).

I have tried changing the permissions on the WordPerfect exe, and have even uninstalled / reinstalled WordPerfect.  Nothing has helped.

Is there a setting somewhere within WordPerfect to change this?  I didn't see one.  I also have WordPerfect X on another XP Home machine and it doesn't have this problem.

Thanks.
wiggymoeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

moorhouselondonCommented:
>If I manually change the permissions everything works fine.

What happens if you try editing a document, once it has been assigned the correct permissions?

If someone else then opens the file afterwards, are the permissions still set as desired, or do you need to change them again?

If the permissions remain as is, then make sure that the WordPerfect Templates folder, together with all the Template files have the correct permissions.  

Let us know whether or not that resolves the issue.  

I presume you have patched WordPerfect with the latest Service Pack (download from www.corel.com).
0
wiggymoeAuthor Commented:
I changed the permissions on the template files, but not the templates folder.

I'll also see what happens to permissions after editing a document.
0
wiggymoeAuthor Commented:
No luck.  I have changed permissions on the templates folder listed in WordPerfect Tools -> Settings -> Files.  New files are still being created with restrictive permissions.

Permissions DON'T remain as-is.  Saving an existing file that has manually had permissions fixed overwrites the correct permissions with the restrictive ones.  Opening a file and closing it without saving doesn't seem to affect permissions, though.
0
Fundamentals of JavaScript

Learn the fundamentals of the popular programming language JavaScript so that you can explore the realm of web development.

wiggymoeAuthor Commented:
I ended up uninstalling WordPerfect 11 and installing WordPerfect X instead.  That fixed it.  I guess WordPerfect 11 just doesn't want to work with NTFS?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
moorhouselondonCommented:
Water under the bridge now, but did you update to the latest version 11 service pack from Corel's website?  The fact that v10 works and v11 doesn't indicates a bug that was overlooked, which might now be fixed.
0
easyworksCommented:
FYI, Service pack 2 did fix my permission problem!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Office Suites-Other

From novice to tech pro — start learning today.