Solved

IIS SMTP Relay issue

Posted on 2007-03-19
3
543 Views
Last Modified: 2008-02-01
I have a windows 2003 server running IIS.  I have turned SMTP on.  
I can configure Outlook express to send emails from the server as long as I set the
"Outgoing mail (SMTP):" to 127.0.0.1
The server has a domain name associated with it.
I would like to be able to set the "Outgoing mail (SMTP):" to the domain name instead of the localhost ip.
Also, I need to be able to send without authenticating, therefore I believe I need to add th domain name to the relay exception list.
Someone suggested that I may need to contact the domain admin (Network Solutions) and have them update a DNS entry?
0
Comment
Question by:kevinvw1
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 31

Accepted Solution

by:
rid earned 250 total points
ID: 18750835
Are you running OE on the server machine? If so, it's logical that you can use "localhost" as outgoing SMTP server. It doesn't matter for mail delivery AFAIK, but the DNS records for your server IP needs to be configured correctly, otherwise your mails will be rejected by many receiving servers and you may end up on blacklists.
/RID
0
 
LVL 7

Assisted Solution

by:december41991
december41991 earned 250 total points
ID: 18764042
Since you are sending it from the server itself you can use the 127 ip or local host. As far as using the domain name... the server needs to have a registered doman (  you are participating in the internet now ) This will enable others who configure the mail account in their OE to use that domain name ( eg: mail.yourdomain.com)  now as you see mail.yourdomain.com is a internet address and should be reachable froom anywhere, you have to register. Register the domain.. have the MX record pointing to your server. then control relay  otherwise you will be black listed in real quick.
0
 

Author Comment

by:kevinvw1
ID: 18766280
I got the MX updated.  But I am discovering something strange...
I can do the following ->  Telnet 127.0.0.1 25 and I get a response from the SMTP server.
But if I use the server's actual ip address and do -> Telnet 10.10.17.78 25 I do not get a response.
0

Featured Post

Back Up Your Microsoft Windows Server®

Back up all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
page view and f5 big ip 4 54
php exec doesnt works on iis 4 49
Exchange 2016 OWA 3 79
Testing a list of Emails for validity 4 35
As tax season makes its return, so does the increase in cyber crime and tax refund phishing that comes with it
Article by: Dermot
The life of crime is over for 22 year-old Christian Ian Salvador, a student from Isabela State University in the Philippines.
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
With Secure Portal Encryption, the recipient is sent a link to their email address directing them to the email laundry delivery page. From there, the recipient will be required to enter a user name and password to enter the page. Once the recipient …

751 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question