Red Hat Enterprise Linux 4 reports incorrect time zone via telnet

Since the new DST went into effect, my Red Hat Enterprise ES 4 machines have the correct system time reflected as being in EDT (eastern daylight time).

However, if you telnet into the same machine, the time is reported one hour slow, with EST (eastern standard time) showing before the year.

An SSH session to the same machine reports the time correctly as EDT.

Is there another update I need for these systems?  I have already made the appropriate DST patches.

Thanks.
Travis
travbeavAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

TintinCommented:
Are you saying that when you login via telnet and run the 'date' command, it shows the timezone as EST and when you login via ssh and run the 'date' command it shows the timezone as EDT?

Are you logging in as the same user?
0
travbeavAuthor Commented:
Yes, you are correct.

When logged into the terminal as root, the date command shows up as EDT. Any telnet session shows up as EST.

We have submitted a sys report to Red Hat, but I was hoping someone could give me an answer sooner. The machine has already been rebooted. It is effecting all of our RHEL 4 machines.....note: these were already patched for DST a few weeks ago.
0
TintinCommented:
If you login as a standard user on the console, do you still get EST?

I'm wondering if you have TZ setting hardcoded in the root profile or /etc/profile or similiar.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

travbeavAuthor Commented:
Hi everyone,

We have narrowed down the problem. Only users who authenticate with WINBIND (against our Win2k active directory) are experiencing this problem.  Local accounts to the box (including root) do not have this issue.

Again, the issue is as follows:  when issuing the DATE command, local users get "EDT" which is the correct TZ. If a winbind user logs in, they get "EST" as their time zone, and the system time is rolled back one hour for these users.

Any ideas on how adjust TZ settings for users authenticating with WINBIND?

Thanks,
Travis
0
travbeavAuthor Commented:
One of our engineers had entered a manual "set TZ EST" entry into the common cshrc file that everyone uses, overriding the EST of the actual system clock. I finally found the problem.

Please go ahead and close this question out.
0
TintinCommented:
Well, I guess I was on the right track when I mentioned checking /etc/profile.

Do all your users have csh or tcsh as their default shell?  That's certainly unusual.
0
travbeavAuthor Commented:
Yes, the engineers here love csh and that's all they use.  

I will accept your answer as you did mention checking the user's profile.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.