Arcserve 11.1 SP2 wont recognize tape device HP Storageworks Ultrium-2

Hi there,

I just installed a new server 2003 SP2 ml370 G5 server. The old server is a ml370 G3 with windows 2003 SP1.

I took out the tape drive from the old ml370 and build it in into the new ml370. Its connected to a new, seperate scsi card.

I have installed the same version of Arcserve, 11.1 and updated it with SP2 for 11.1.

Now when I go to the device manager inside arcserve it sees the correct drive, a HP Storageworks Ultrium-2 device. I went to the HP site to download the original driver for the tape drive and installed it.

Now when I go to the device configuration, I see the device but I am unable to assign it! It looks like this:

I cant configure a backup job now because it gives me the error:

Cannot submit the run now job due to unavailable group or backup device.

Any ideas?

Who is Participating?
dovidmichelConnect With a Mentor Commented:
First thing to try is to disable the library and tape drive from within the OS Device Manager. ARCserve does not use media changer or tape drive drivers, it sends the SCSI commands to the SCSI Mini port provided by the controller driver. Tape device drivers can conflict with ARCserve and so they should be disabled.
phylaxictAuthor Commented:
Hi there,

first of all thanks a lot for trying to help me out.

I went to the device manager and disabled the tape drive. I rebooted the server, but still the same result. In the Computer Management overview, underneath Storage, I can see the library that belongs to the unit with a red cross through the icon. The properties showed me the enable checkbox was unmarked.

I rebooted the server, but still i have exactly the same problem.
Is this just a stand alone tape drive?
The image at the above link is for tape libraries, and so if all you have is a stand alone tape drive you do not run the Device Configuration tape library setup.
The new generation of project management tools

With’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

phylaxictAuthor Commented:
Yes its a standalone device. I'm used to working with Backup Exec and I must say this config is a bit confusing.

If I dont need to run the device configuration wizard, how do I add the tape drive to a backup job?

phylaxictAuthor Commented:
I would like to add to that:

Disabled the tape drive in device manager. Deleted the available library which I saw in Computer Management\Storage\Libraries

Rebooted the server

But still in the device manager I get to see this:
dovidmichelConnect With a Mentor Commented:
The ARCserve Device Manager window is not displaying the SCSI controller. If it does not see the SCSI controller is can't show the drive attached to it.

Go to the ARCserve Server Admin, Configuration, Tape Engine, set message level to detail.
Stop the Tape Engine
rename BrightStor ARCserve Backup\LOG\tape.log
start the Tape Engine.
After it has finished initializing copy that new log here.

I've seen this before with a HP system but was not involved in the resolution so I'll see if I can track it down, but the tape log will help to tell if this is the same problem.
Does the system have a IDE RAID adapter?
OK first off the problem is that the SCSI controller is not displayed.
I have seen three cases in two cases there was a NVIDIA IDE RAID controller. The driver for the NVIDIA controller prevented all access to the SCSI Mini port and so even though the Tape Engine was able to tell there was a SCSI controller it was not able to query it to obtain device information and so it was not displayed in the ARCserve Manager Device Window.

In the third case it was a HP ProLiant ML350 G5 and they were using ARCserve 10.5.
Check your tape.log for entries like this:
Windows NT SCSI Get Inquiry on \Scsi Port 2 Failed. MS=1
Failed to get inquiry for devices on board 2. Continuing with other boards

If they are in your log then at least we know it is the same problem. In that other case the resolution was upgrading to 11.5. In this case lets try updating 11.1 first with the latest Tape Engine updates.
QO84873 10.9 MB 12/18/06 NT -DEVICE SUPPORT UPDATE 9
QO84984 12.5 MB 01/11/07 NT -SECURITY UPDATE - TAPE ENGINE  

Have you tried running the standalone HP tape diags?

If you can't talk to the tape drive using a rudimentary low level diag,then the issue lies elseware and not within AS.
phylaxictAuthor Commented:
Hi there,

The problem has been resolved. Apparently SP2 for windows server 2003 caused the trouble. Removing SP2 for 2003 server has solved the problems.

Thanks a lot all for the support and helping us figuring this out. Points will go to dovidmichel for his assistance.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.