"Access is denied." when trying to access shares on another PC in workgroup

I get the following message when I try to open up another PC in 'View workgroup computers' to connect to a share -

Workgroup name

\\PC1 is not accessibe.  You might not have permission to use this network resource.  Contact the administrator of this server to find out if you have access permissions.

Access is denied.

I ran the Network Setup Wizard.  File and Printer Sharing is on on both PCs.  Both PCs are using the Windows Firewall and have an exception for File and Printer Sharing.  Both are XP Pro.  NetBIOS over TCP/IP is enabled on both PCs.  There is network connectivity.  I can ping the PC.  I can see the PC.  I'm trying to connect to a shared printer and install it.  Any ideas would be appreciated.  Thank you.
marathonman330Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sirbountyCommented:
See this PAQ - http://www.experts-exchange.com/Q_21014637.html

I've never really had good success with the network setup wizard.  Follow the steps outlined there and you should be good to go... :)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
marathonman330Author Commented:
Additional info - I am trying to connect via wireless.  PC1 (server) is connected to the router via ethernet.  PC2 is wireless.
0
Michael FrederickRegional IT Manager IIICommented:
This is a rights issue. You need to have the same user name and password on all machines in a Workgroup. That is the only way this will work.

If you need further help setting up users, please let me know.

Cheers
0
Hey MSSPs! What's your total cost of ownership?

WEBINAR: Managed security service providers often deploy & manage products from a variety of solution vendors. But is this really the best approach when it comes to saving time AND money? Join us on Aug. 15th to learn how you can improve your total cost of ownership today!

sirbountyCommented:
That is, in fact, a common misconception.
You can certainly use different usernames and passwords in a workgroup.
See the link I posted for details on that... :)
0
Michael FrederickRegional IT Manager IIICommented:
Yes you could do that, but why would you want to give 100% access to your systems? That is a huge security risk.
0
sirbountyCommented:
Um...I'm not sure what you're referring to.

It's more of a 'security risk' to give the same username and password to all systems than it is to use specific credentials per device.  It's more of a nuisance maybe, but certainly not a security risk...
0
marathonman330Author Commented:
I won't be able to try any of the suggestions until tomorrow but I have setup many workgroups and have always been able to share files and printers without giving a thought to usernames and passwords.  Thank you.
0
sirbountyCommented:
By default the network wizard sets you up with simple sharing...this is probably why.  One or more of the systems still has this enabled.

Start->Run->secpol.msc

From Security Options - Network Access: Sharing and security model - change that setting to be the same on all devices.  It's either classic - users authenticate as themselves or guest - users authenticate as guest (which if you want to share resources, you should disable the guest access anyway, since that can also be a security risk)
0
Michael FrederickRegional IT Manager IIICommented:
Your instructions are flawless and well writen.

My concern is:

* Let Everyone's permissions apply to anonymous users as well:
        Click Start->Run->SECPOL.MSC /S <ENTER>
        Navigate to Local Policies/Security Options.
        Double click "Network Access:Let Everyone permissions apply to anonymous users"
        Click Enabled and click OK

  * Enabling Guest account may be necessary:
       Click Start->Run->Lusrmgr.msc
         Open Users
         Double click Guest account
         Deselect Account is disabled (if selected)
         Click OK
1. Allowing anonymous to have everyone permissions? Security risk?
2. Enabling Guest account? Security Risk?

Please correct me if I am wrong.

Cheers
0
sirbountyCommented:
Presumably it's answered.

As for the other expert's comments on security risks - these instructions are steps to implement in succession.  In other words, enabling the guest account would be nearly a last resort.  The threat of either of these is certainly dependent upon your situation.  Certainly you don't want to give Everyone full control and then allow anonymous users to have that same access level...the assumption there is that Everyone has limited access to begin with (which is the default).
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
OS Security

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.