Solved

Help in setting up to Setup OWA on Exchange 2003.

Posted on 2007-03-19
15
189 Views
Last Modified: 2010-03-06
I need a little help in setting up to Setup OWA on Exchange 2003.

I created an CA, and I installed it, but now I get "The Page Cannot be diplayed.  Where as before, I was able to do http://servername/Exchange and get in.  I could not get in from the outside corectly.  If I did http://companyname.com/Exchange it would hang and not get the mail.

I need some guidance,

Thanks

Rick
0
Comment
Question by:rarnold_6951
  • 9
  • 6
15 Comments
 
LVL 10

Expert Comment

by:MATTHEW_L
ID: 18753746
What changes did you make to Exchange / IIS.  Just installing a CA should not change anything.
0
 

Author Comment

by:rarnold_6951
ID: 18757563
I don't think I made any. The only change I made was adding the CA.  there might have been something I did an inadvertant click on, but I don't think so.

Rick
0
 
LVL 10

Expert Comment

by:MATTHEW_L
ID: 18757743
On the Exchange server go into IIS MMC and make sure the web site is running, that is running on port 80.  Have you tried a reboot since the problems began and teh addition of the CA.
0
 

Author Comment

by:rarnold_6951
ID: 18764366
Matthew,

If I look at the default Website, it is running on port 80 and the SSL port is 443.  443 is routed to my mail server by my router and the IP address has not changed on the inside.

Rick
0
 
LVL 10

Expert Comment

by:MATTHEW_L
ID: 18765064
have you tried restart iis?

iisreset from the command prompt.
0
 

Author Comment

by:rarnold_6951
ID: 18770461
Thanks,

I tried your suggestion no luck.

Rick
0
 
LVL 10

Expert Comment

by:MATTHEW_L
ID: 18771716
You may try a reset of the Exchange virtual directories, but this seems to be more of a problem with IIS.  If you to go http://servername do you get anything?

http://support.microsoft.com/kb/883380
0
Promote certifications in your email signature

Has your company recently won an award or achieved a certification? They'll no doubt want to show it off. Email signature images used to promote certifications & awards can instantly establish credibility with a recipient and provide you with numerous benefits.

 

Author Comment

by:rarnold_6951
ID: 18772359
When I do that, I get the page must be viewed over a secure channel.  When I try to put an https://servername - page cannot be displayed
0
 
LVL 10

Expert Comment

by:MATTHEW_L
ID: 18772392
Ahhh.  Ok.  Go into IIS manager.  On your exchange virtual directories go to properties, go under directory security, go under edit toward the bottom of that page.  Remove the box for require SSL secure chanel.
0
 
LVL 10

Expert Comment

by:MATTHEW_L
ID: 18772398
What I think has happened is your IIS is set to only allow SSL, however the server probably doesnt have a certificate yet so SSL fails.
0
 
LVL 10

Expert Comment

by:MATTHEW_L
ID: 18772403
Make sure require SSL is turned off for the main web site and virtual directories.
0
 

Author Comment

by:rarnold_6951
ID: 18777056
Matthew,

Very Cool:  

That worked for the indside, but when I remoted into another computer to hit my domain name outside the domain,  I still get page can not be displayed. So http://myserver/exchange works, but http://domainName.com/Exchange doe not.

I did a ping against the domain name from the outside and then I checked it against what the router was reporting and they both matched.  The insde works, and I think the outside should too by taking SSL off but it does not.

Rick
0
 
LVL 10

Accepted Solution

by:
MATTHEW_L earned 500 total points
ID: 18777886
If it works from the inside then there must be something else going on.  Make sure your port forwarding, firewall, NAT etc are all configured correctly on the firewall.  You may also try the following

telnet domainname.com 80
get /index.html

You should get some kind of output to that, probably an error, but nevertheless it would tell you that IIS is responding.
0
 

Author Comment

by:rarnold_6951
ID: 18780462
It works from both places inside and outside now.  I went back to the router and port 80 was not open.   I opened up the port and now it works fine.  

The orginal thing I was trying to do was SSL to make sure it was secure communication between client and host.  OWA is a very nice tool

Thanks,

Rick
0
 
LVL 10

Expert Comment

by:MATTHEW_L
ID: 18780517
Good deal.

If you want to use SSL with OWA purchase a commerical cert.  It is much easier and will save you many countless headaches down the road.

www.godaddy.com
http://www.certificatesforexchange.com/

Not too badly priced either.
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

Utilizing an array to gracefully append to a list of EmailAddresses
ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
In this video we show how to create a Contact in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Contact ta…
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now