No Print Job with vista

I am having trouble with my Lexmark z625 printer printing documents. To the short the printer will send a message to the computer to print but no print job.  This is going on with the new windows vista. The printer prints fine with the older version of windows but not with vista. Could you please help?
cnandrewsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

DiMO2Commented:
I know this is going to sound really crass or rude but I mean it politely. Don't use Lexmark printers they are really crappy. I have seen problematic lexmark printers my entire history in computers. They always have one issue or another which is why they are typically "giveaway" printers that they throw in when you buy  prebuilt system. I know this doesn't solve your problem and I don't expect points for it. I'm just trying to give some solid advice from personal experience. Stay away from lexmark in the future. You'll thank me.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
5t34lth_G33kCommented:
You could search the Lexmark website for Vista drivers. I just looked and couldnt find the z625. I found the Z615 however, not sure if it is close to your model? Anyway, they didnt have Vista drivers, so it looks like you will either have to wait for certified Vista drivers, or get another printer

http://downloads.lexmark.com/cgi-perl/downloads.cgi?ccs=227:5:0:433:0:0&emeaframe=&target=http://downloads.lexmark.com/cgi-perl/downloads.cgi&target=http://downloads.lexmark.com/cgi-perl/downloads.cgi&&req=:::::

One other option is to try the Windows XP drivers - this is not supported and could make your situation worse, but can be worth trying as it sometimes works (it worked for my D Link wireless card, for example)
0
DiMO2Commented:
haha score you gave me points for that answer that offcially made my day!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Vista

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.