Solved

Cisco PtP connection IP changes

Posted on 2007-03-19
9
420 Views
Last Modified: 2010-04-17
I currently have a PtP connection with a cisco 1720 (remote site) and 2620 router (data center). The current running-config's are below. We have an issue with a voip device at the remote site, where we need it to be outside of the network. Our t1 provider gives us serveral external addresses, and we plan to make it so we can give the voip device an external address.

DATA CENTER ROUTER:

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname FTX_2620_DataCenter_Router
!

!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Multilink0
 no ip address
 no ip directed-broadcast
 no cdp enable
 ppp multilink
 multilink-group 0
!
interface Multilink1
 no ip address
 no ip directed-broadcast
 no cdp enable
 ppp multilink
 multilink-group 1
!
interface FastEthernet0/0
 description connected to EthernetLAN
 ip address 192.9.10.24 255.255.255.0
 no ip directed-broadcast
 duplex auto
 speed auto
!
interface Serial0/0
  ip address 10.1.1.1 255.255.255.252
 no ip directed-broadcast
 no ip mroute-cache
 service-module t1 clock source internal
 service-module t1 timeslots 1-24
 service-module t1 remote-alarm-enable
!
router rip
 version 2
 network 10.0.0.0
 network 192.9.10.0
 no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.9.100.254
ip http server
!
snmp-server engineID local 000000090200000628CB1B60
snmp-server community public RO
snmp-server location DataCenter
snmp-server contact Synergy,3056525699
!
line con 0
 exec-timeout 0 0
 login
 transport input none
line aux 0
line vty 0 4
 login
!
no scheduler allocate
end

REMOTE SITE ROUTER:

Current configuration : 1181 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname FTX_Remote_Router_1700
!
!
!
!
!
!
memory-size iomem 25
ip subnet-zero
ip dhcp excluded-address 192.17.17.254
ip dhcp excluded-address 192.17.17.1 192.17.17.49
ip dhcp excluded-address 192.17.17.151 192.17.17.254
!
ip dhcp pool 192.17.17.0/24
   network 192.17.17.0 255.255.255.0
   dns-server 192.9.10.10 192.9.10.13
   default-router 192.17.17.254
!
!
!
!
interface Multilink1
 no ip address
 no cdp enable
 ppp multilink
 multilink-group 1
!
interface Serial0
 description PTP to Finotex Data Center
 ip address 10.1.1.2 255.255.255.252
 service-module t1 remote-alarm-enable
!
interface FastEthernet0
 ip address 192.17.17.254 255.255.255.0
 no keepalive
 speed auto
 full-duplex
!
router rip
 version 2
 network 10.0.0.0
 network 192.17.17.0
 no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.1.1.1
ip http server
!
snmp-server community public RO
!
line con 0
line aux 0
line vty 0
 login
line vty 1 4
 login
!
end


Now, what i need is to give both routers each one of our available external addreses. like this:
Data Center Router IP: 66.175.103.249 255.255.255.240
REMOTE SITE Router IP: 66.175.103.253 255.255.255.240

I tried changing the IP's, but it will not seem to connect to each other anymore. although the serial line still is up.

What can I do to set this correctly?
0
Comment
Question by:syndev
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
9 Comments
 
LVL 50

Expert Comment

by:Don Johnston
ID: 18755423
Did you put in a network statement for RIP?

network 66.0.0.0
0
 

Author Comment

by:syndev
ID: 18755780
Yes, I added network 66.0.0.0 to both routers.

I set the following on the data center router and it seemed to allow me to connect to it both externally and insternally, so the issue now would to be to get the remote site up.

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname FTX_2620_DataCenter_Router
!

!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Multilink0
 no ip address
 no ip directed-broadcast
 no cdp enable
 ppp multilink
 multilink-group 0
!
interface Multilink1
 no ip address
 no ip directed-broadcast
 no cdp enable
 ppp multilink
 multilink-group 1
!
interface FastEthernet0/0
 description connected to EthernetLAN
 ip address 66.175.103.249 255.255.255.240
 no ip directed-broadcast
 duplex auto
 speed auto
!
interface Serial0/0
  ip address 10.1.1.1 255.255.255.252
 no ip directed-broadcast
 no ip mroute-cache
 service-module t1 clock source internal
 service-module t1 timeslots 1-24
 service-module t1 remote-alarm-enable
!
router rip
 version 2
 network 10.0.0.0
 network 66.0.0.0
 network 192.9.10.0
 no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 66.175.103.241 (this is our default router gateway)
ip http server
!
snmp-server engineID local 000000090200000628CB1B60
snmp-server community public RO
snmp-server location DataCenter
snmp-server contact Synergy,3056525699
!
line con 0
 exec-timeout 0 0
 login
 transport input none
line aux 0
line vty 0 4
 login
!
no scheduler allocate
end


Now, once I set the remote site router as 66.175.103.253 255.255.255.240, then i can no longer ping the data center router or default gateway. how must the remote site be configured?
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 18755818
What interface are you changing the IP on?

I assumed it was the serial interface.

You can't use those IP addresses on the fastethernet interfaces.
0
Webinar: Aligning, Automating, Winning

Join Dan Russo, Senior Manager of Operations Intelligence, for an in-depth discussion on how Dealertrack, leading provider of integrated digital solutions for the automotive industry, transformed their DevOps processes to increase collaboration and move with greater velocity.

 

Author Comment

by:syndev
ID: 18755843
No...i been changing the IP's  on the fastethernet interface's. Why cannot it be used on that?....can you give me an example of how it should look?
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 18755974
The IP addresses that you're trying to use are in the same network. You MUST use IP addresses for two different networks.

Are these networks connected to the public internet? If so, where and how?
0
 

Author Comment

by:syndev
ID: 18756000
Yes, they are public addresses given by our T1 provider, which is a set from 66.175.103.241-254

66.175.103.241 is the default gateway
The remote site is a dry ptp connection directly to the data center.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 18756054
So no internet connection?

If you're not connected to the internet, you don't need public IP addresses.

That said, if you want to use the public addresses, you'll either have to put them on the serial link, on one of the ethernet networks, or subnet it further and use them on both ethernet networks. Of course if you use the last option, you won't have many IP addresses for each network.

Why are you wanting to use the public IP addresses?
0
 

Author Comment

by:syndev
ID: 18756272
Well, the goal was to a VOIP gateway, which is located at the remote site, a public IP address without it having to route through the internal network first, because we were having problems with it going through the firewall. So we are trying to set the cisco devices on pulic IP's, then set a VPN through them via sonicwall's.

I dont mind keeping one of the cisco routers without a public address though. Preferably the Data Center router, I assumed they both would need to be on the same scope.

So what would you recommend is best?
0
 
LVL 50

Accepted Solution

by:
Don Johnston earned 500 total points
ID: 18757330
Public or private addresses aren't going to change anything. A VPN tunnel can be created to, from or through either public or private addresses.
 
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
WatchGuard T50 - Internet Priority Based on VLAN or User 1 87
Setting up a VPN 60 231
Local DNS and Home Routers 4 66
Mesh Router system for 10,000 Sq ft office? 18 22
It happens many times that access list (ACL) have to be applied to outgoing router interface in order to limit some traffic.This article is about how to test ACL from the router which is not very intuitive for everyone. Below scenario shows simple s…
Problem Description:   Couple of months ago we upgraded the ADSL line at our branch office from Home to Business line. The purpose of transforming the service to have static public IP’s. We were in need for public IP’s to publish our web resour…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

710 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question