SQL Server 2005 Connection Dialog question


I've just upgraded to Microsoft SQL Server 2005 Management Studio Express. I've noticed that each time I open a saved query the application displays the 'Connect to Database Engine' dialog and asks me to connect again. I'm sure this didn't happen when i first started using the software. Any ideas?

Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.


That's a standard 2005 "feature".  You're prompted to login with each saved file (even if opened in batches).  If you install SP2, they provided an option to always utilize the last active connection for each newly opened file.  That's about the only way around this issue...


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
molarAuthor Commented:
Thanks for the input.
The server is just the default instance on the local server. It's already registered so I don't think that that's the problem.

I've tried installting SP2 but I get the same problem. How do I get to the "always utilize the last active connection for each newly opened file" option?


Maybe I misunderstood you.  The patch fixes the issue when opening multiple scripting files, it utilizes the active connection.  I would assume that it would do the same for each individual file (as indicated by this post)

molarAuthor Commented:
I got the sql server 2005 connection to work. Downloaded SP2 from another link on the microsoft site and it seems to have fixed the problem.

Thanks dk
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server 2005

From novice to tech pro — start learning today.