Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Solaris 10 zone Solaris security toolkit - no ftp

Posted on 2007-03-20
4
Medium Priority
?
1,218 Views
Last Modified: 2013-12-27
Hi.
I've installed a new zone on my solaris 10. As I allmost allways do I run the Solaris Security Toolkit with jass-execute secure.driver
This turns off allmost everything I don't need, but for this zone I need ftp.
So, I ve done:
1. svcadm enable ftp  
2. netstat -a | grep LISTEN   = ftp is now LISTEN.  
3. svcs -v ftp      State=online
but then I try ftp localhost I get: 421 Service not available?
Any idea what I'm missing?
0
Comment
Question by:kristian_gr
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 16

Assisted Solution

by:Hanno P.S.
Hanno P.S. earned 668 total points
ID: 18756704
Did run the abovementioned commmands in your global zone or in the non-global zone you just installed?
0
 

Author Comment

by:kristian_gr
ID: 18756965
in the none-global zone. I don't want ftp in the global-zone.
I allso don't inherit any pkg-dir from the global zone.
0
 
LVL 22

Assisted Solution

by:blu
blu earned 332 total points
ID: 18844471
It sounds like you may need to configure the ftpaccess file under /etc in the local zone. The error message you are seeing happens anytime the server closes the connection to the client. This can happen if the ftpd was started with -a and the client is not in the ftpaccess file, or if inetadm is configured to run ftpd with tcp-wrappers turned on. I believe Sun Security Toolkit does the latter and
possibly the former as well. If it is tcp-wrappers, then you also need to look for a /etc/hosts.deny and /etc/hosts.allow file.
0
 
LVL 16

Accepted Solution

by:
Hanno P.S. earned 668 total points
ID: 19041530
did you try a
  # inetadm -e ftp
to enable the FTP server?
To disable it, use
  # inetadm -d ftp

You may want to check /etc/ftpd/* config files, too. Especially ftpusers
0

Featured Post

New benefit for Premium Members - Upgrade now!

Ready to get started with anonymous questions today? It's easy! Learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A metadevice consists of one or more devices (slices). It can be expanded by adding slices. Then, it can be grown to fill a larger space while the file system is in use. However, not all UNIX file systems (UFS) can be expanded this way. The conca…
Why Shell Scripting? Shell scripting is a powerful method of accessing UNIX systems and it is very flexible. Shell scripts are required when we want to execute a sequence of commands in Unix flavored operating systems. “Shell” is the command line i…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:

670 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question