• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1645
  • Last Modified:

Force all users login OWA using Domain\Username

We have a DC W2003 Server Std edition executing Exchange 2003 Server enterprise, with a Trust Domain DC NT4.0.
Users are in NT4.0 domain with a Trust Domain.
Owa is enabled.
After a migration from Exchange 5.5 to Exchange 2003 Server, old users from Exchange 5.5  can login to OWA using the sentence:
Username on NT 4.0 Domain
But, new mailboxes  must  login to OWA using the sentence:
Domain NT4.0 \ Username on NT 4.0 Domain.
After some testing, only if we disable Netbios name on new mailboxes is it possible to use the sentence:
Username on NT 4.0 Domain

The question is:  There is some policies to aplicate to Exchange to force all users login via OWA using the sentence?

Thank´s in advance.
1 Solution
edit your Logon.asp

In this article we will focus on the Logon.asp file for US English located in the USA folder
(C:\Program Files\Exchsrvr\exchweb\bin\auth\usa.)

Edit the Logon.asp file, therefore browse to and open the Logon.asp file in notepad (remember to make a backup of the file before editing it!). Find below code by pressing CTRL+F then search for <% If g_fIsMSIE5Rich Then %>  (Now press Find or F3 twice!):

<% If g_fIsMSIE5Rich Then %>
<BODY scroll="AUTO" bgColor="#3D5FA3" text="#000000" leftMargin=0 topMargin=0>
<FORM action="/exchweb/bin/auth/owaauth.dll" method="POST" name="logonForm" autocomplete="off">
<% Else %>
<BODY scroll="AUTO" bgColor="#FFFFFF" text="#000000" onload="window.document.logonForm.username.focus()">
<FORM action="/exchweb/bin/auth/owaauth.dll" method="POST" name="logonForm">
<% End If %>

In above code you should replace both instances of:

<FORM action="/exchweb/bin/auth/owaauth.dll" method="POST" name="logonForm" autocomplete="off">

With below piece of code:

<script Language=javascript>
function logonForm_onsubmit()
if (logonForm.username.value.indexOf("@") !=-1)
return true;
logonForm.username.value = "NetBIOS domain here\\" + logonForm.username.value;
  return false;
<FORM action="/exchweb/bin/auth/owaauth.dll" method="POST" name="logonForm" autocomplete="off" onsubmit="logonForm_onsubmit()">

Remember to replace NetBIOS domain here in above code with your own NetBIOS domain name (if your DNS name were Testdomain.com your NetBIOS name would be Testdomain.)
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now