Nokia E61 Mail for Exchange error - Invalid credentials

I have installed Exchange mobile on exchange 2003 SP2.
OWA is working as well as OMA as well as direct push from a Windows mobile device.
However from the nokia E61 I am always getting the error " Invalid mail for exchange credentials".

What could be the reason for that?
LVL 14
Ehab SalemIT ManagerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MATTHEW_LCommented:
A few things,

Are you using SSL on Exchange 2003, if so is it a home-grown certificate.

How are you entering your userid on the device?

username
password
domain.com

I have seen some people having luck with username@domain.com and then the password.

Do you have any other smart phones / pda's to test.  I found a cinular forum that may be of interest about your exact phone and problem.
0
Ehab SalemIT ManagerAuthor Commented:
No SSL
username is the logon username (not the email address)
password is password
domain.com
Will try username@domain.com and let you know.
Windows mobile phones are working (imate).
What is the forum you mentioned?
Thanks
0
MATTHEW_LCommented:
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

Ehab SalemIT ManagerAuthor Commented:
I tried all but no way!
0
MATTHEW_LCommented:
May very well be a problem with the phone since your other windows mobile phones are working.  I read one forum that a hard reset of the device and starting from scratch helped someone.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MATTHEW_LCommented:
Did the hard reset help you out?
0
Ehab SalemIT ManagerAuthor Commented:
Yes, thanks
0
Ehab SalemIT ManagerAuthor Commented:
Actually I did 2 things that solved the problem:
1- There was an error in the GPRS settings (proxy used for push mail is different than the WAP one!), I don't know why, but from the working devices I found that there are 2 internet settings, one used for browsing and one for push and POP.
When I made these changes to the E61, it started to hang when sync started instead of giving the credential error.
2- A hard reset and firmware update solved the problem.

I should have shared this info. Thank you for asking.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Cell Phones

From novice to tech pro — start learning today.