?
Solved

Cant connect to SQL Express Edition Witness

Posted on 2007-03-21
16
Medium Priority
?
794 Views
Last Modified: 2008-03-10
Hi,
I have implementing Database mirroring with two standard windows 2003 (64bit) servers running 2005 sql (64 bit). I have installed a SQL Express Edition on my Windows XP SP2 PC to act as a witness. But, when I try to connect to the witness PC from SQL Mgmt Studio from the principal server, it comes back with a an error saying that "By default, remote connections will be disabled, Microsoft SQL Server Error 2.

Can someone help. I tried everything in the following link
http://www.cryer.co.uk/brian/sqlserver/hresult_0x2%20npp_error_establishing_connection.htm
Thanks.
0
Comment
Question by:Cromwellhospital
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 9
  • 7
16 Comments
 
LVL 29

Expert Comment

by:Nightman
ID: 18764750
1. Try disabling windows firewall first to see if that is blocking connectivity.
2. Check that TCP is enabled, and running.
3. Can you connect from another machine?
0
 

Author Comment

by:Cromwellhospital
ID: 18765026
Firewall is disabled, TCP is enabled
I can ping my XP machine, but can't connect from SQL Mgmt Studio.
0
 
LVL 29

Expert Comment

by:Nightman
ID: 18765106
1. Have you enabled the remote connections using the Surface Area Configuration?
2. Are you connecting to a named instance or the default instance?
3. Are you connecting with windows authentication, and are the machines all on the same domain?
4. I am assuming that you can connect from Management Studio on the XP machine. Please can you confirm this.
5. can you telnet onto the TCP port on the XP "server" from one of the other servers?
0
Optimize your web performance

What's in the eBook?
- Full list of reasons for poor performance
- Ultimate measures to speed things up
- Primary web monitoring types
- KPIs you should be monitoring in order to increase your ROI

 

Author Comment

by:Cromwellhospital
ID: 18765244
I have enabled remote connections using SA Config
Default instance
Windows Authentication
Telnet on port 1433 onto the XP machine fails
And, how can I get Mgmt Studio in the XP machine? All I have is Configuration Tools.
0
 
LVL 29

Expert Comment

by:Nightman
ID: 18765313
You can download the Management Studio for Express from Microsoft (alternatively, you should be able to install the 32-bit Client Tools from the SQL Server Media).

Is SQL running on port 1433 on the XP box? It may not be, so you need to confirm this.
0
 

Author Comment

by:Cromwellhospital
ID: 18765480
The TCP/IP is enabled and the properties says that it is looking at port 1433.
0
 
LVL 29

Expert Comment

by:Nightman
ID: 18765516
If remote connections and TCP are enabled, and you can't even telnet to the port, then that suggests incorrect instance name, network connectivity or permissions.
0
 

Author Comment

by:Cromwellhospital
ID: 18770062
The instance name is sqlexpress on the express edition and I can ping the XP machine and I am trying to connect using a domain admin account !!!
0
 
LVL 29

Expert Comment

by:Nightman
ID: 18770081
I understand that. But the fact that you can't telnet to the port suggests that the either the service is not running, TCP is not enabled or there is something blocking the connection (such as windows firewall).
0
 

Author Comment

by:Cromwellhospital
ID: 18770190
I installed Mgmt Studio for SQL Express Edition in XP machine and I can't connect to the same instance. It throws the same error.

 "By default, remote connections will be disabled, Microsoft SQL Server Error 2.
0
 
LVL 29

Expert Comment

by:Nightman
ID: 18770205
1. Check to see if the SQL Service is running
2. Is named pipes enabled?
3. Are you connecting to MACHINENAME\SQLExpress (named instance)?
0
 

Author Comment

by:Cromwellhospital
ID: 18770599
Its connecting now both ways. But, when I try to add the witness, this error comes up

microsoft sql server, error 1498
0
 
LVL 29

Expert Comment

by:Nightman
ID: 18770636
Is that the entire error message?
0
 
LVL 29

Expert Comment

by:Nightman
ID: 18770643
Sorry - You are using the RTM version of SQL 2005 in which does not support mirroring.

Install SP1.
0
 

Author Comment

by:Cromwellhospital
ID: 18770654
And, I have installed SP1 for Express Edition.
0
 
LVL 29

Accepted Solution

by:
Nightman earned 2000 total points
ID: 18770665
Have you installed SP1 on all of the servers?
0

Featured Post

U.S. Department of Agriculture and Acronis Access

With the new era of mobile computing, smartphones and tablets, wireless communications and cloud services, the USDA sought to take advantage of a mobilized workforce and the blurring lines between personal and corporate computing resources.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

So every once in a while at work I am asked to export data from one table and insert it into another on a different server.  I hate doing this.  There's so many different tables and data types.  Some column data needs quoted and some doesn't.  What …
Use this article to create a batch file to backup a Microsoft SQL Server database to a Windows folder.  The folder can be on the local hard drive or on a network share.  This batch file will query the SQL server to get the current date & time and wi…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…
Visualize your data even better in Access queries. Given a date and a value, this lesson shows how to compare that value with the previous value, calculate the difference, and display a circle if the value is the same, an up triangle if it increased…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question