[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

Error attempting to auto mount /home directories to an NFS server under RedHat

Posted on 2007-03-21
7
Medium Priority
?
686 Views
Last Modified: 2013-12-16
Hi All,

I'm currently using RedHat 4 Enterprise Workstation 4 U4 for a small lab.

I've got a Fedora Core 6 File Server with an NFS share, and I'm simply exporting the /home directory on that server for the RH4Ent clients to auto.home their /home directories.

When I restart autofs I get:

failed to load map: "/usr/sbin/automount --timeout=60 /home[WARNING]c/auto.home"

So it will not automount the /home directory.

On the server I'm simply using corresponding users and groups.  In a test environment using all Fedora Core machines, it works without an issue.

Also, if I issue the command:

[root@tuw5 etc]# mount lfs1:/home /home/

It works without a problem and the NFS share on the LFS1 server is mounted to the local RedHat Ent 4 workstation.

What am I doing wrong?



Here are the files:

[root@tuw5 etc]# more auto.master
#
# $Id: auto.master,v 1.3 2003/09/29 08:22:35 raven Exp $
#
# Sample auto.master file
# This is an automounter map and it has the following format
# key [ -mount-options-separated-by-comma ] location
# For details of the format look at autofs(5).
#/misc  /etc/auto.misc --timeout=60
/misc   /etc/auto.misc
#/net   /etc/auto.net
/net    -hosts
/home   /etc/auto.home --timeout 300

[root@tuw5 etc]# more auto.home
* -fstype=nfs,soft,intr,rsize=8192,wsize=8192,nosuid,tcp lfs1:/home:&

0
Comment
Question by:gerhardub
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
7 Comments
 
LVL 38

Accepted Solution

by:
wesly_chen earned 2000 total points
ID: 18767051
> [root@tuw5 etc]# more auto.home
> * -fstype=nfs,soft,intr,rsize=8192,wsize=8192,nosuid,tcp lfs1:/home:&
change to
* -fstype=nfs,soft,intr,rsize=8192,wsize=8192,nosuid,tcp lfs1:/home/&

Besides, check your /etc/sysconfig/autofs and edit two options
--- /etc/sysconfig/autofs ---
LOCALOPTIONS="soft,intr,rsize=8192,wsize=8192,nosuid,tcp"
DAEMONOPTIONS="--timeout=300"
-------
Then you can change to /etc/auto.home
*  lfs1:/home/&
0
 
LVL 1

Author Comment

by:gerhardub
ID: 18767627
Thanks, I'll give that a try and tell you if it appears to work!!

Is this a syntax issue between RedHat and Fedora?
0
 
LVL 38

Expert Comment

by:wesly_chen
ID: 18767701
> Is this a syntax issue between RedHat and Fedora?
No, but there are some options difference for autofs in /etc/sysconfig/autofs since there is new feature update in autofs recently.
0
NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

 
LVL 1

Author Comment

by:gerhardub
ID: 18769002
Yeah, it was syntax based, I guess due to version, which is confusing.

Fedora Core 6 (which has a newer Kernel than RH Ent WS4 U4) uses:

* lfs1:/home /home:&

RedHat 4WS U4 uses:

* lfs1:/home /home/&

..and that appears to have been the issue.
0
 
LVL 1

Author Comment

by:gerhardub
ID: 18770661
Well, I'm still getting an error when I attempt to get RedHat to load the auto.home settings...

I'm going to open another ticket for this.  It works flawlessly on a new RedHat installation, so what is preventing this one from working?

The new case is here:

http://www.experts-exchange.com/OS/Linux/Q_22465459.html
0
 
LVL 38

Expert Comment

by:wesly_chen
ID: 18773562
> Fedora Core 6 (which has a newer Kernel than RH Ent WS4 U4) uses:
> * lfs1:/home /home:&
Mmm, I will try it on RHEL5 (based on FC6) to see if there is issue over there or not.
0
 
LVL 1

Author Comment

by:gerhardub
ID: 18775137
When I say "new" installation, I mean taking that last release of RH 4 Wks Ent U4 and isntalling that freash.  I then use one of the RH systems for the NFS server, and connect to it with the other.

Since I'm going from Fedora Core 6 (32bit) to RH 4 U4 (x86_64), I wonder if there is an incompatibility?

I wonder if they support the same versions of NFS, etc...
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

rdate is a Linux command and the network time protocol for immediate date and time setup from another machine. The clocks are synchronized by entering rdate with the -s switch (command without switch just checks the time but does not set anything). …
If you have a server on collocation with the super-fast CPU, that doesn't mean that you get it running at full power. Here is a preamble. When doing inventory of Linux servers, that I'm administering, I've found that some of them are running on l…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Suggested Courses
Course of the Month12 days, 23 hours left to enroll

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question