Link to home
Start Free TrialLog in
Avatar of leebaskin
leebaskinFlag for United States of America

asked on

Backup Exec 10.d to USB harddrive - Offline

I am using Backup Exec 10.d for my backup software; I am backing up to a USB hard drive. Every night when the backup is supposed to start the device goes from online to offline and the backup does not start until I put the device back online the next morning. Is there a way to have the backup automatically set the device to online state?? Or a better way to use the USB hard disk?
Avatar of Hedley Phillips
Hedley Phillips
Flag of United Kingdom of Great Britain and Northern Ireland image

Have you created a backup folder inside of the USB drive and then targeted that in the backup job?

Should just run and backup to that folder.

Few more ideas:

Have you checked the event logs for clues what is happening with the scheduled backup?

Are your tapes relatively new and write enabled? Have you tried Ntbackup on the same drive and media?

Check each service and make sure they all have the same Log On profile. It sounds like there is disagree among the services. If you have them set to the administrator, have you changed the administrator password recently. If you have you need to reset it on the services Log On profile.

If a target device or backup-to-disk folder goes offline while Backup Exec services are running, You might have to restart the services before the backup will run. We have to do this whenever we change USB hard drives (they are on a server remote to the one being backed up).

Avatar of leebaskin

ASKER

I change the USB disk every day with a different one (not Tape! its a removable disk). So, I have to unplug and plug in the disk every day. Will I need to create a folder on every disk?

Yes, I check the logs everytime but get just about the same msg. as the pop up error from backup exec.
Source: Backup Exec
EventID: 58057

NTBackup works ok with the same media


******   "If a target device or backup-to-disk folder goes offline while Backup Exec services are running, You might have to restart the services before the backup will run. We have to do this whenever we change USB hard drives (they are on a server remote to the one being backed up)." ********

This is what I am doing, after I change the drive I set the meda to "online" and let the scheduled backup start when it needs to.... when the backup starts that is when the media goes to "offline" until I go into devices and set it back to "online" then the backup starts....   problem is that when i do that the backup is running when users are logged in making changes to files........    


Avatar of AdamRobinson
AdamRobinson

Yes, you have to create a folder on every disk.  You also have to make sure that when you create the folder that your drive keeps the proper drive designation.

That is, if you have two drives and you create a folder that ends up as "E:\BEBackup\"  you will need to make sure the next time you try to backup to that drive that it keeps the E:\ drive designation.

The best way I'd suggest you do it (though it's highly dependent on your backup situation), is to leave one drive always connected.  Back up to a second drive (that you have the time to check correctly) on a scheduled date for off-site/protected storage.  

You know you'll always have your first drive there no matter what, and that the job won't fail.  The second you can tolerate failover for a shortened time period.  

This would work best with 3 - 4 drives, depending on the amount of data you're backing up.

>> Will I need to create a folder on every disk?

yes.

You are using the 'Removable Backup-to-Disk Devices' section rather than 'Backup-to-Disk Folders'?

I have just created a Removable Device from our USB drive:


- Removable Backup-to-Disk Devices
            |__ Iomega
                        |__FLDR000002

Backed up to it, removed it and did it again.
I cannot use the 'Removalble Backup-to-Disk folder' option, when I try to set it up I get this error popup box ~~> ( "The drive syntax is incorrect. A removable Backup-to-Disk must specify a drive only, with no path. Example "A:" )
 I can use the 'Backup-to-Disk folder' to backup it works just fine until I change out the disk.....    is there a script that I can run before the backup to set the media 'online?'
ASKER CERTIFIED SOLUTION
Avatar of Computer101
Computer101
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial