• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 498
  • Last Modified:

OWA access denied

Some of my users periodically travel. When at some locations, not all, and they try to access thier e-mail on my Exchange 2003 server via OWA, they are repeatedly prompted for their password. Finally OWA opens with the folder list pane on the left, however the reading pane is empty and displays access denied. Can someone please tell me what is causing this? Are my users behind a Proxy or firewall at the locations where this happens? How can I get them access to thier e-mail with OWA?

1 Solution
Might be that ports are blocked on the networks they they are at. Are they accessing from a hotel room or another company's intranet? Ports 80 HTTP and 443 SSL (if you are suing SSL) are required. Does this happen on another company's network only? Also, if you are usiing SSL, is it a certificate you created yourself, or one from 3rd party? If you are using SSL and have created your own certificate, have them try adding the "S" to the http. In other words, "https://mail.yourcompany.com/exchange" froman internet browser.

Good luck!  
Rob WilliamsCommented:
Just a suggestion; When the users connect, in the logon box there is an option under Client; Premium or Basic. Try the basic option when experiencing these problems. I have found some sites, presumably ones with less than perfect Internet performance, will give you "funky" results or partial displays. Reducing to basic allows proper access, though slightly simpler interface.
harold9153Author Commented:
This has happened at hotels rooms and on other company intranets. I'm not using SSL. I've tried the Basic option in the login box.
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Hmmm....This may be kind of along shot, but are there any other protocols besides TCP/IP bound to the network card? Check the properties of the net card from within My Net Places to make sure that IPX/SPX isn't bound to it. If it is, remove it and restart.
I digress...I guess itwouldn't matter over an Internet Exploder OWA connection.
Any reason you aren't using SSL?
That means your usernames and passwords are going across in the clear. If the users are regularly accessing the server from hotels and the like, then there could be all sorts of things going on. HTTP traffic is also prone to interference from proxies and cache. HTTPS traffic is not treated like that so can provide a better experience.

I agree with Sembee.  I've had some flaky experience running OWA exclusively through port 80.  I've also found that buying a certificate from an outside source is well worth the money.  The self-signed certificates that the server produces can cause problems if the device you are trying to access with cannot (or doesn't) display the "Are you sure you want to trust this site" dialogue.  Also, are your users trying to do anything else besides access OWA?  If they are using SharePoint you have to open up port 444 as well.
harold9153Author Commented:
I solved this and here's how. I have a Cisco 3000 VPN Concentrator to which my users often use make a connection to the internal LAN with the Cisco IPSec VPN client. I turned on the WebVPN feature on the Concentrator.

(In a WebVPN connection, the VPN Concentrator acts as a proxy between the end user's web browser and target web servers. When a WebVPN user connects to an SSL-enabled web server, the VPN Concentrator establishes a secure connection and validates the server's SSL certificate. The end user's browser never receives the presented certificate.)

The users types the public IP of the Concentrator in their browser to connect to the WebVPN. The VPN Concentrator creates a self-signed SSL server certificate when it boots that they have to accept. They login to the WebVPN using the same credientials as when they use the regular Cisco IPSec VPN client. Another screen come up into which they enter the URL for our OWA. Now then I'm not using SSL on my OWA server (though I am taking others advice and intend to) however OWA comes up without a problem. I suppose this "fools" any proxies, caches, etc.

Any thoughts?
PAQed with points refunded (500)

EE Admin
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Tackle projects and never again get stuck behind a technical roadblock.
Join Now