Job Step Proxy Account not available

Hi,

I want to set a proxy account for SQL Agent, that is available under SQL Agent Properties > Job System. But the problem is that the option for setting the proxy account is not available. It is there but i cannot set any value, because every option under Job Step Proxy Account is grayed out.

Please help me finding the reason why this option isn't availble. There must be some SQL Server configuration that is causing this but I am unable to find it.

Urgent help required.

Thanks & Regards,
Rehan
- Rattu
LVL 2
rattu976Asked:
Who is Participating?
 
cowanbenefitsConnect With a Mentor Commented:
You can't do it if the database is SQL 2005, per Microsoft:

 Use a non-administrator proxy account

    Sets a non-administrator proxy account for SQL Server Agent. Microsoft SQL Server 2005 supports multiple proxies, therefore this option is only applicable when managing SQL Server Agent versions prior to SQL Server 2005.

http://technet.microsoft.com/en-us/library/ms189727.aspx 

I am having a similar problem... SQL appears to be running jobs as the job owner, not as the Service account as it states. I do not want to give my job owner SA rights.
0
 
Daniel ReynoldsSoftware Applications Developer / IntegratorCommented:
Are you logged in as an administrator?
0
 
rattu976Author Commented:
I am logged as windows login with sysadmin rights over the server.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.