• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 779
  • Last Modified:

Vista's offline files.


I'm a bit lost with Windows Vista...  Here is the situation : laptop with Vista Business Edition, Server with SBS2003.  GPO redirects user's files to \\SERVER\USERS\%USERNAME%\MY DOCUMENTS.  So far so good.  Mapping then a disk (U: for instance) to \\SERVER\USERS\%USERNAME%\MY DOCUMENTS works fine.  

Now, with XP, automatically, My Documents was "available offline" therefore synchronised at logon/logoff.

On the Vista laptop, not only I cannot find the way to redirect the folder "User's Files" to a network drive, but I can't even make the U: drive available offline.  

This is where it gets weird, on some of the mapped drive, right-click, the option "make available offline" appears, and some other mapped drives, this option is nowhere to be seen ? (of course the only one I need is the U drive, murphy's law).

How can I then redirect the "User's Files" folder and how can I make it available offline once redirected ?

  • 2
1 Solution
You should still be able to use the same GPOs to redirect the Documents location to the server.  I have had some problems with some of my GPOs causing Vista not to work right unless converted to the new admx format.  You might want to try creating a new GPO from Vista GPM console and moving the computer or user to a separate container to test it out and make sure no other policies could be breaking it.  If you want to try manual redirection go to start then right click on the documents folder and select properties, it should be the second icon down on the top right.  The go to the location tab and you can put in a UNC path.

As for you other issue, some drives being able to be offline and other not.  Have you checked on your server to see if the "Users" share on the server has the correct "Offline settings"?  The default setting is "Only the files and programs that users specify will be available offline".  It might be possible that somehow this was changed to "Files or programs from the share will not be available offline.  You can access these settings from Computer Management under Shares.

In my testing on Vista you should be able to right click on your U: drive and select "Always available offline" to make the entire share available offline.  I don't have SBS2003 to test, but I think the options above should be the same.
polarisitAuthor Commented:
So I thought yeah... I'll give it a try anyways thanks StormyToad :)
polarisitAuthor Commented:
Txs Stormy somehow in my SBS box the offline settings for my \users\ folder had changed... Reverted and now it works.  Thanks mate.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Train for your Pen Testing Engineer Certification

Enroll today in this bundle of courses to gain experience in the logistics of pen testing, Linux fundamentals, vulnerability assessments, detecting live systems, and more! This series, valued at $3,000, is free for Premium members, Team Accounts, and Qualified Experts.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now