Solved

trouble receiving mail from outside world but can send

Posted on 2007-03-22
10
215 Views
Last Modified: 2008-01-09
Hi Experts

I have had my mx records changed on my internet domain www.aa.co.uk say to point to my IP address
When i do a MX lookup at http://www.mxtoolbox.com/index.aspx it confirms this (i think they set up a sub domain (mail.aa.co.uk).
When i do a mail test at the same site i get this:No connection could be made because the target machine actively refused it.
I have my ports open both ways on my router (netgear dg834) and firewall (sonic wall tz150) both ways
Not quite sure though if my  connector's configured correctly, as far as i know it is as i have done some reading on this subject.
I have anonymous access on the access tab
nothing in relay and only the list below selected
external dns setup
and unassigned ip selected
I can send mail out to a external account.
Okay here are a few logs that have appeared

#Fields: date time c-ip cs-username s-sitename s-computername s-ip s-port cs-method cs-uri-stem cs-uri-query sc-status sc-win32-status sc-bytes cs-bytes time-taken cs-version cs-host cs(User-Agent) cs(Cookie) cs(Referer)
2007-03-22 09:50:02 172.17.26.1 - SMTPSVC1 PLUTO 172.16.26.1 0 QUIT - - 240 43266 127 0 43266 SMTP - - - -
                     


Can anyone advise me on this situation??

Also related to this do i have to create a actual dns record on my SBS server relating to www.aa.co.uk
and the ip address of the hosted site.
0
Comment
Question by:rmfb
  • 7
  • 2
10 Comments
 
LVL 22

Expert Comment

by:Olaf De Ceuster
ID: 18770046
Run the internet connection wizard (You can run this as many times as you like) in Server Management> To do list> Point 2 to set up email access.
Here is how: http://www.sbs-rocks.com/sbs2k3/sbs2k3-n2.htm
Hope this help,
Olaf
0
 
LVL 8

Expert Comment

by:jsvor
ID: 18770149
Go to dnsreports and run the dns and mail settings tests.  (http://www.dnsreport.com/)

You can also check out this link on Microsoft's page to test your exchange server: http://technet.microsoft.com/en-us/library/003e4901-884f-4bc7-b3c3-557add4e5c3a.aspx.
0
 

Author Comment

by:rmfb
ID: 18770240
Hi guys this is what i get from dns report

Failed
ERROR: I could not complete a connection to any of your mailservers!

mail.xtranet-itsolutions.co.uk: The mailserver terminated the connection before the transaction was complete (state 7). This is not RFC compliant, and therefore either due to an error, or it may be the result of a non-RFC-compliant mailserver or non-RFC-compliant anti-spam program.

If this is a timeout problem, note that the DNS report only waits about 40 seconds for responses, so your mail *may* work fine in this case but you will need to use testing tools specifically designed for such situations to be certain.
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 

Author Comment

by:rmfb
ID: 18770249
this is what i get for mail server test
Host Preference IP(s) [Country] mx00.1and1.co.uk. 10 212.227.15.186 [DE]212.227.15.169 [DE]212.227.15.150 [DE]212.227.15.134 [DE] mx01.1and1.co.uk. 10 212.227.15.134 [DE]212.227.15.186 [DE]212.227.15.169 [DE]212.227.15.150 [DE] --------------------------------------------------------------------------------


Step 1:  Try connecting to all of these (in the order as returned by the DNS resolver, per RFC1123 5.3.4):
         mx00.1and1.co.uk. - 212.227.15.186
         mx00.1and1.co.uk. - 212.227.15.169
         mx00.1and1.co.uk. - 212.227.15.150
         mx00.1and1.co.uk. - 212.227.15.134
         mx01.1and1.co.uk. - 212.227.15.134
         mx01.1and1.co.uk. - 212.227.15.186
         mx01.1and1.co.uk. - 212.227.15.169
         mx01.1and1.co.uk. - 212.227.15.150
This is not my ip though and i dont understand why as the other post goes to mail.xtranet-itsolutions.co.uk ip address =mine and reverse dns passes etc
0
 

Author Comment

by:rmfb
ID: 18770329
Hi

okay telnet session says
connecting aa.co.uk.. coul;d not open connection to the host port 23..connection failed

0
 

Author Comment

by:rmfb
ID: 18770535
Here are some more logs
#Fields: date time c-ip cs-username s-sitename s-computername s-ip s-port cs-method cs-uri-stem cs-uri-query sc-status sc-win32-status sc-bytes cs-bytes time-taken cs-version cs-host cs(User-Agent) cs(Cookie) cs(Referer)
2007-03-22 11:07:43 217.146.189.93 web23408.mail.ird.yahoo.com SMTPSVC1 PLUTO 172.17.26.1 0 HELO - +web23408.mail.ird.yahoo.com 250 0 54 32 47 SMTP - - - -
2007-03-22 11:07:43 217.146.189.93 web23408.mail.ird.yahoo.com SMTPSVC1 PLUTO 172.17.26.1 0 MAIL - +FROM:<jimjam_r@yahoo.co.uk> 250 0 45 32 250 SMTP - - - -
2007-03-22 11:07:43 217.146.189.93 web23408.mail.ird.yahoo.com SMTPSVC1 PLUTO 172.17.26.1 0 RCPT - +TO:<rflint@xtranet-itsolutions.co.uk> 250 0 0 42 0 SMTP - - - -
2007-03-22 11:07:50 217.146.189.93 web23408.mail.ird.yahoo.com SMTPSVC1 PLUTO 172.17.26.1 0 QUIT - web23408.mail.ird.yahoo.com 240 6812 74 4 0 SMTP - - - -
2007-03-22 11:09:44 66.36.241.109 test.DNSreport.com SMTPSVC1 PLUTO 172.17.26.1 0 HELO - +test.DNSreport.com 250 0 53 23 109 SMTP - - - -
2007-03-22 11:09:44 66.36.241.109 test.DNSreport.com SMTPSVC1 PLUTO 172.17.26.1 0 MAIL - +FROM:<> 250 0 27 12 0 SMTP - - - -
2007-03-22 11:09:44 66.36.241.109 test.DNSreport.com SMTPSVC1 PLUTO 172.17.26.1 0 RCPT - +TO:<postmaster@xtranet-itsolutions.co.uk> 250 0 0 46 0 SMTP - - - -
2007-03-22 11:09:50 66.36.241.109 test.DNSreport.com SMTPSVC1 PLUTO 172.17.26.1 0 RCPT - +TO:<abuse@xtranet-itsolutions.co.uk> 550 0 0 41 5000 SMTP - - - -
2007-03-22 11:09:55 66.36.241.109 test.DNSreport.com SMTPSVC1 PLUTO 172.17.26.1 0 RCPT - +TO:<postmaster@[62.3.230.195]> 550 0 0 35 5016 SMTP - - - -
2007-03-22 11:09:55 66.36.241.109 test.DNSreport.com SMTPSVC1 PLUTO 172.17.26.1 0 QUIT - test.DNSreport.com 240 11141 57 35 5016 SMTP - - - -
2007-03-22 11:13:58 125.225.6.152 - SMTPSVC1 PLUTO 172.17.26.1 0 QUIT - - 240 16 184 35 16 SMTP - - - -
0
 

Author Comment

by:rmfb
ID: 18770733
Hmm Mail now seems to have resumed and comming in ok

you could figure that could you
0
 
LVL 8

Accepted Solution

by:
jsvor earned 500 total points
ID: 18772750
I wonder if your DNS records got messed up somewhere along the lines.  Now that you are receiving mail do the tests at dnsreports show that everything is OK with your setup?
0
 

Author Comment

by:rmfb
ID: 18784765
Hi

Sorry i have not replied been away.
Yes have done the tests and everything A OK.
I think you may have been right about the dns settings somewhere along the line.

Many thanks though for your input
0
 

Author Comment

by:rmfb
ID: 19126109
Asking Mod to close question and refund points as no help needed problem corrected itself
0

Featured Post

Optimizing Cloud Backup for Low Bandwidth

With cloud storage prices going down a growing number of SMBs start to use it for backup storage. Unfortunately, business data volume rarely fits the average Internet speed. This article provides an overview of main Internet speed challenges and reveals backup best practices.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

This process describes the steps required to Import and Export data from and to .pst files using Exchange 2010. We can use these steps to export data from a user to a .pst file, import data back to the same or a different user, or even import data t…
This article explains how to install and use the NTBackup utility that comes with Windows Server.
To show how to generate a certificate request in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Servers >> Certificates…
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…

808 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question