trouble receiving mail from outside world but can send

Hi Experts

I have had my mx records changed on my internet domain www.aa.co.uk say to point to my IP address
When i do a MX lookup at http://www.mxtoolbox.com/index.aspx it confirms this (i think they set up a sub domain (mail.aa.co.uk).
When i do a mail test at the same site i get this:No connection could be made because the target machine actively refused it.
I have my ports open both ways on my router (netgear dg834) and firewall (sonic wall tz150) both ways
Not quite sure though if my  connector's configured correctly, as far as i know it is as i have done some reading on this subject.
I have anonymous access on the access tab
nothing in relay and only the list below selected
external dns setup
and unassigned ip selected
I can send mail out to a external account.
Okay here are a few logs that have appeared

#Fields: date time c-ip cs-username s-sitename s-computername s-ip s-port cs-method cs-uri-stem cs-uri-query sc-status sc-win32-status sc-bytes cs-bytes time-taken cs-version cs-host cs(User-Agent) cs(Cookie) cs(Referer)
2007-03-22 09:50:02 172.17.26.1 - SMTPSVC1 PLUTO 172.16.26.1 0 QUIT - - 240 43266 127 0 43266 SMTP - - - -
                     


Can anyone advise me on this situation??

Also related to this do i have to create a actual dns record on my SBS server relating to www.aa.co.uk
and the ip address of the hosted site.
rmfbAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Olaf De CeusterCommented:
Run the internet connection wizard (You can run this as many times as you like) in Server Management> To do list> Point 2 to set up email access.
Here is how: http://www.sbs-rocks.com/sbs2k3/sbs2k3-n2.htm
Hope this help,
Olaf
0
jsvorCommented:
Go to dnsreports and run the dns and mail settings tests.  (http://www.dnsreport.com/)

You can also check out this link on Microsoft's page to test your exchange server: http://technet.microsoft.com/en-us/library/003e4901-884f-4bc7-b3c3-557add4e5c3a.aspx.
0
rmfbAuthor Commented:
Hi guys this is what i get from dns report

Failed
ERROR: I could not complete a connection to any of your mailservers!

mail.xtranet-itsolutions.co.uk: The mailserver terminated the connection before the transaction was complete (state 7). This is not RFC compliant, and therefore either due to an error, or it may be the result of a non-RFC-compliant mailserver or non-RFC-compliant anti-spam program.

If this is a timeout problem, note that the DNS report only waits about 40 seconds for responses, so your mail *may* work fine in this case but you will need to use testing tools specifically designed for such situations to be certain.
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

rmfbAuthor Commented:
this is what i get for mail server test
Host Preference IP(s) [Country] mx00.1and1.co.uk. 10 212.227.15.186 [DE]212.227.15.169 [DE]212.227.15.150 [DE]212.227.15.134 [DE] mx01.1and1.co.uk. 10 212.227.15.134 [DE]212.227.15.186 [DE]212.227.15.169 [DE]212.227.15.150 [DE] --------------------------------------------------------------------------------


Step 1:  Try connecting to all of these (in the order as returned by the DNS resolver, per RFC1123 5.3.4):
         mx00.1and1.co.uk. - 212.227.15.186
         mx00.1and1.co.uk. - 212.227.15.169
         mx00.1and1.co.uk. - 212.227.15.150
         mx00.1and1.co.uk. - 212.227.15.134
         mx01.1and1.co.uk. - 212.227.15.134
         mx01.1and1.co.uk. - 212.227.15.186
         mx01.1and1.co.uk. - 212.227.15.169
         mx01.1and1.co.uk. - 212.227.15.150
This is not my ip though and i dont understand why as the other post goes to mail.xtranet-itsolutions.co.uk ip address =mine and reverse dns passes etc
0
rmfbAuthor Commented:
Hi

okay telnet session says
connecting aa.co.uk.. coul;d not open connection to the host port 23..connection failed

0
rmfbAuthor Commented:
Here are some more logs
#Fields: date time c-ip cs-username s-sitename s-computername s-ip s-port cs-method cs-uri-stem cs-uri-query sc-status sc-win32-status sc-bytes cs-bytes time-taken cs-version cs-host cs(User-Agent) cs(Cookie) cs(Referer)
2007-03-22 11:07:43 217.146.189.93 web23408.mail.ird.yahoo.com SMTPSVC1 PLUTO 172.17.26.1 0 HELO - +web23408.mail.ird.yahoo.com 250 0 54 32 47 SMTP - - - -
2007-03-22 11:07:43 217.146.189.93 web23408.mail.ird.yahoo.com SMTPSVC1 PLUTO 172.17.26.1 0 MAIL - +FROM:<jimjam_r@yahoo.co.uk> 250 0 45 32 250 SMTP - - - -
2007-03-22 11:07:43 217.146.189.93 web23408.mail.ird.yahoo.com SMTPSVC1 PLUTO 172.17.26.1 0 RCPT - +TO:<rflint@xtranet-itsolutions.co.uk> 250 0 0 42 0 SMTP - - - -
2007-03-22 11:07:50 217.146.189.93 web23408.mail.ird.yahoo.com SMTPSVC1 PLUTO 172.17.26.1 0 QUIT - web23408.mail.ird.yahoo.com 240 6812 74 4 0 SMTP - - - -
2007-03-22 11:09:44 66.36.241.109 test.DNSreport.com SMTPSVC1 PLUTO 172.17.26.1 0 HELO - +test.DNSreport.com 250 0 53 23 109 SMTP - - - -
2007-03-22 11:09:44 66.36.241.109 test.DNSreport.com SMTPSVC1 PLUTO 172.17.26.1 0 MAIL - +FROM:<> 250 0 27 12 0 SMTP - - - -
2007-03-22 11:09:44 66.36.241.109 test.DNSreport.com SMTPSVC1 PLUTO 172.17.26.1 0 RCPT - +TO:<postmaster@xtranet-itsolutions.co.uk> 250 0 0 46 0 SMTP - - - -
2007-03-22 11:09:50 66.36.241.109 test.DNSreport.com SMTPSVC1 PLUTO 172.17.26.1 0 RCPT - +TO:<abuse@xtranet-itsolutions.co.uk> 550 0 0 41 5000 SMTP - - - -
2007-03-22 11:09:55 66.36.241.109 test.DNSreport.com SMTPSVC1 PLUTO 172.17.26.1 0 RCPT - +TO:<postmaster@[62.3.230.195]> 550 0 0 35 5016 SMTP - - - -
2007-03-22 11:09:55 66.36.241.109 test.DNSreport.com SMTPSVC1 PLUTO 172.17.26.1 0 QUIT - test.DNSreport.com 240 11141 57 35 5016 SMTP - - - -
2007-03-22 11:13:58 125.225.6.152 - SMTPSVC1 PLUTO 172.17.26.1 0 QUIT - - 240 16 184 35 16 SMTP - - - -
0
rmfbAuthor Commented:
Hmm Mail now seems to have resumed and comming in ok

you could figure that could you
0
jsvorCommented:
I wonder if your DNS records got messed up somewhere along the lines.  Now that you are receiving mail do the tests at dnsreports show that everything is OK with your setup?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rmfbAuthor Commented:
Hi

Sorry i have not replied been away.
Yes have done the tests and everything A OK.
I think you may have been right about the dns settings somewhere along the line.

Many thanks though for your input
0
rmfbAuthor Commented:
Asking Mod to close question and refund points as no help needed problem corrected itself
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.