Unable to obtain IP address without restarting router

I've installed a wireless network at a clients' house. Everything was working fine for several months. Recently I reinstalled one of the computers with windows XP home, then reconnected it to the network. Everything seemed fine. Shortly afterwards the client reported that they were unable to connect to the internet on the newly reinstalled computer.

I took a look at the setup and found that after after a restart there would be a strong wireless signal, but that it would be unable to obtain an IP address. Other wired and wireless computers on the network were able to connect without issue. The only way to re-establish the broken connection was to restart the router.

Router: BT home hub (built in wireless access point)

Computer 1: desktop - connected by ethernet (allways works)
Computer 2: laptop - connected wirelessly (not sure which card it's got) (allways works)
Computer 3: desktop - connected wirelessly with Belkin USB wireless G (problem connection)

All computers are set to receive an IP address automatically.
The problem computer has a strong wireless signal.
WPA-PSK encryption in use

Can anyone help me work out what is causing this problem? Part of me thinks that it must be something to do with the router, but it's just a bit odd that it started happening immediately after a reinstall.

Thanks
PhilipkAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

stergiumCommented:
hello Philipk. i suggest that you try changing the wireless channel. i know it must sound awkward but give it a try. one of my clients had the same problem and it came up that another wireless network that was close created the problem.  please feed back
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
LimeSMJCommented:
If the hardware and operating system were the same before and after on the problem computer, the problem you are describing would most likely be caused by a driver issue.  If there were changes made to the hardware or OS, please advise.
0
PhilipkAuthor Commented:
"i suggest that you try changing the wireless channel"
I've changed the wireless channel from 6 to 11. I read on some sites that the hub has problems on the lower channels, specifically channel 1. I did that last night via remote access, but have not had any feedback yet from the client as to its effectiveness.

"If there were changes made to the hardware or OS, please advise"
No changes made to the drivers or OS. I installed the drivers for the wireless card from the same disk as before. I also tried downloading the latest drivers from the Belkin website, but it did not solve the problem.

I'm going to the clients' now to take another look, I'll post the results here a little later. Any further suggestions greatly appreciated!
0
MSSPs - Are you paying too much?

WEBINAR: Managed security service providers often deploy & manage products from a variety of solution vendors. But is this really the best approach when it comes to saving time AND money? Join us on Aug. 15th to learn how you can improve your total cost of ownership today!

CGretskiCommented:
Does the client/router have an option to automatically choose channel, if so disable this and set everything to one specific channel, as 1/2 may be roaming between channels whilst the other is hard-coded.
0
PhilipkAuthor Commented:
"Does the client/router have an option to automatically choose channel, if so disable this and set everything to one specific channel, as 1/2 may be roaming between channels whilst the other is hard-coded."

It was set to automatic, but I think on this router that means it automatically chooses channel 6!

I've manually set the router to channel 11, and I've set the problem pc's IP address to a static one outside the router's dhcp pool. I restarted the problem pc countless times and each time it was able to connect to the network successfully. However - I'm waiting to hear back from the client as to the effectiveness of these changes after extended use.

I'll post back here when I have further information, hopefully before the end of the week.

Thanks for all your suggestions.

Phil
0
PhilipkAuthor Commented:
Hi,

Finally, after a few weeks of testing, the client has reported that the internet connection is working consistently.

Thanks for all your suggestions.

Regards,
Philip
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Wireless Networking

From novice to tech pro — start learning today.