• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 291
  • Last Modified:

VPN tunnel connected, but unable to access shared folders on computers at the other end.

OS- Windows XP
Router- Linksys RV016
I am trying to establish a VPN connection between two offices using a Linksys RV016 router on both ends.  These are the only routers in use at either location.  The tunnel has been established and I am able to ping pc's at the other location.  I was even able to print to a printer at the other office.  However, I am unable to gain access to shared folders.  All the computers at both location are apart of the same workgroup.

I also set up remote VPN on my laptop running Windows Vista and I'm able to gain access to shared folders on computers at either end with no problem.
0
kzackery
Asked:
kzackery
  • 3
  • 2
1 Solution
 
Rob WilliamsCommented:
-Both sites must to use different local subnets, i.e. they cannot not both be 192.168.1.x as an example. If so you will not be able to connect to resources
-name resolution over a VPN can be problematic. We can deal with that, but as a test can you connect to a PC or share using the IP address such as
\\192.168.123.123\ShareName ?
-you need to connect as a user that has permissions to access the share. i.e you need to be logged on remotely with a user name and password exactly the same as on the machine you are connecting to. However, if not it "should" prompt you for an appropriate user name and password.
-the Windows firewall, or any other software firewall, will block you from connecting from a different subnet, by default. Try disabling at least as a test, on the machine to which you are connecting.
0
 
kzackeryAuthor Commented:
-I have both sites on different local subnets.

-I can on only connect using the IP address when I'm working from my laptop.

-I'll try to drop the windows firewall when I go back to the other location.

Thanks
0
 
Rob WilliamsCommented:
Could well be the firewall/s. The Vista mobile client may have been assigned an IP in a different subnet and be seen differently by the firewall.
The Windows firewall, by default, when you enable file and print sharing, allows access only from the local network (i.e. same subnet). As a test I would just turn it off, but if that resolves you could add your subnet as an approved network. To do so go to:
Control Panel | Network connections | right click on the network adapter and choose properties | advanced | settings | exceptions | highlight file and print sharing and click edit | for each of the 4 ports, highlight the port and choose change scope | either select "any computer including those on the Internet" or "custom list" and add your remote subnet using something like 192.168.123.0/255.255.255.0

The fact that you could connect to the printer re-enforces the firewall possibility as it would not have it's own firewall.
0
 
kzackeryAuthor Commented:
Kudos to you RobWill, that fixed my problem.  After I readjusted the settings on the windows firewall everything worked perfectly.

Thanks
0
 
Rob WilliamsCommented:
Great, glad to hear.
Thanks kzackery,
--Rob
0

Featured Post

Get quick recovery of individual SharePoint items

Free tool – Veeam Explorer for Microsoft SharePoint, enables fast, easy restores of SharePoint sites, documents, libraries and lists — all with no agents to manage and no additional licenses to buy.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now