Automatically rebooting clients using WSUS

I have just installed and configured WSUS using GPO.  So far it is detecting computers and downloading updates great.  In my GPO I have it set to autodownload and schedule the installation for 12:00 a.m.  My question is how do I get the system to automatically reboot.  I know it will prompt but that delays the installation until the morning when the user gets in the office.
magarnerAsked:
Who is Participating?
 
Rob WilliamsConnect With a Mentor Commented:
There is a policy which will force the reboot. Disabling or leaving un-configured will enforce:
Computer configuration | administrative templates | Windows components | Windows Update | "no auto restart for scheduled automatic updates installations"
If a user is logged on it will give them a 5 minute warning.
Note: this will remind logged on admins, but not force a reboot.
If the policy is disabled, it will ask them to reboot, but not force it.
You can also use the enable option and set a reoccurring reminder for the logged on user with the GPO "re-prompt for restart with scheduled installations'
0
 
stiddyCommented:
If the user has local admin rights nothing can really be done except you would have to log off that user prior to 12:00am. We have instituted that in our factility where every user must log off COB or they will be logged off.

If the users do not have administrative rights then change the GPO setting "to not allow non-admin users" the option to see the shield pop ups.
0
 
magarnerAuthor Commented:
Robwill - So what you are saying is if that policy is left not configure (which it is) then the non admin users will be given a 5 minute window and if they do nothing because they are not here it will reboot?
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
Rob WilliamsCommented:
Correct. Also if they are not logged on, it should reboot right away.

Make sure you do not configure this way for your servers. You want to make sure you only allow a ,manual reboot for them.
I often create different policies for servers, workstations and laptops (out of the office).
0
 
magarnerAuthor Commented:
I am not sure how to create different policies for servers vs. users.  But I am using WSUS - so I put the servers in their own group which is set to detect only.  Tonight is the test I will let you know if the clients reboot or not.
0
 
Rob WilliamsCommented:
To create different policies you do so in the same way, but put servers in one OU with one WSUS policy and workstations in another OU with a second WSUS policy.

Let us know how it goes. Timing with WSUS can be odd sometimes. If you are detecting updates and applying the same day, sometimes the updates won't be applied until the next install day. If daily, 24 hours.
0
 
magarnerAuthor Commented:
Thanks for you help - the reboot worked.
0
 
Rob WilliamsCommented:
Excellent..."love it when a plan comes together"  <G>
Thanks magarner,
--Rob
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.