Solved

Error in /var/adm/messages

Posted on 2007-03-22
3
1,510 Views
Last Modified: 2013-12-27
/# uname -a
SunOS jaws2 5.9 Generic_118558-34 sun4u sparc SUNW,Sun-Fire-480R

This is one of the 2-node clustered machine.
We have been getting errors in /var/adm/messages on jaws2 as below.
 Mar 21 16:02:16 jaws2 automountd[16114]: [ID 784820 daemon.error]
 server jaws not responding Mar 21 16:02:19 jaws2 last message repeated 1 time

The automount works fine and also the connectivity to the external NAS storage is fine. We have restarted the automount daemon, restarted syslog service but the problem still persists.

Is there anyway we can get rid of these messages which pops up every 10 minutes?

thnks in advance
0
Comment
Question by:sriniajay
3 Comments
 
LVL 38

Accepted Solution

by:
yuzh earned 500 total points
ID: 18776148
check if your NFS server  jaws  is overloaded?

What version of OS is ruuning on jaws, how many NFS clients in the network?

make sure your OS patch lever is up-to-date

if your have a large number of NFS client, consider to modify the NFS
configuration file /etc/default/nfs (Solaris 9,  for Solaris 8 or older
modif /etc/rc3.d/S15nfs.server  the "nfsd -a Value" )
change NFSD_SERVERS=16 to a bigger value, eg 32

then restart the nfs server
 /etc/rc3.d/S15nfs.server stop
/etc/rc3.d/S15nfs.server start
0
 
LVL 27

Expert Comment

by:Nopius
ID: 18790043
sriniajay, please provice us the content of /etc/auto_master and /etc/auto_* files.
Is 'jaws' a virtual cluster IP or physical IP of another cluster node?
Is NFS service condifured in cluster environment?
If 'jaws' is a virtual IP, on which node NFS service (I guess in failover mode) is currently running ?
0
 

Author Comment

by:sriniajay
ID: 18794747
Nopius, here's the output for the files you needed. Jaws is the virtual ip for the jaws cluster(jaws1& jaws2). Yes, autofs is configured on this cluster envrionment. Jaws1 is the online node now.
/etc# ls auto_*
auto_home     auto_master

/etc# more auto_master
# Master map for automounter
#
+auto_master
/net            -hosts          -nosuid,nobrowse,rsize=32768,wsize=32768,hard
/user           auto_home       -nosuid,nobrowse
/xfn            -xfn

/etc# more auto_home
# Home directory map for automounter
#
+auto_home
0

Featured Post

Courses: Start Training Online With Pros, Today

Brush up on the basics or master the advanced techniques required to earn essential industry certifications, with Courses. Enroll in a course and start learning today. Training topics range from Android App Dev to the Xen Virtualization Platform.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Attention: This article will no longer be maintained. If you have any questions, please feel free to mail me. jgh@FreeBSD.org Please see http://www.freebsd.org/doc/en_US.ISO8859-1/articles/freebsd-update-server/ for the updated article. It is avail…
Java performance on Solaris - Managing CPUs There are various resource controls in operating system which directly/indirectly influence the performance of application. one of the most important resource controls is "CPU".   In a multithreaded…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
This video shows how to set up a shell script to accept a positional parameter when called, pass that to a SQL script, accept the output from the statement back and then manipulate it in the Shell.

786 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question