Event ID 5504 Exchange 2000 server

I'm getting numerous Event ID 5504 (every couple of minutes) and an a couple Event ID 9999.

It's on an Exchange 2000 server - DC - service pack 4. Forwarders are enabled with my ISP DNS servers.

Email and internet is working fine. Just hundreds of these warnings.

Event Type: Warning
Event Source: DNS
Event Category: None
Event ID: 5504
User: N/A
Computer: Computer_name
Description: The DNS server encountered an invalid domain name in a packet from IP_Address.
The packet is rejected.

The IP address in all these warnings are the same - IP address of ISP DNS server (ATT)

I tried using different DNS servers in the forwarders, but same problem.

TCP/IP settings are pointing to itself on the server for DNS.

I've tried many of the solutions from the search here, but haven't found a solution.

Please help. Thanks.
lordshin808Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

poweruser32Commented:
look at this link as it says it applies to win 2000 as well http://support.microsoft.com/kb/920162
0
lordshin808Author Commented:
Poweruser32: I don't see anywhere on that link that say it applies to Windows 2000.

I'm alittle reluctant to apply a hotfix, when everything seems to be working fine. It just annoying to see all these warnings in my eventviewer. I want to be absolutely sure this hotfix is the solution, before I do anything.

Thanks,
0
poweruser32Commented:
if you check down the end of the page it says applies to as well
0
What were the top attacks of Q1 2018?

The Threat Lab team analyzes data from WatchGuard’s Firebox Feed, internal and partner threat intelligence, and a research honeynet, to provide insightful analysis about the top threats on the Internet. Check out our Q1 2018 report for smart, practical security advice today!

MATTHEW_LCommented:
I didn't see anything about Windows 2000 either.  I can tell you I have had this problem with 2003 and applied the hotfix and it took care of the problem.
0
Hypercat (Deb)Commented:
Try turning off the forwarders completely - you don't absolutely have to have them, and it may resolve the issue.  If it does, you could try contacting your ISP and see if they can give you other DNS servers to try.  I've also seen a comment (on EventID.net) related to this suggesting that it might indicate that your bandwidth is saturated, so you might want to check that out, too.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
SembeeCommented:
I have seen this happen with some firewalls. You might find that even removing the forwarders could mean the problem continues.

Simon.
0
lordshin808Author Commented:
Simon, is there something I could look for on the firewall to test this possibility?
0
SembeeCommented:
Not really - look for any kind of DNS scanning features. You many need to speak to the firewall supplier to find it if they are aware of any issues.

Simon.
0
MATTHEW_LCommented:
Are you using Cisco?  If so they have what they call ip fixup protocol which causes problems for smtp, may be a similar problem for DNS.
0
lordshin808Author Commented:
Simon, I will look for this DNS scanning feature on my firewall.

Matthew, I'm not using a Cisco. It's a Netopia 3546 modem/router/firewall.

Hypercat, turning off the forwarders is not an option. I've tried using different DNS servers from the ISP and still same problem.

let me keep working on this... Thanks guys.
0
MATTHEW_LCommented:
Why can you not turn off forwarders for a test?
0
lordshin808Author Commented:
Matthew: if I turn off the forwarders will Windows 2000 just use the root hint servers to resolve domain names on the Internet, right? I won't have any issues with DNS queries, right?
0
MATTHEW_LCommented:
You will not have any issues resolving dns queries.  Your system will use the root hints, otherwise known as the root dns servers to resolve all dns queries.  It will not break anything.

Give it a try and see what happens.
0
lordshin808Author Commented:
Okay Thanks guys, it looks like turning off the forwarders eliminated the 5504 event ids.

Is it okay if I just stop using the forwarders completely? Or should I try different DNS servers from the ISP? Everytime I try a different DNS server in the forwarders I get these errors.

I thought it was best practice to use forwarders, but if it give these 5504 errors, what are you suppose to do?

I'm awarding the points to Hypercat and Matthew for these suggestions and encouragement.
0
Hypercat (Deb)Commented:
I've run servers with forwarders and without, and I've never seen a great deal of difference performance-wise.  If you do use forwarders, you need to disable recursion to get the most benefit out of it (to prevent reverting to root hints), and I've found that often causes problems and errors.  So, my advice is to just leave it off.
0
lordshin808Author Commented:
Hypercat, thanks alot. Everything's working fine. No more annoying errors. I will just keep the forwarders off.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.