• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 505
  • Last Modified:

no outbound email with MS SBS 2003 & a Dynamic IP & TZO

I really need some guidance here. I have MS SBS 2003 R1. I can send and recieve emails with my hotmail account inside my exchange profile running ol 2007 or 2003. I can also send emails to others on my network. (It's just a small network 1 server, 1desktop & 1 laptop) I have just setup a different user and logoff & onto the other account whern I want to check to see if it send info to people on the inside network.

I am using TZO so that I have a public domain name attached to my server IP.  And I was able to loginto my server from a remote location. The issue is when I'm sending emails from my exchange account to someone outside of my network it doesn't send.
I talked to tzo and they have told me I needed to get their outbound message relay service - so I got that and insatalled it and they said that it looks right on their end from what they can see, but that I would need to have my smtp service point to their server (omr.tzo.com) The problem lies with how to i do that ? I tried to follow the direction from MS Help screens but to no avail it wants me to go to IIS and then right click on the virttual server .... which I don't see.  I'm so confused now .... Can someone please help

Most things are working for me where I'm having issues is with exchange,
0
jploessl
Asked:
jploessl
  • 12
  • 11
  • +1
1 Solution
 
Hypercat (Deb)Commented:
What you need to do is set up an SMTP connector to relay your mail through their server.  Go into the Exchange System Manager, find the Connectors folder, right-click and select New / SMTP Connector.  Take a look at this article, read through it and see if you can understand and follow it:

http://support.microsoft.com/kb/265293/en-us
0
 
jploesslAuthor Commented:
I do have the smtp connector setup I believe ... at least it shows up and looks to be correct.
The document link you referred to me I believe is for exchange server 2003 std & enterprise. And when I was following the steps they are incorrect for SBS server 2003.

Any other Ideas or help will be greatly appreciated
0
 
MATTHEW_LCommented:
Try this for SBS 2003 to configure it to use a smart host.
http://support.microsoft.com/kb/821911
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
jploesslAuthor Commented:
thankyou
that went fine ... although the email didn't go to my hotmail account ... any other suggestions
0
 
MATTHEW_LCommented:
Check message tracking and see what happened with the email.
0
 
SembeeCommented:
As this is SBS you must use the wizard to configure the SMTP connector.
What are you using as a smart host? Your ISP, something else? Does the operator of the smart host require authentication?

Have you looked in the queues to see if the message has actually left your server? It could be lost somewhere in the smart host operators network.

Simon.
0
 
jploesslAuthor Commented:
how do I check the message tracking ?
I also reran the wizard just to make sure I have the bases covered... it still isn't sending the emails.
I'm using TZO's outbound mail relay (omr.tzo.com)
and I'm not sure how to check the message queue
0
 
MATTHEW_LCommented:
In Exchange System manager, tools, then message tracking.  You can search by server, user, time etc, to find that message and see if it was at the very least relayed to the ISP's smart host.

Make sure message tracking is enabled first.  This in the properties of your server in ESM, servers, your server properties, make sure the box for enable message tracking is checked.

Post back the results and what you find in message tracking for that specific email.
0
 
MATTHEW_LCommented:
The queue is also located under Exchange System Manager (ESM), servers, your server, and then click on queues.  See if there are any queues where the number of messages are greater than 0.
0
 
jploesslAuthor Commented:
I turned on the message tracking now.

When I look at the Queue for (omr.tzo.com) smtp connector it shows that there are 10 messages
0
 
MATTHEW_LCommented:
I just gave a shot at using your ISP smart host.  Looks like it requires authentication to relay.

This should help out a bit with configuring Exchange with the authentication settings for relaying through your smart host.
http://msmvps.com/blogs/kwsupport/archive/2005/10/08/69816.aspx
0
 
MATTHEW_LCommented:
You may need to contact your ISP if you are unsure what to use for authentication, but I think that is the issue.
0
 
jploesslAuthor Commented:
My ISP is charter and they don't require authentication, at least I've don't ever remember having to setup authentication ever before.  Or are you thinking about TZO.com and if so they never brought it up to me when I called in to them today a couple of times
0
 
jploesslAuthor Commented:
i'm going to call charter now to see, but they aren't real eager to help non-business users
0
 
jploesslAuthor Commented:
I called charter and they said that they don't require authentication
0
 
MATTHEW_LCommented:
try to telnet to omr.tzo.com

telnet omr.tzo.com
helo host.domain.com
mail from:<user@domain.com>
rcpt to:<user@otherdomain.com>
data

See if you get any errors trying to send.
0
 
jploesslAuthor Commented:
this is the error that I'm getting
C:\>TELNET omr.tzo.com
Connecting To omr.tzo.com...Could not open connection to the host, on port 23: C
onnect failed

C:\>
C:\>
0
 
MATTHEW_LCommented:
sorry,

telnet omr.tzo.com 25

forgot the 25
0
 
jploesslAuthor Commented:


C:\>TELNET omr.tzo.com 25
Connecting To omr.tzo.com...Could not open connection to the host, on port 25: C
onnect failed

C:\>
0
 
jploesslAuthor Commented:
are we stomped yet ? ...
0
 
MATTHEW_LCommented:
Well that is a problem.  I can connect to that mail server on port 25.  Is your ISP possibly blocking smtp to mail servers?  Can you connect to any external email servers?  Any problems with internet connectivity etc?

This is why your queue is stoped up with messages.
0
 
jploesslAuthor Commented:
I can connect to hotmail & yahoo mail accounts. And yes I belive my isp blocks me from having a email server but thats what the outbound email relay servioce is supposed to correct out of port 2525
0
 
MATTHEW_LCommented:
Well there it is.  You are supposed to be using port 2525, I just tried that, and your mailserver is listening on port 2525.  You need to tell Exchange to use port 2525 for outbound mail relay as port 25 is blocked by your ISP.  

In ESM, under servers, your server, protocols, smtp, properties of the default smtp virtual server, delivery tab, outbound connections button at the bottom.

Select the tcp port to be 2525 instead of 25.  See if that takes care of it for you since your ISP is blocking 25, you need to use this instead which that mailserver is listening on for incoming mail.
0
 
jploesslAuthor Commented:
You are a Genius ... Thanks for everything I really appreciate it.
0
 
MATTHEW_LCommented:
No problem, glad you got your email working again.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

  • 12
  • 11
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now