Solved

prevent internal Exchange Server's name from showing up on internet message header of outgoing mail

Posted on 2007-03-23
4
792 Views
Last Modified: 2010-05-18
How can I prevent our internal Exchange Server's name from showing up on internet message header of our outgoing mail?  

We recently implemented a single-server Exchange 2003 organization on our network.  The Exchange Server sits behind a Fortinet firewall device with an external IP, 65.xxx.xxx.48.  Our external MX record (mail.company.com) points to 65.xxx.xxx.49 which is set up as a Virtual IP on the Fortinet that points to our Exchange Server's (mail.company.local) internal address, 192.168.1.20
Any mail sent from our internal network to an exteranl recipient goes out through the firewall.
I noticed in a test message sent to my Comcast email account from my company account that the message header contained the following line:
   Received: from mail.company.local (mail.company.com[65.xxx.xxx.49](untrusted sender))...

Is there a way to prevent the Exchange server's local network name from being avaialble to the receiving mail server?  Could showing the internal server's name be a risk to us?  It seems to me it would be something a spammer would like to know.
0
Comment
Question by:bjordon35
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 10

Accepted Solution

by:
MATTHEW_L earned 125 total points
ID: 18780811
Go into Exchange System Manager, servers, your server, protocols, smtp, properties of smtp virtual server, under delivery tab, advanced button.  Set your FQDN for what you want people to see in banners etc.  This should be its real public FQDN probably should be the same as mx record or a record etc, but this is where you would set mail.company.com rather than mail.company.local.
0
 

Author Comment

by:bjordon35
ID: 18780915
That worked, thank you!

What would the Masquerade Domain field be used for?
0
 
LVL 10

Expert Comment

by:MATTHEW_L
ID: 18781006
This is where you would type the domain name that you are accepting mail for.  The FQDN is the public FQDN of the server so mail.company.com instead of mail.company.local.  The masquerade domain is the public domain name.  Instead of company.local it would be company.com
0
 

Expert Comment

by:mahtab786_dbi
ID: 21735264
The same problem in exchange 2007......how can i remove..
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Marketers need statistics and metrics like everybody else needs oxygen. In this article we explain how to enable marketing campaign statistics for Microsoft Exchange mail.
This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…

737 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question