System Time - SuSe Linux

I have a machine running SuSe Linux 9.0.  I have changed the time on this machine twice...it sticks for a little while (a couple of hours) and then changes back to one hour earlier (darn early Daylight Savings Time change!).

I've changed the time both via command line as root and also through the GUI.  I'm guessing that this machine is going out to the web and getting an updated time from somewhere, but I can't find how to turn that off, if that is, in fact, what's happening.

Any ideas?
biffsmithAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ShineOnCommented:
Did you update the Zones databases and the etc/localtime or did you just manually change the system clock?

If the system is using UTC (as is normal) but displaying local time, if you don't fix your zones databases and etc/localtime to reflect the proper DST, when you change the clock, you're changing its UTC time to be different from reality.

If it is accessing an NTP time source, then it will sync its time back to "reality" it gets from the time source.  Without the  correct offsets in your zones tables, it will change the displayed local time accordingly.

Go to ftp://elsie.nci.nih.gov/pub/ and download the current tzdata tarball, and install it.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ShineOnCommented:
Oh, after you untar it, you use the zic (zone info compiler) to compile the new info into your zones databases.

SuSE Linux 9.0 should be smart enough to link the databases to your local zone setting in /etc

However - since it's SuSE Linux 9 (don't know if it's Enterprise or not, but...) you should check the Novell site.

Here's a link for the official patches for SLES: http://www.novell.com/support/dynamickc.do?externalId=3853518&sliceId=SAL_Public&command=show&forward=nonthreadedKC&kcId=3853518
0
biffsmithAuthor Commented:
Thanks, ShineOn!   I updated my zone info and now the date on my intranet web pages (that are housed on this machine) is correct (they are php pages just using the PHP date command), but when I run the unix date command at the prompt it's showing 1 hour later.  This is bizarre.

Any reason why that is?

0
ShineOnCommented:
Is the date command displaying the correct time zone?

Did you re-establish the symlink to the correct zone in /etc/localtime?

Did you make sure PHP is using the correct time zone?  PHP has its own zone settings, in various places. Only if no other TZ settings are found does PHP do a "magical guess" at the timezone based on the host OS settings.

Check your code for the date_default_timezone_set function.  Check config.php.  Check for a TZ environment variable. Check for a userconfig.php.  Look for date.timezone.  
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.