Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

OWA internal DNS Questions

Posted on 2007-03-23
16
Medium Priority
?
607 Views
Last Modified: 2008-02-01
How do I setup a "friendly" DNS for OWA from inside my Lan...

Currently my users access OWA using: http://servername/exchange

I want to set it up so that while inside the LAN users just have to type OWA in the browser..

I am guessing this is quite easy to do but for some reason, I cannot get it to work..

Thanks
0
Comment
Question by:paadmin
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 10
  • 6
16 Comments
 
LVL 12

Expert Comment

by:Donnie4572
ID: 18782114
I assume you have added

OWA --> internalIPaddress
to your internal dns?

From a client type
nslookup
type
OWA
press enter and see if it returns the ip address
If not then
type
OWA.domainname.com
press enter and see if it returns the ip address

one of these should work if you have added the entry to dns zone.
0
 
LVL 12

Expert Comment

by:Donnie4572
ID: 18782170
If this one works...
OWA.domainname.com
but OWA does not then this is because of a setting on the client.

For example,
for netbios names resolved by the client like OWA the client will add its domain name to the netbios name and request the resolution from dns.

Also,
You can add additional domains as a search suffix.

On the client go to TCP/IP properties click advanced button and the dns tab
you should have the radio button "append primarysuffix..." selected

This will cause the client to:
instead of resolving OWA it will append the domain name and resolve the FQDN OWA.domain.com



0
 
LVL 12

Expert Comment

by:Donnie4572
ID: 18782199
also,

You will need to set the primary suffix of the client.

From my computer properties
choose computer name
click the change button
more button
add your domain name here
For example,
domain.com




0
U.S. Department of Agriculture and Acronis Access

With the new era of mobile computing, smartphones and tablets, wireless communications and cloud services, the USDA sought to take advantage of a mobilized workforce and the blurring lines between personal and corporate computing resources.

 

Author Comment

by:paadmin
ID: 18782717
Donnie4572 thanks for the help..

From NSLOOKUP when I type for owa I get back the ip, server name and name: owa.domainname.local back..

But When I type : http://owa into the browser I get nothing... I am not sure if I have my DNS set up correctly.

I created a CNAME record with Alias of OWA pointing to http://servername/exchange..
Do I need to do anything else in DNS ?

I set my client side settings as suggested above but still no success.. I know this is proably really easy but I just can't figure it out..

Thanks so much for your help,
Liam
0
 
LVL 12

Expert Comment

by:Donnie4572
ID: 18783284
You should remove the cname and create an "A" Host record.
0
 

Author Comment

by:paadmin
ID: 18783287
Do I just create an A recond to the ip address of the server ? A record's will jsut execpt ip address'.. (If I am correct)... My owa address is : http://servername/exchange 
0
 
LVL 12

Expert Comment

by:Donnie4572
ID: 18783292
From DNS MMC expand your domain name "dns zone"
right click your domain name "dns zone"
choose new A host record.
In the name feild put OWA only not FQDN
Enter the IP address
0
 
LVL 12

Expert Comment

by:Donnie4572
ID: 18783315
The new url will be
http:/owa/exchange

If you want to use this url:    http://owa
 or even leave off the http:// and type owa in the address bar

you will need to follow this:

http://support.microsoft.com/kb/319878/

0
 

Author Comment

by:paadmin
ID: 18783332
Hey thanks, we are making progres..

So now when I type: http://owa .. I get an error Microsft CRM (We do use this program) but when i type

http://owa/exchange it works..

Any ideas why CRM is messing with my OWA records ?

Thanks
Liam
0
 
LVL 12

Accepted Solution

by:
Donnie4572 earned 500 total points
ID: 18783374
So you may not be able to use this
http://support.microsoft.com/kb/319878/
This KB allows you to assign the default web site to OWA and it appears that CRM has already been assigned to the Default web site.


0
 

Author Comment

by:paadmin
ID: 18783432
That worked.. Awesome thanks..

One thing i norticed though...

Now when I type: mail.domain.com from outside the domain, I get promted for credentials twice.. But when I enter mai.domina.com/exhcange it works as it alwys did..

I know this is outside the lan but was wondering if this is a simple fix ?

I am going to go ahead and award the point as you answered my questions and fixed my problem

Thanks
Liam
0
 
LVL 12

Expert Comment

by:Donnie4572
ID: 18783493
This is because the default web site has authentication turned on.
Are you using SSL cert?
0
 

Author Comment

by:paadmin
ID: 18783548
I am embarrased to say that we do not have SSL enabled on OWA...That is going to change soon..
0
 
LVL 12

Expert Comment

by:Donnie4572
ID: 18783583
I think you can get a godaddy cert for about 20usd

You could try changing the default web site security to anonymous only.
This way the login security will be set on the exchange virtual directory.
I'm not sure how this will affect CRM.

Also,
Any changes to the permissions should be done with caution because if the permissions get out of sync it could require reinstall of IIS and exchange.
0
 

Author Comment

by:paadmin
ID: 18793722
Hey Donnie, thanks for all of your advise, we are going to leave the permission as they are for now. Users are going to use the original url and they will never know the difference.

OWA from inside is working great using OWA from the broswer so thank you so much for your help...

Have a great week,
Thanks
Liam  
0
 
LVL 12

Expert Comment

by:Donnie4572
ID: 18793853
Good choice
Glad I could help
Donnie
0

Featured Post

Back Up Your Microsoft Windows Server®

Back up all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article will help to fix the below error for MS Exchange server 2010 I. Out Of office not working II. Certificate error "name on the security certificate is invalid or does not match the name of the site" III. Make Internal URLs and External…
This article will help to fix the below errors for MS Exchange Server 2013 I. Certificate error "name on the security certificate is invalid or does not match the name of the site" II. Out of Office not working III. Make Internal URLs and Externa…
To show how to generate a certificate request in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Servers >> Certificates…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question