Solved

Running an executable on one server from a shortcut on another server

Posted on 2007-03-23
5
197 Views
Last Modified: 2010-04-19
I am resubmitting this question because it has become more of an issue now...

I have a 2003 R2 terminal server and I would like to put a shortcut on it that points to an executable on another 2003 R2 server.  When I try to run the program this way I get a message saying I don't have permissions even if I am in as domain admin.  I assume this is a security setting.  Can someone tell me how to allow this?

In addition, I have one set of servers where this works, but it doesn't work on another group of servers on another network.  As a test I have simply been trying to browse to notepad.exe using unc paths logged in as domain admin.  On one network it works, on the other it doesn't.

Help please...
0
Comment
Question by:rwilsonz
  • 2
  • 2
5 Comments
 
LVL 29

Expert Comment

by:Alan Huseyin Kayahan
ID: 18783185
      *You have to take the ownership of the shared folder at the other r2 server in which this executable resides. Also right click the folder and make sure domain admin account has all necessary rights and there is no other implict permision that may affect admin permissions.
       *Also try to reach the administrative share \\server\c$\ and then try to run a program.
      *In terminal services configuration panel, right click terminal server RDP-tcp>properties>permissions and check if admin account has full rights.
0
 

Author Comment

by:rwilsonz
ID: 18783531
Thanks for the response.

As you suggested, I made domain admins the owner of the share and verified that domain admins had full rights and that they propegated down to the actual executable.
I also verified that admins have full rights from terminal services config.

These all seem like the right things, but I still can't run a program, either from the share or the c$ admin share.  Any other thoughts?  Would some machine policy be restricting this?
0
 
LVL 48

Accepted Solution

by:
Jay_Jay70 earned 500 total points
ID: 18789765
you need to add the server to your trusted site in the intranet zone......under internet explorer - tools - security
0
 

Author Comment

by:rwilsonz
ID: 18793461
Bingo!!!  That did it!  Thanks so much.

To be clear... I needed to add the server that had the program I was trying to run into the Local Intranet zone of the server I was trying to run the program from.
0
 
LVL 48

Expert Comment

by:Jay_Jay70
ID: 18796642
no worries!
0

Featured Post

Optimizing Cloud Backup for Low Bandwidth

With cloud storage prices going down a growing number of SMBs start to use it for backup storage. Unfortunately, business data volume rarely fits the average Internet speed. This article provides an overview of main Internet speed challenges and reveals backup best practices.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Mapping Drives using Group policy preferences Are you still using old scripts to map your network drives if so this article will show you how to get away for old scripts and move toward Group Policy Preference for mapping them. First things f…
This article shows how to deploy dynamic backgrounds to computers depending on the aspect ratio of display
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …

863 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

27 Experts available now in Live!

Get 1:1 Help Now