Solved

Mac/Linksys Wireless Problem - Access Control List

Posted on 2007-03-23
19
1,958 Views
Last Modified: 2012-06-27
Hi, I'm using a brand new iMac, trying to connect to a Linksys W/L G router. The wireless works fine, as my PC laptop has no problems connecting. It's using WEP 64 security.

When I try to use the Mac, it sees the wireless network ('linksys') but when you click on it to connect, it gives you an error saying it can't connect as the machine isn't in the access control list... any ideas?

By the way, MAC filtering is disabled on the router.
0
Comment
Question by:mgustavson
  • 5
  • 3
  • 3
  • +4
19 Comments
 
LVL 39

Expert Comment

by:Eoin OSullivan
ID: 18784798
OK .. I've had problems with WEP and WPA and Airport Extreme on my iMac

Can you first try disabling WEP and all security and check if the iMac can connect.
If it works then you may want to try WEP with strict 10 character strings or try WPA.

Alternatively if you want to leave security off and just restict wireless access to the router to the MAC address of your devices as a filter which works well too.
0
 
LVL 53

Expert Comment

by:strung
ID: 18786454
Make sure you re entering the 10 character Hex WEP key from the Mac, and not the Llnksys passphrase (which only works from other LinkSys NICs). If that doesn't work, try putting a $ sign before the WEP key.
0
 
LVL 2

Accepted Solution

by:
joshlamerritt earned 168 total points
ID: 18812877
I've had the same issue with Macs and Linksys routers.  I resolved the issue by upgrading to the latest firmware on the Linksys router.
0
 
LVL 8

Expert Comment

by:Andrew Duffy
ID: 18815995
I wasn't even able to update the firmware on my client's Linksys router, but that's the best way to do it.

There are compatibility issues between PC and Mac WEP standards. Mac supports 40bit and 128bit, not 64bit. If you update the firmware (available from the Help menu in your router's config page) you'll be able to use WPA instead, which is very compatible.
0
 
LVL 53

Expert Comment

by:strung
ID: 18817406
Mac 40 is the same as PC 64. Just different nomenclature.
0
 
LVL 1

Author Comment

by:mgustavson
ID: 18879374
Hey everyone,

I've finally been able to try this again - I really appreciate all the input!

After messing around with different things and being unable to make it work - I simply left it unsecured... Not a good thing to do, I know, but this is a pretty unimportant machine on it's own wireless network.

However, even though it was working fine when I left it, the user has let me know that the same issue has popped up again. I tried all the different ways of entering the key, by the way, when I had the chance - using the hex instead of Linksys passphrase, etc, but no luck.

In fact, it doesn't really prompt you for a passcode at all, it just simply says 'machine is not in the access control list' it never asks for a passcode!

The only way I was able to enter one - if I remember correctly, as this was a couple of days ago - was by going into System Preferences, then into Networks, and in there, setting the default settings up for the AirPort, and that made it work temporarily...

very confusing!
0
 
LVL 8

Expert Comment

by:Andrew Duffy
ID: 18880719
were you able to update the firmware?
0
 
LVL 53

Expert Comment

by:strung
ID: 18881908
The LinkSys passphrase will definitely not ever work. The message you are getting is consistent with there being some sort of MAC address filtering on the LinkSys.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 4

Expert Comment

by:homepup
ID: 18894932
I would hit the reset button on the linksys, and start from scratch. Try with no security and tighten it at each step.

Another trick to try: Enter your WEP key starting with a $
For instance, $abcdef12345678901234567890 for a 26 character hexadecimal password.
0
 
LVL 1

Author Comment

by:mgustavson
ID: 18894951
I know that the LinkSys passphrase won't work - that's LinkSys only. I've been trying the hex versions of that passphrase.

There's definitely no MAC filtering turned on - so that's not an issue. That's why I'm confused about the 'Access Control List' message which definitely seems like a MAC filtering issue.

I haven't updated the firmware yet - I'll try that tomorrow. I'll also try the idea of putting the $ in front of they key... can someone explain why that might work? I'm just curious as I've never heard of that before.

If neither of those steps work I'm going to hard reset the router and start from scratch as per homepup's suggestion.

It's really confusing trying to reconcile LinkSys passcodes with Mac, ie. 40/64/128 bit WEP etc...
0
 
LVL 4

Expert Comment

by:homepup
ID: 18895014
I recall back on OS9, the Mac would assume the WEP key being entered was a passphrase, not hex. In the case of the University I work for, we have no comparable passphrase, hex only. The fix was to enter the hex WEP key preceded by a $, which told the system it was hex, not a passphrase.

I remember reading something once about linksys being a pain and Mac users having to use the old $ trick to get it to work. That's why I have an Apple Airport™ ;)

Worth a shot.
0
 
LVL 4

Expert Comment

by:homepup
ID: 18895018
I'd also recommend going to 128-bit WEP, if you aren't going WPA. At least make the crackerz work for more than a few minutes. :P
0
 
LVL 4

Expert Comment

by:homepup
ID: 18895044
0
 
LVL 1

Author Comment

by:mgustavson
ID: 18895118
Thanks for the tips homepup!

I'm going to try everything I can think of when I'm back at this machine tomorrow - do you have any ideas on what to do if I still can't get it to request a password? Because that's the primary problem - it never lets me enter one! I see the network, click on it to access it, and just get back the access control list error.

So in that scenario, I can never input a password.
0
 
LVL 4

Assisted Solution

by:homepup
homepup earned 166 total points
ID: 18897162
You can goto the Apple in the top right corner, select 'System Preferences'. Then goto Network | Airport. Click configure. Then click the plus sign at the bottom left and when the window pops up, type in the name of the wireless network and select the type of password that you want to enter. You may need to remove your previous connection to the linksys before doing this (click the minus button while having it selected in the list). I also recommend having Airport set to 'by default, join PREFERRED networks'. I've had issues leaving it to Automatic.
0
 
LVL 19

Assisted Solution

by:pheidius
pheidius earned 166 total points
ID: 19082523
note: I just made this same post in another similar thread but here goes;
Well, all the advice above is technically solid. On the other hand, I went round and round with a Dlink and then a Linksys and did all the things suggested. When all was said and done, I still had weak signals and dropped connections even though both the “routers were centrally located and high. I then switched to an old Airport Extreme I had bought for my classroom four years ago and now I have rock solid four bars on my Quad and MBP plus a consistent 54mbs on my pc gaming station and laptop. So, in my experience with all the time I spent troubleshooting this, you are better of buying a used Airport Extreme if you want to save a few bucks or even buy a new one. It is worth it.  While I have read Wep works better, it is relatively insecure. It seems to me, for whatever reason, there is some tiny difference in the protocol for MAC WPA vs. the router drivers that throws things off. I have even experienced this same issue traveling with my MBP at both my brother-in-law’s and my cousin’s houses. Buy an Airport Extreme new or used. If you do, however, keep cracking at it, then I would indeed reset the router. I would then creat a brand new network using your Mac while physically connected to it with an ethernet cable. Once the network is created I found the best thing to do was to click using dhcp with a manual adress on the Mac. Why? I duuno. but this allowed me to get by the can't connect error. but, ultimately, all that did was to give me an inconsistently powered/dropping connection that I finally solved with my old Extreme station.
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

I recently purchased a Bluetooth headset called the Music Jogger (model BSH10). The control buttons on it look like this: One of my goals is to use it as the microphone and speakers for Skype calls. In that respect, it works well. However, I …
DECT technology has become a popular standard for wireless voice communication. DECT devices are not likely to be affected by other electronic devices and signals because they operate in a separate frequency-band.
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…
You have products, that come in variants and want to set different prices for them? Watch this micro tutorial that describes how to configure prices for Magento super attributes. Assigning simple products to configurable: We assigned simple products…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now