Solved tab is missing in IIS v5.1. How do I get the tab to re-appear?

Posted on 2007-03-23
Last Modified: 2012-08-13
My application uses 1.1 framework. I have Win XP Pro with IIS v5.1 set up on the virtual server machine. My development machine has the tab visible and has 1.1.4322 and 2.0.50727 available in the drop-down box on the tab.

The 1.1.4322 framework folder exists on the deployment machine but there is no tab visible in IIS properties for the website. The website main page will load, but only the page .gif images are visible.... there are no controls that load.....I know the virtual directory is set up properly because the main page does load.

I have uninstalled IIS and reinstalled it 3 times on the deployment machine, but this doesn't solve the problem. Do I uninstall the 1.1. framework in the 'add-remove' programs area, and then reinstall the framework?

How do I go about fixing this issue? Thanks....
Question by:jazjef
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
LVL 11

Accepted Solution

dready earned 500 total points
ID: 18783648
The order in which the .net framework and IIS are installed does matter. Normally, you should first install IIS and then the .net framework, else aspx pages wont work. If you installed it the other way around, there is no need to deinstall and reinstall though. The tool aspnet_regiis.exe takes care  of that. In commandwindow, go to the dir where you find the exe and call aspnet_regiis.exe -i

open the command prompt [For windows Xp and greater]
>>cd C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322
>>aspnet_regiis.exe -i

In case you are using any other windows then search the aspnet_regiis.exe file and run this file from the command prompt with -i argument

Hope that solves your problem. Sounds like this one.

Author Comment

ID: 18784191
thanks dready...

I will try your solution out. I was trying the aspnet_regiis.exe -i at the C:\ prompt and getting a message that said it could not be found. According to your answer, I need to be in the proper directory at the C prompt to get it to register.....

I did go to the 1.1.4322 framework  folder in windows explorer and click on the aspnet_regiis.exe file though----I got a brief flash of the dos command window, but this didn't change anything. Here's what I was typing at the C prompt:

C:\aspnet_regiis.exe -i   [Enter]

...but this is wrong isn't it?

Why doesn't it work if I navigate there in windows and click the executable?...

LVL 11

Expert Comment

ID: 18785342
It doesnt work because you are not in the right directory.  And you do have to do it from de command window (Start/run) , it doesnt work with doubleclicking from windows explorer.
Use cd to navigate to the directory where you found it, for example
cd windows
cd blahblah
and the promtp will look like this, pointing to the right directory
and then you type aspnet_regiis.exe -i   [Enter]

must work!

(Sorry, cant remember where it normally is, and am on pc without .net framework, but you did find it so that shouldnt matter).
SharePoint Admin?

Enable Your Employees To Focus On The Core With Intuitive Onscreen Guidance That is With You At The Moment of Need.


Author Comment

ID: 18785756
thanks again dready....

I had a computer here at home with the same specs as the one at work that has the problem. I setup IIS on it last night, copied the project files to a folder, set up the folder as a virtual directory, and ran it.... it re-creates the same problem as the machine at work....yes! far so good....

Then I applied your solution of navigating through dos directories to run the aspnet_regiis.exe -i

Works great!.... yeah!...problem solved.

I will apply your solution on the virutal server when I go in on Monday to work.... if your solution works on the actual machine on Monday then I'll give you the points..... and it looks like it will since it worked on a re-creation/simulation of the problem here at home...

LVL 11

Expert Comment

ID: 18785812
Hey jazjef,

great, glad i could help. I ran into this problem quite a few times at work, and we used to deinstall .net framework and iis and reinstall in the right order, until i 'discovered' aspnet_regiis. Saves so much time.


Author Comment

ID: 18808320
I would like to add that the tab never did show up in IIS, but everything worked just fine. I don't know the requirements to get the tab to show up, but I got the result I wanted... thanks dready

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have developed many web applications with asp & and to add and use a dropdownlist was always a very simple task, but with the new, setting the value is a bit tricky and its not similar to the old traditional method. So in this a…
Today is the age of broadband.  More and more people are going this route determined to experience the web and it’s multitude of services as quickly and painlessly as possible. Coupled with the move to broadband, people are experiencing the web via …
Attackers love to prey on accounts that have privileges. Reducing privileged accounts and protecting privileged accounts therefore is paramount. Users, groups, and service accounts need to be protected to help protect the entire Active Directory …

739 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question