Solved

Open ports on Cisco PIX501

Posted on 2007-03-23
11
508 Views
Last Modified: 2010-05-18
I am trying to troubleshoot a network installation of ACT where I am unable to connect to the database when I'm connected to the domain through vpn access.  ACT Technical Support thinks that I need to open up ports 65100-65200 on our Cisco PIX501.  What comand should I use to enter this in to the config?
0
Comment
Question by:baggio8
  • 5
  • 5
11 Comments
 
LVL 28

Expert Comment

by:batry_boy
ID: 18784378
If you have a VPN connection to the PIX, then you typically aren't filtered based on port.  All IP traffic is typically allowed down a VPN tunnel and you should see behavior similar to being connected directly to the internal network.  Your setup could be unique in that individual ports are filtered when being sent down the VPN tunnel, but I would have to look at the firewall config to determine this.

If you post the entire PIX config, sanitized of course, then I could tell you if there is something in the PIX that needs to be opened up or if it could be something else.
0
 

Author Comment

by:baggio8
ID: 18785576
Thanks for the response:

Building configuration...
: Saved
:
PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password XXXXXXXXXXXX
passwd XXXXXXXXXXXX
hostname XXXXXXXXXXXX
domain-name ciscopix.com
clock timezone EST -5
clock summer-time EDT recurring
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name XXXXXXXXXXXX
name 192.168.78.2 Server
object-group service Service-service-group tcp
  port-object eq ident
  port-object eq https
  port-object eq smtp
  port-object eq www
access-list outside_access_in permit tcp any host XXXXXXXXXXXX object-group Service-service-group log
access-list outside_access_in permit icmp any host XXXXXXXXXXXX echo-reply log
access-list outside_access_in permit tcp any host XXXXXXXXXXXX eq 3389
access-list outside_access_in permit tcp any host XXXXXXXXXXXX eq 4125
access-list outside_access_in permit tcp any host XXXXXXXXXXXX eq 444
access-list inside_outbound_nat0_acl permit ip 192.168.78.0 255.255.255.0 192.168.100.0 255.255.255.0
access-list vpngroup_splitTunnelAcl permit ip 192.168.78.0 255.255.255.0 192.168.100.0 255.255.255.0
access-list inbound permit tcp any interface outside eq 3389
pager lines 24
logging on
logging timestamp
logging monitor informational
logging device-id ipaddress outside
logging host outside XXXXXXXXXXXX
mtu outside 1500
mtu inside 1500
ip address outside XXXXXXXXXXXX 255.255.255.224
ip address inside 192.168.78.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool vpnpool 192.168.100.100-192.168.100.115
pdm location XXXXXXXXXXXX 255.255.255.0 outside
pdm location 192.168.0.2 255.255.255.255 inside
pdm location XXXXXXXXXXXX 255.255.255.255 outside
pdm location XXXXXXXXXXXX 255.255.255.0 outside
pdm location 192.168.100.0 255.255.255.0 outside
pdm location 192.168.78.96 255.255.255.224 outside
pdm location 192.168.78.0 255.255.255.0 inside
pdm location Server 255.255.255.255 inside
pdm location XXXXXXXXXXXX 255.255.255.255 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 192.168.78.0 255.255.255.0 0 0
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) XXXXXXXXXXXX Server dns netmask 255.255.255.255 0 0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 XXXXXXXXXXXX 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server RADIUS (inside) host Server veitsgroupllc timeout 10
aaa-server LOCAL protocol local
aaa authentication ssh console LOCAL
aaa authorization command LOCAL
ntp server XXXXXXXXXXXX source outside
http server enable
http XXXXXXXXXXXX 255.255.255.0 outside
http 0.0.0.0 0.0.0.0 outside
http 192.168.78.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map client authentication LOCAL
crypto map outside_map interface outside
isakmp enable outside
isakmp nat-traversal 20
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup vpngroup address-pool vpnpool
vpngroup vpngroup dns-server Server
vpngroup vpngroup wins-server Server
vpngroup vpngroup default-domain veitsgroup.local
vpngroup vpngroup split-tunnel vpngroup_splitTunnelAcl
vpngroup vpngroup idle-time 1800
vpngroup vpngroup password ********
telnet timeout 5
ssh XXXXXXXXXXXX 255.255.255.0 outside
ssh 0.0.0.0 0.0.0.0 outside
ssh XXXXXXXXXXXX 255.255.255.0 outside
ssh 0.0.0.0 0.0.0.0 inside
ssh timeout 5
management-access outside
console timeout 0
dhcpd lease 3600
dhcpd ping_timeout 750
username XXXXXXXXXXXX
username XXXXXXXXXXXX
username XXXXXXXXXXXX
username XXXXXXXXXXXX
username XXXXXXXXXXXX
username XXXXXXXXXXXX
username XXXXXXXXXXXX
username XXXXXXXXXXXX
username XXXXXXXXXXXX
username XXXXXXXXXXXX
username XXXXXXXXXXXX
username XXXXXXXXXXXX
privilege show level 0 command version
privilege show level 0 command curpriv
privilege show level 3 command pdm
privilege show level 3 command blocks
privilege show level 3 command ssh
privilege configure level 3 command who
privilege show level 3 command isakmp
privilege show level 3 command ipsec
privilege show level 3 command vpdn
privilege show level 3 command local-host
privilege show level 3 command interface
privilege show level 3 command ip
privilege configure level 3 command ping
privilege show level 3 command uauth
privilege configure level 5 mode enable command configure
privilege show level 5 command running-config
privilege show level 5 command privilege
privilege show level 5 command clock
privilege show level 5 command ntp
privilege show level 5 mode configure command logging
privilege show level 5 command fragment
terminal width 80
Cryptochecksum:XXXXXXXXXXXX
: end
[OK]
0
 
LVL 28

Expert Comment

by:batry_boy
ID: 18785624
Your PIX is configured to allow all IP traffic down the VPN tunnel when you are connected to a VPN session.  There are no ports being blocked so I don't think your database connectivity issue is related to the firewall.  You should be able to get to all ports on that server already.

You can always verify this by using a packet sniffer on the server, like Wireshark (formerly Ethereal).
0
 
LVL 28

Expert Comment

by:batry_boy
ID: 18785635
I just happened to think...can you ping the database server while you are in a VPN session?
0
 

Author Comment

by:baggio8
ID: 18785645
Yes, I can ping the server, but I don't think I can ping the remote machine from the server.
0
Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

 

Author Comment

by:baggio8
ID: 18785672
I just tried to ping the remote laptop from the server using the node name, but it timed out.  I did an ipconfig and found the IP address of the laptop.  I was able to ping tha from the servert: 192.168.100.103
I can ping the server from the laptop using the server name or IP address.
0
 
LVL 28

Accepted Solution

by:
batry_boy earned 500 total points
ID: 18785678
OK, so there is no problem with bidirectional traffic flow at an IP level.  That, combined with looking at your PIX config, you should not be blocked at the port level.  So there is some other reason your database is not working.  Opening up ports on your firewall will not solve your problem because there are no ports being blocked during a VPN session.
0
 

Author Comment

by:baggio8
ID: 18785687
Is there anyway to temporarily turn the firewall function off on the PIX for testing purposes?
0
 
LVL 28

Expert Comment

by:batry_boy
ID: 18785906
No.  The closest equivalent to that would be to add a statement such as the follows:

access-list outside_access_in permit ip any any

Meaning all IP traffic from any source to any destination would be permitted.  I don't recommend doing this since it would leave yourself wide open to any traffic from the Internet, but you can always negate that statement once your testing is done by issuing the command:

no access-list outside_access_in permit ip any any
0
 
LVL 32

Expert Comment

by:rsivanandan
ID: 18788405
Looks to me like a fragmentation/MTU issue.

Can you just try this;

1. On the client machine, on programs menu where Cisco VPN client is installed, there is a utility called 'setmtu', use that and set the mtu to 1300 on the client laptop.

Then do a connect and see if that makes any difference.

Cheers,
Rajesh
0
 

Author Comment

by:baggio8
ID: 18832177
Thanks for the responses.  It's not a fragmentation issue and it doesn't appear to be ports either. ACT tech support couldn't figure it out, so I am setting up a offline database that will sync with the server database when the remote client reconnects to the domain. This isn't the initial result that I was looking for, but as a workaround it's probably going to work out even better.
0

Featured Post

Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
Access shared drive during VPN session 9 65
Cisco MAC address finding 5 49
cisco nexus experiance 2 30
Access List 4 14
For a while, I have wanted to connect my HTC Incredible to my corporate network to take advantage of the phone's powerful capabilities. I searched online and came up with varied answers from "it won't work" to super complicated statements that I did…
Use of TCL script on Cisco devices:  - create file and merge it with running configuration to apply configuration changes
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now