Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

How to copy a profile to Samba's default profile for new users

Posted on 2007-03-24
1
Medium Priority
?
452 Views
Last Modified: 2010-03-18
I have an XP pro machine and I have the default profile on that computer perfect and would like this copied to the Linux box so the profile is default.

Basically I have a new Suse 10.2 box, Samba installed, setup as a PDC. When I attach an XP box and add it to the domain the users profile on the XP box now shows as a roaming user. Instead of it using the default profile on the XP box it uses the one on the Linux box I guess, so all of the icons, settings are lost. How can I copy my perfect profile to Samba so it will use it as a default profile ?
0
Comment
Question by:ParanoidOne
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
1 Comment
 
LVL 35

Accepted Solution

by:
ShineOn earned 2000 total points
ID: 18787304
Roaming profiles, eh?

I think the roaming profile when using samba as PDC is stored in the .msprofile directory that should be in each user home directory.  Make sure the .msprofile file has ACL support, which means that /home must be mounted with ACL support...

I'm not sure where the default profile should be, but in the Gentoo document on Samba as PDC, they say to make sure your samba.conf has this section, which implies that's where the default and user profiles are stored:

[profiles]
 path = /var/lib/samba/profiles
 browseable = no
 writeable = yes
 default case = lower
 preserve case = no
 short preserve case = no
 case sensitive = no
 hide files = /desktop.ini/ntuser.ini/NTUSER.*/
 write list = @smbusers @root
 create mask = 0600
 directory mask = 0700
 csc policy = disable

Also, in your XP boxes, using GPEDIT.MSC, make sure your roaming profiles setting, Local Computer Policy / Computer Configuration / Administrative Templates / System / User Profiles
has "Do not check for ownership of Roaming Profile Folders" set to "enabled"  - or -
Change the registry key
HKLM\SOFTWARE\Policies\Microsoft\Windows\System
to add the value "CompatibleRUPSecurity"=dword:00000001

And, if you have problems where your profiles load but don't get saved back to the server, check for the presence of the nvidia video driver roaming profiles bug.



0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
In response to a need for security and privacy, and to continue fostering an environment members can turn to for support, solutions, and education, Experts Exchange has created anonymous question capabilities. This new feature is available to our Pr…

670 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question