Solved

MAC transmit FIFO under-run

Posted on 2007-03-24
6
2,409 Views
Last Modified: 2013-12-01
I've got a Vista Business x64 desktop with a Mavell Yukon ethernet adapter.  I have the latest WHQL drivers from Marvell however my NIC suffers from reoccuring MAC transmit FIFO under-run errors and crashes.  The only way to fix the problem is to reboot or do a repair of the connection, and problem seems to occur more frequently when i'm using remoting into my desktop, it almost never happens when i'm on it, but only after i disconnect.  Is there a driver setting i can change that will eliminate this error?

It generates a system event id of 93 from source yukon64 which i identify as the driver for the NIC.

0
Comment
Question by:maninblac1
6 Comments
 
LVL 10

Expert Comment

by:bbrunning
ID: 18787451
I've got an onboard marvell yukon 10/100/1000 on my mobo that constantly shuts off too unless I disable/re-enable or just reboot.

I solved the problem by buying another PCI network adapter and use that instead. I think the marvells aren't programmed well for vista yet...most likely a driver problem.
0
 
LVL 24

Expert Comment

by:Kenneniah
ID: 18802504
Hmm haven't had any issues with mine (Marvell Yukon 88E8001/8003/8010 PCI Gigabit Ethernet Controller).
I'm just using the built-in Vista drivers, haven't installed anything from Marvell.
0
 
LVL 6

Expert Comment

by:kane77573
ID: 18817444
I would just put a pci NIC in there.
In my personal exp and corp envionment, Marvells are the worst NICs this IT dept has ever seen.
Always have problems with them.
I would personally disable it in the bios and pop a simple PCI nic in
0
 
LVL 9

Author Comment

by:maninblac1
ID: 18948005
It appears that i've identified the source of the problems.  It's a combination of bad drivers(i've updated), and a bad network connection.  Contacted the information fabric here, they report carrier sense errors in the local subnet switch, i had my machine hooked up through a shady passthrough switch (never had any problems with it till now), but it seems like bypassing the switch has resolved the issue.

I'd forgotten that that switch was back there, never thought to check.
0
 
LVL 1

Accepted Solution

by:
Computer101 earned 0 total points
ID: 18970653
PAQed with points refunded (250)

Computer101
EE Admin
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The article will include the best Data Recovery Tools along with their Features, Capabilities, and their Download Links. Hope you’ll enjoy it and will choose the one as required by you.
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

860 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question