Solved

Solaris, Linux Booting Problem

Posted on 2007-03-25
3
310 Views
Last Modified: 2013-12-27
Hi

i have a following config of MY Desktop PC

1 G RAM
3 GHZ P4 Processor
915 GAV Mother Board
15" Colour Monitor
Two HDDs:

160 GB (Ony Windows XP and Windows 2003 Server) (Windows Boot Loader)
80 GB(Solaris And Linux) (Solaris Boot Loader)

so when i change boot sequence from 160 GB HDD to my 80 GB HDD and boot successfully to solaris

but when i try to boot to Linux I get the following Error Or Warning Message:

Biso Bug : Legacy Free FADT Detected but FADT Size (128) Is Incorrect.

this is First Problem OK

The Second Problem i m facing is following

80GB HDD Partition Info

1 Boot Parition (Linux) Primary
2(Solaris) Parimary
3 /(Linux)
4 /home (Linux)
5/tmp(Linux)
6/var(Linux)
7 Swap

So i first installed solaris In the HDD MBR then it takes windows In Its Boot List OK
then i installed Linux and Boot Loader i installed in /boot using First sector of the partition ok
but what happened after installing Linux

When i choose Windows from Solaris Boot option Linux Used to boot using Grub and also from Linux Grub boot loader also I am uable to boot Windows pls help me out how to boot windows from Solaris Boot Loader.




0
Comment
Question by:ANKITJAIN_RHCE
3 Comments
 
LVL 27

Accepted Solution

by:
Nopius earned 500 total points
ID: 18790021
About 1st problem, I read here: http://www.centos.org/modules/newbb/viewtopic.php?topic_id=5046
> I got the same error message, when I changed in my BIOS to "Add Extra Tables for ACPI 2.0 Support" it disappeared.

To answer your second question please copy/paste here the content of this file on Solaris:
1) cat /boot/grub/menu.lst
2) format
then from format output you will see a list of disk like c0t0d0p0 or c0t0d0s2
give us a list of disks on very first prompt (to select disk)
3) prtvtoc /dev/rdsk/????
where ???? is changed to cXtXdXp0 (devices, recognized by Format).

I may just guess that you have first drive (160G) is a hd0 and your second drive (80G) is hd1
Then to boot Windows directly from Solaris' GRUB menu, just add 3 lines like:
title Windows XP
root (hd0,0)
chainloader +1

Also I guess that Solaris' GRUB goes first when booting from HD1.

0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Post Clonezilla image restore issue 6 61
LINUX Field Separators 7 55
NTPD Client Port Usage 12 60
Looking for a program called HoneyMine. 3 60
Using libpcap/Jpcap to capture and send packets on Solaris version (10/11) Library used: 1.      Libpcap (http://www.tcpdump.org) Version 1.2 2.      Jpcap(http://netresearch.ics.uci.edu/kfujii/Jpcap/doc/index.html) Version 0.6 Prerequisite: 1.      GCC …
Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.

685 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question